Bug 38644 - [VIEWING] Text gets damaged if scrolled with "Smooth scroll" on
Summary: [VIEWING] Text gets damaged if scrolled with "Smooth scroll" on
Status: RESOLVED DUPLICATE of bug 58358
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-24 08:00 UTC by uls6502
Modified: 2014-11-04 21:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (234.62 KB, image/png)
2012-09-21 08:31 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description uls6502 2011-06-24 08:00:26 UTC
How to reproduce:
1) Open a document, preferably in read-only mode (so it will be easier).
2) Turn on "smooth scrolling".
3) Use Up and Down keys to scroll the text.

You will see:
Some vertical lines of pixels are duplicated or missing, damaging the text.
Comment 1 Björn Michaelsen 2011-12-23 12:27:06 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:02:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:03:28 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:08:02 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:10:08 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 sasha.libreoffice 2012-09-20 13:40:11 UTC
Looks like video driver problem. Not reproducible in 3.6.1 on Fedora 64 bit
(Was reproducible with 3.2.1 on Mandriva with AMD video in my case)
Changing to WFM
Comment 7 Rainer Bielefeld Retired 2012-09-21 08:18:36 UTC
Very old bug inherited from OOo. 

[Reproducible] with Server Installation of "LibreOffice 3.6.2.1 rc  German UI/ German Locale [Build-ID:  ba822cc] on German WIN7 Home Premium (64bit) 

My PC
64 bit AMD Phenom II X4 955 Processor 3.2 GHz, 4GB RAM, 
Graphic Card: NVIDIA GeForce GT 430, Monitor HANNS-G HL225DBB 1920 x 1080 

I think we should already have a bug where I also have been involved, but I can't find it. Can someone help to find it (if it exists)?
Comment 8 sasha.libreoffice 2012-09-21 08:27:24 UTC
Bug 38067, Bug 36391, Bug 43498
Comment 9 Rainer Bielefeld Retired 2012-09-21 08:31:59 UTC
Created attachment 67481 [details]
Screenshot

@sasha:
Please do not modify Status to WORKSFORME only because you were not able to reproduce a bug with a single quick test. Please use similar criteria to those you find on <https://bugs.freedesktop.org/page.cgi?id=fields.html#status>, what means although intensive attempts it has been impossible to reproduce the bug.
Comment 10 Rainer Bielefeld Retired 2012-09-21 08:52:45 UTC
thx, I think "Bug 43498 - gtk3 VCL plugin is badly broken (copy/paste fails, graphical corruption on scrolling)" is the one I remembered. That one might be related, but I have no idea what a "gtk3 VCL" might be.

And Strange, I tested some different versions and was not able to reproduce with OOo 1.1.5, LibO 3.3.3, 3.4.5, 3.5.1. So I think we should return to user's Version.

I seems this one is a little tricky
Comment 11 Zeki Bildirici 2013-09-30 15:21:47 UTC
(In reply to comment #10)
> thx, I think "Bug 43498 - gtk3 VCL plugin is badly broken (copy/paste fails,
> graphical corruption on scrolling)" is the one I remembered. That one might
> be related, but I have no idea what a "gtk3 VCL" might be.
> 
> And Strange, I tested some different versions and was not able to reproduce
> with OOo 1.1.5, LibO 3.3.3, 3.4.5, 3.5.1. So I think we should return to
> user's Version.
> 
> I seems this one is a little tricky

Hi,

Any progress or have you tried with recent versions of LibreOffice?

Best regards,
Zeki
Comment 12 retired 2014-06-27 20:47:06 UTC
NEEDINFO as of Comment 11.

Please let us know if this still happens with LO 4.3RC1 http://www.libreoffice.org/download/pre-releases/

Which OS is this happening on?

Where is "smooth scrolling" activated exactly?

Since one of the two bugs linked under "See Also" is closed as "not reproducible" and so far no one has been able to reproduce this, setting to worksforme.

Should this persist for anybody, make sure to reopen and provide a screencast illustrating the issue happening. Thanks :)
Comment 13 Adolfo Jayme 2014-07-03 10:32:52 UTC
(In reply to comment #12)
> Which OS is this happening on?

You see in the attached screenshot that is Windows

> Where is "smooth scrolling" activated exactly?

Googled it for you: https://help.libreoffice.org/Common/View_1#Smooth_scroll

> Since one of the two bugs linked under "See Also" is closed as "not
> reproducible"

That is not a reason to close things. Sigh.
Comment 14 V Stuart Foote 2014-11-04 21:15:05 UTC
The original poster has never been heard from. 
Some useful information and postings are here, rather than invalid, as a little QA housekeeping setting resolved duplicate of active issue bug 58358

*** This bug has been marked as a duplicate of bug 58358 ***