Bug Hunting Session
Bug 39028 - Add auto-update based on user preferences
Summary: Add auto-update based on user preferences
Status: RESOLVED DUPLICATE of bug 68274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 45609 78695 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-07-07 02:26 UTC by Gabriele Castagneti
Modified: 2016-02-10 13:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Castagneti 2011-07-07 02:26:38 UTC
You want to update to the latest Libò version.

Step you do on Windows:
1. Download 188MB
2. Uninstall the existent Libò installation
3. Install the new version
Time used: at least 1h (download + uninstall + install)

My suggestion:
1. During the first installation, user selects its preferences about upgrading:
   - QA: Beta user
   - QA: RC user
   - Real-life test
   - Production environment
   - Industrial enviroment
2. User can also customize the interaction:
   [] Check automatically
   [] Download automatically
   [] Install automatically
3. Libò looks for new version on Libò website, based on user's installation preferences (Beta/RC/Release).
4. If there are updates available, Libò does what user has selected.
5. If user wants, Libò downloads only the different files and NOT all installation.
6. Installation...
7. Libò updated!
Comment 1 Björn Michaelsen 2011-12-23 12:29:12 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 vitriol 2012-02-04 02:51:11 UTC
*** Bug 45609 has been marked as a duplicate of this bug. ***
Comment 3 Shahar Or 2012-02-09 10:03:46 UTC
As much as I don't like Windows OS, this would get the latest version on those machines.
Comment 4 sophie 2014-05-26 14:54:04 UTC
*** Bug 78695 has been marked as a duplicate of this bug. ***
Comment 5 Juha 2014-10-22 09:25:24 UTC
I support this! This would ensure that everyone has the latest version running, even non-tech savvy users that don't realize to update nor it's benefits. Some schools have LibreOffice also and usually it's not possible to download and install it's latest version without admin rights. Built-in updating system should work even without admin rights.

For example, Mozilla Firefox checks periodically updates for the latest version and updates itself automatically. Even user without admin rights can check and update Firefox to it's latest version. Please, could LibreOffice has the same?

I also think it would be more meaningful to LibreOffice devs to continue working with Libre if they know that ALL LibreOffice users would benefit for their latest contributions, not just them who realize to update (or are able to do it by having admin rights).
Comment 6 Shahar Or 2016-02-10 13:23:25 UTC
Is this solved by #68274?

*** This bug has been marked as a duplicate of bug 68274 ***