Bug Hunting Session
Bug 39805 - Hebrew nikud not represented properly (Windows specific)
Summary: Hebrew nikud not represented properly (Windows specific)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 48732 (view as bug list)
Depends on: HarfBuzz
Blocks: Font-Rendering RTL-Hebrew
  Show dependency treegraph
 
Reported: 2011-08-03 08:33 UTC by Jonathan Allen
Modified: 2017-10-04 20:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LOfault.odt (8.87 KB, application/vnd.oasis.opendocument.text)
2012-03-02 09:30 UTC, Jonathan Allen
Details
LOshouldbe.GIF (29.72 KB, image/gif)
2012-03-02 09:30 UTC, Jonathan Allen
Details
LOfault.GIF (48.01 KB, image/gif)
2012-03-02 09:30 UTC, Jonathan Allen
Details
experiments with copy-paste to Calc 3.5.0 on Windows XP 32 bit (14.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-03 00:52 UTC, sasha.libreoffice
Details
file created in Word 2007 by copy-paste correct parts of text (5.10 KB, application/vnd.oasis.opendocument.text)
2012-03-03 01:17 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Allen 2011-08-03 08:33:13 UTC
Hebrew text cut'n'pasted from a Hebrew word processor (such as DavkaWriter) doesn't get the nikud (pointing) correct if more than one accent applies to a letter.

The problem manifests if a vowel is applied to a letter that already has a dagesh in it.  Vowels normally appear under or over, but in the same letter space as, the consonant letter which they follow (pronunciation-wise).  Type a lamed with a patakh and the patakh will appear as a short horizontal line under the lamed.  However, type a lamed with a dagesh (a dot in the middle of the letter) and then type the patakh and the patakh goes to the left of the lamed, widening the letter space by the width of the vowel mark.  The cursor moves over both as if they are single character, but the visual appearance looks as if a space with the vowel point has been inserted after the consonant letter.

This is a major issue for me, since I use entirely pointed Hebrew texts in mainly English documents.  The same problem also exists in OpenOffice 3.3.0, so presumably dates from before the code branch.  I don't remember it happenning in OpenOffice 2.4
Comment 1 Björn Michaelsen 2011-12-23 12:27:01 UTC Comment hidden (obsolete)
Comment 2 Jonathan Allen 2012-01-22 11:00:49 UTC
Bjoern,

> https://bugs.freedesktop.org/show_bug.cgi?id=39805
> 
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.

I have tried several times, but can't install the 3.5.0 beta-2 file. It
starts the install process (Windows), then tells me that I have to exit
the 3.5 QuickStart program before continuing.  I removed 3.4 but that
made no difference.

What now?

Jonathan
Comment 3 sasha.libreoffice 2012-03-01 05:36:07 UTC
Created attachment 57933 [details]
LOfault.odt

> I have tried several times, but can't install the 3.5.0 beta-2 file ...
try to reboot before installation.

Thanks for bugreport
Please, verify: in last version of LibreOffice problem remains?
Comment 4 Jonathan Allen 2012-03-02 09:30:32 UTC
Friends,

> --- Comment #1 from Björn Michaelsen <bjoern.michaelsen@canonical.com> 2011-12-23 12:27:01 PST ---
> [This is an automated message.]
> This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
> started right out as NEW without ever being explicitly confirmed. The bug is
> changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
> to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2
> prereleases.

Sorry for the delay - I had (a) too much work to do (b) problems getting
the betas to load.  The problem persists in the 3.5.0 production down that
I just downloaded and installed.  Attached are three small files:

   1. the LibreOffice file with the Hebrew characters pasted in

   2. a screenshot showing what the characters should look like as they
      do in DavkaWriter, the Hebrew W/P we use

   3. a screenshot showing what LibreOffice does with the text

Jonathan
Comment 5 Jonathan Allen 2012-03-02 09:30:34 UTC
Created attachment 57934 [details]
LOshouldbe.GIF
Comment 6 Jonathan Allen 2012-03-02 09:30:34 UTC
Created attachment 57935 [details]
LOfault.GIF
Comment 7 sasha.libreoffice 2012-03-03 00:40:25 UTC
Thanks for attachments.
This is Windows specific problem
Reproducible in 3.4.3 and 3.5.0 beta 3 on Windows XP 32 bit
Reproduced in all modules of LibreOffice
Reproduced in Word and Excel 2003, Firefox, Inkscape by copy-paste text from Writer
Reproduced in Word by saving as doc file

What is interesting in 3.5.0: when copy-paste from Writer to Calc using double click of cell in Calc before placing or placing cursor in Formula bar, text looks correctly. If paste into Calc just by press Ctrl-V, text looks wrong. And after this pastes wrong by all variants of pasting. But if save such experiments in Calc as ods file, close office completely, open file by Calc 3.5.0 again, then text in cells looks correct.
If open this file by Calc 3.4.3, it crashes on Windows
Comment 8 sasha.libreoffice 2012-03-03 00:52:41 UTC
Created attachment 57956 [details]
experiments with copy-paste to Calc 3.5.0 on Windows XP 32 bit
Comment 9 sasha.libreoffice 2012-03-03 01:02:11 UTC
Experiments on another comp with Windows XP 32 bit
Open attached ods file with Calc 3.4.3 -- crash
Open it with Word 2007 -- opens as text document where first 2 occurenes of text is correct.
Copy-paste right (looking ok) occurrence of text from Word 2007 to Firefox -- looks wrong
The same to Word 2003 -- looks ok
The same to Writer 3.4.3 -- immediately crashes
Open attached ods file with Excel 2007 -- all occurenes of text looks wrong
Comment 10 sasha.libreoffice 2012-03-03 01:17:58 UTC
Created attachment 57957 [details]
file created in Word 2007 by copy-paste correct parts of text
Comment 11 sasha.libreoffice 2012-03-03 02:22:33 UTC
After some experiment I have determined: if delete this from document file:
 style:font-name-complex="Lucida Sans Unicode"
then on Windows document becomes with wrong character appearance
Comment 12 sasha.libreoffice 2012-03-03 02:25:30 UTC
@ Michael
Please, take look at this bug. 
IMHO not enough of one element in odt file, in result looks wrong on Windows
Comment 13 Urmas 2013-03-13 05:36:44 UTC
Apparently this is a problem with precomposed characters and legacy Hebrew fonts. All modern fonts display that string properly. Decomposed sequences like Sin + Shin dot + Dagesh + Patach look good with any font.
Comment 14 QA Administrators 2015-04-19 03:21:09 UTC Comment hidden (obsolete)
Comment 15 Jonathan Allen 2015-04-19 17:12:31 UTC
As requested, I have tested this again with the latest LO 4.4.2 on Win XP 32.  It still has the same problems: if one hebrew consonant has more than one addition, a dagesh and a vowel, then the vowel appears in a pseudo-space after the character and all the following text is moved along to the left.
Comment 16 Jonathan Allen 2015-04-19 17:15:05 UTC
Sorry to use another comment slot, but I should add that the problem manifests in exactly the same way in OOo, both before and after the split.
Comment 17 Roeland 2016-08-28 19:09:56 UTC
*** Bug 48732 has been marked as a duplicate of this bug. ***
Comment 18 Lior Kaplan 2016-11-07 08:28:25 UTC
@khaledhosny, you've marked this bug as resolved. Can you add why - a commit was made or a comment by someone confirming the fix ( I couldn't find one).
Comment 19 Khaled Hosny 2016-11-07 09:01:59 UTC
This is fixed by work in bug 89870, it can be verified with the daily builds.