Bug Hunting Session
Bug 48732 - Hebrew Nikud still not represented properly
Summary: Hebrew Nikud still not represented properly
Status: RESOLVED DUPLICATE of bug 39805
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering RTL-Hebrew
  Show dependency treegraph
 
Reported: 2012-04-15 06:11 UTC by Jonathan Allen
Modified: 2017-10-02 11:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of text in Davkawriter (GIF) (54.89 KB, image/gif)
2012-04-15 06:11 UTC, Jonathan Allen
Details
Screenshot of text in LibreOffice Writer 3.5.2 (GIF) (28.82 KB, image/gif)
2012-04-15 06:12 UTC, Jonathan Allen
Details
Saved text from LibreOffice 3.5.2 (ODT) (9.40 KB, application/vnd.oasis.opendocument.text)
2012-04-15 06:13 UTC, Jonathan Allen
Details
Screenshot of your file on Win Vista SP2 (34.86 KB, image/gif)
2012-04-26 02:21 UTC, Erwan
Details
win7 (sp1) with 4.0.1.2 (57.94 KB, image/png)
2013-03-19 21:33 UTC, Lior Kaplan
Details
Windows XP SP3, LibreOffice 4.0.1.2 (247.12 KB, image/png)
2013-03-20 12:36 UTC, Boaz Dodin
Details
Windows XP (the font with OpenType tables) (56.36 KB, image/png)
2013-08-04 14:24 UTC, Maxim Monastirsky
Details
Windows 7 (the font without OpenType tables) (86.58 KB, image/png)
2013-08-04 14:25 UTC, Maxim Monastirsky
Details
Three fonts (David, Frank Ruel, Vilna) showing problem (44.36 KB, image/gif)
2015-07-29 10:59 UTC, Jonathan Allen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Allen 2012-04-15 06:11:43 UTC
Created attachment 60012 [details]
Screenshot of text in Davkawriter (GIF)

The situation with Hebrew nikud may have improved slightly with 3.5.2 over the original report in 3.4.2 -- it gets one of them right, but still fails with a number of other examples.

The first attachment (screenshot) shows the text as it should be in DavkaWriter, a proprietory Hebrew/English WP.  The second attachment (screenshot) shows the text when pasted into LO-writer 3.5.2  The third attachment (ODT) is the saved file from LO 3.5.2

Reading from right to left, the first word is OK.

The second word looks correct, but I;m not convinced: it has both a dagesh (dot) in the centre of the second letter and a holem (dot) vowel at its top left corner.  It is unclear whether the vowel is in the consonant space correctly or not.

The third word is clearly incorrect: the present of a dagesh (dot) in the first consonant has displaced the patakh (dash) vowel from under the first letter to the left where is has created a non-accessible space after the first letter.

The fourth word is again incorrect, as the presence of the dagesh (dot) in the second letter has displaced the sh'va (double dot) vowel to the left and created another non-accessible space in the word.
Comment 1 Jonathan Allen 2012-04-15 06:12:36 UTC
Created attachment 60013 [details]
Screenshot of text in LibreOffice Writer 3.5.2 (GIF)
Comment 2 Jonathan Allen 2012-04-15 06:13:42 UTC
Created attachment 60014 [details]
Saved text from LibreOffice 3.5.2 (ODT)
Comment 3 Erwan 2012-04-26 02:21:37 UTC
Created attachment 60606 [details]
Screenshot of your file on Win Vista SP2
Comment 4 Erwan 2012-04-26 02:24:10 UTC
I also have problems with pointed Hebrew inserted in LTR text (French or English or Italian) - quite often it's correct on screen but bugged on printing and PDF exporting (but OK on .ps printing !)

I've opened your file on my computer and it's OK, cf screenshot. As far as I understand from your screenshot, you're running Win XP. I've read that XP, Vista and Seven use different versions of Uniscribe, the Microsoft DLL used for rendering complex uniscribe text. Maybe the bug is related to the way LibreOffice "talks" with the Uniscribe DLL.
Comment 5 Jonathan Allen 2012-04-26 03:00:50 UTC
Erwan,

> I also have problems with pointed Hebrew inserted in LTR text (French or
> English or Italian) - quite often it's correct on screen but bugged on printing
> and PDF exporting (but OK on .ps printing !)

Yes, I too have noticed significant issues with printing from both OO and LO
in a Windows environment in exactly the way you describe.  In my case, it is
usually with numbered lists: on-screen they look fine, but are always mis-
spaced on printing directly but are usually correct with PDF export.

> I've opened your file on my computer and it's OK, cf screenshot. As far as I
> understand from your screenshot, you're running Win XP. I've read that XP,
> Vista and Seven use different versions of Uniscribe, the Microsoft DLL used for
> rendering complex uniscribe text. Maybe the bug is related to the way
> LibreOffice "talks" with the Uniscribe DLL.

Yes, I confirm that the text is exactly right on your screenshot.  Sadly,
since I am stuck with the Win XP laptop, I still need a fix for this ...

Jonathan
Comment 6 Lior Kaplan 2012-11-10 16:12:46 UTC
So it seems that this problem reproducible only on Windows XP.
Comment 7 Boaz Dodin 2013-03-19 12:01:09 UTC
(In reply to comment #2)
> Created attachment 60014 [details]
> Saved text from LibreOffice 3.5.2 (ODT)

Confirmed on:
Windows XP SP3, LibreOffice 4.0.1.2
Comment 8 Lior Kaplan 2013-03-19 21:33:12 UTC
Created attachment 76779 [details]
win7 (sp1) with 4.0.1.2

@boaz - Could you add a screenshot ? My tests looks OK (see attached file).
Comment 9 Boaz Dodin 2013-03-20 12:36:20 UTC
Created attachment 76813 [details]
Windows XP SP3, LibreOffice 4.0.1.2

@ Lior - attached screenshot.
Comment 10 Maxim Monastirsky 2013-08-01 10:13:25 UTC
(In reply to comment #4)
> I also have problems with pointed Hebrew inserted in LTR text (French or
> English or Italian) - quite often it's correct on screen but bugged on
> printing and PDF exporting (but OK on .ps printing !)
> 
> I've opened your file on my computer and it's OK, cf screenshot. As far as I
> understand from your screenshot, you're running Win XP. I've read that XP,
> Vista and Seven use different versions of Uniscribe, the Microsoft DLL used
> for rendering complex uniscribe text. Maybe the bug is related to the way
> LibreOffice "talks" with the Uniscribe DLL.

There is one more difference between WinXP and Vista\W7: The font 'David' that was shipped with WinXP DOESN'T have any OpenType features, while the version that was shipped with Vista\W7 DOES. So more testing needed with other fonts that known to have OpenType features.
Comment 11 Maxim Monastirsky 2013-08-04 14:22:58 UTC
As I thought, this bug caused by the absence of OpenType tables from the font 'David' that was shipped with Windows XP, and has nothing to do with Windows (or UniScribe) versions. So I'm removing the mention of 'Windows XP' from the summary.

Here's the proof:
(I didn't want to experiment with the font 'David' itself, because the EULA forbids copying or altering)

I took the font 'David CLM' (from the latest Culmus release) which do have OpenType features, and installed it as-is on Windows XP. Then I opened your document, and changed the font to 'David CLM'. The result is that the Nikud sits perfectly below the letters.

Next I opened 'David CLM' in FontForge, and resaved it without OpenType features. Then I installed this modified version on Windows 7, and changed the font of your document to that. The result is a reproduction of the bug on Windows 7. (See screenshots below)

Anyway I don't see what we can do in order to solve this bug, other than stop using UniScribe and use ICU\HarfBuzz\whatever we using on other platforms, and hope that their heuristics are better than in UniScribe (or write a patch for them). (BTW this will solve several other bugs in LO's UniScribe interface, some of them related to Hebrew.)
Comment 12 Maxim Monastirsky 2013-08-04 14:24:31 UTC
Created attachment 83613 [details]
Windows XP (the font with OpenType tables)
Comment 13 Maxim Monastirsky 2013-08-04 14:25:13 UTC
Created attachment 83614 [details]
Windows 7 (the font without OpenType tables)
Comment 14 Julien Nabet 2014-06-22 12:24:01 UTC
Any update with recent LO version? Indeed, ICU has been updated but perhaps other commits would have helped here.

(BTW, I'm running "make check" with last Harfbuzz version 0.9.29)
Comment 15 QA Administrators 2015-07-18 17:44:04 UTC Comment hidden (obsolete)
Comment 16 Jonathan Allen 2015-07-29 10:54:15 UTC
Tested today in (my) latest LO.  Still very much present.  I have tried it with three of the fonts that Davka provide - David, FrankRuel and Vilna and they all still manifest exactly the same problem.

LO:
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: en_GB

Platform: Win XP, SP3
Comment 17 Jonathan Allen 2015-07-29 10:59:42 UTC
Created attachment 117512 [details]
Three fonts (David, Frank Ruel, Vilna) showing problem

New screenshot showing bug in 4.4.3  Fonts are, in order, David, FrankRuel and Vilna.
Comment 18 Roeland 2016-08-17 19:20:35 UTC
Isn't this a duplicate of Bug 39805?
Comment 19 Roeland 2016-08-28 19:09:56 UTC

*** This bug has been marked as a duplicate of bug 39805 ***