Bug Hunting Session
Bug 39963 - Presentation: .ppsx not associated to LibO
Summary: Presentation: .ppsx not associated to LibO
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-09 14:31 UTC by Andres Sanchez
Modified: 2012-04-12 03:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Results from test prompted by Tor (109.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-08-25 11:03 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andres Sanchez 2011-08-09 14:31:01 UTC
The file association for LibreOffice 3.4.2 not work in this version over Windows Systems, but over Linux this work fine.
Comment 1 Rainer Bielefeld Retired 2011-08-09 23:36:47 UTC
I can confirm the effect with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]", but I can't tell whether it's a bug. May be the difference is intended, for Linux there is no PowerPoint or PowerPointViewer?

Also .ppt, .pptx, .pptm, .pot, .potx, .potm are not associated to LibO (although those document types are listed in the File-Open dialog), but to "MS PowerPointViewer" on my PC.

After the PP-Viewer I also installed OOo 3.4, what also did not associate to OOo

@Andres Sanchez
What's your WIN version?

@Thorsten
Any Idea what might be intended?
Comment 2 Andres Sanchez 2011-08-10 04:18:53 UTC
(In reply to comment #1)
> I can confirm the effect with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit)
> German UI [OOO340m1 (Build:203)]", but I can't tell whether it's a bug. May be
> the difference is intended, for Linux there is no PowerPoint or
> PowerPointViewer?
> 
> Also .ppt, .pptx, .pptm, .pot, .potx, .potm are not associated to LibO
> (although those document types are listed in the File-Open dialog), but to "MS
> PowerPointViewer" on my PC.
> 
> After the PP-Viewer I also installed OOo 3.4, what also did not associate to
> OOo
> 
> @Andres Sanchez
> What's your WIN version?
> 
> @Thorsten
> Any Idea what might be intended?

I'm working over Windows XP Pro 32 Bit, and my linux Arch.
Comment 3 Thorsten Behrens (CIB) 2011-08-15 08:27:42 UTC
This should be configurable from the installer UI - just look into the custom install. Default seems to be to not touch any existing registration for those file types (which appears sensible to me).
Comment 4 Rainer Bielefeld Retired 2011-08-18 22:11:53 UTC
(In reply to comment #3)
> This should be configurable from the installer UI - just look into the custom
> install. 

No! During installation you see 3 Checkboxes for  "Open OWRD/EXCEL/Powerpoint documents with LibO". I checked them all (as everytimes), for PP only .pps will be associated to LibO. Others remain associated to MS-PP-Viewer, .ppsx to no program at all
Comment 5 Rainer Bielefeld Retired 2011-08-18 22:14:07 UTC
Thorsten:
You took this one, so I assign to you for now. Please feel free to reassign to an other developer if it’s not your area. Please set Status to ASSIGNED if you accept this Bug.
Comment 6 Thorsten Behrens (CIB) 2011-08-19 01:36:16 UTC
Ah right, thanks for checking, Rainer -> accepting the bug.
Comment 7 Rainer Bielefeld Retired 2011-08-24 02:13:02 UTC
@Thorsten: Can you please also check "Bug 40340 - Powerpoint files open with Draw in MS-Explorer", "Bug 40248 - CONFIGURATION: File Type association broken for RTF", It seems we have a more general problem here.
Comment 8 Thorsten Behrens (CIB) 2011-08-25 00:20:17 UTC
Tor, any chance you could look into this?
Comment 9 Don't use this account, use tml@iki.fi 2011-08-25 00:32:33 UTC
OK
Comment 10 Don't use this account, use tml@iki.fi 2011-08-25 01:12:07 UTC
Please be more specific and tell exactly which file extensions you expected to be associated with LibreOffice, but weren't. Also tell what application, if any, they were associated with before installing LibreOffice, and whether that changed at all after the installation.

A useful way is to run the commands assoc and ftype, redirecting output to a file, before and after installation. For instance like this:

C:\> assoc >assoc.1.txt
C:\> ftype >ftype.1.txt
... install LibreOffice
C:\> assoc >assoc.2.txt
C:\> ftype >ftype.2.txt

Then check the differences between the 1 and 2 files. Attach them in a bug report if necessary.

When I installed 3.4.3rc2 in a "clean" (virtual) machine, all of .ppt, .pptx, .pptm, .pot, .potx and .potm were associated with LibreOffice, showed up with LibreOffice icons in Explorer, and LibreOffice did open such files when double-clicking on them. (OK, so I tested only that .ppt, .pptx, .potm and .pptm opened.)

So, you need to give a lot more instructions how to reproduce this. Is it essential that some other application, like "MS PowerPointViewer" is installed first for the problem to show up?
Comment 11 Don't use this account, use tml@iki.fi 2011-08-25 01:34:38 UTC
OK, so the .ppsx extension mentioned in the title of this bug does not get associated with LibreOffice. I have no idea whether LibreOffice even is capable of handling such documents. 

The extension .pps does get assocated, though, and indeed double-clicking such a document opens it showing full-screen in Impress.

If Microsoft PowerPoint Viewer is installed before installing LibreOffice 3.4.3rc2, I must choose a "custom" installation and select the toggle box forcing it to associate itself with PowePoint documents. Otherwise it leaves the existing association (for PowerPoint Viewer) intact. This is as intended to the best of my knowledge.
Comment 12 Rainer Bielefeld Retired 2011-08-25 02:09:55 UTC
(In reply to comment #11)
>  I have no idea whether LibreOffice even is capable
> of handling such documents. 

At least it's in the "open Document" file type list.

> 
> ... and select the toggle box
> forcing it to associate itself with PowePoint documents. Otherwise it leaves
> the existing association (for PowerPoint Viewer) intact. 

If that really woks for you that would not be in accordance with my results. I did exactly that (checked all boxes for MS documents) and pps. remained the only LibO associated file. I also see other problems (.rtf ist not associated to LibO), and I read similar bugs and comments in mailing lists. The association currently seems to work a little random controlled.

I will try to contribute some more info, but currently most of the problem does no longer exist. After Installation of 3.4.3RC1 PP documents (except .ppsx) now are associated, please compare with my results from Comment 1. I should mention that for my comment 1 test I only created empty text documents with PowerPoint name extensions and checked the icons in WIN explorer.
Comment 13 Rainer Bielefeld Retired 2011-08-25 11:03:24 UTC
Created attachment 50572 [details]
Results from test prompted by Tor

No more strange effects, my observation that association of more Powerpoint document types has been broken seems to have been a slip, may be caused by my lots of upgrades, parallel installations (Master, ...).All Parallel installations have been done due to manual in the Wiki.
Comment 14 Rainer Bielefeld Retired 2011-08-25 11:04:59 UTC
@Radek:
Is .ppsx planned to be associated?
Comment 15 Don't use this account, use tml@iki.fi 2011-08-25 23:21:00 UTC
I added the .ppsx association in one location in master yesterday, and once I have a master build and can verify that it works I will ask to get it cherry-picked into the 3.4 branch.

Anyway, it is quite trivial of course to associate file types (extensions) yourself with the application of your choice. Especially in those legendary "enterprise" deployments sysadmins can do such things in their sleep. LibrOffice does open .ppsx files fine, it seems. It is just the association that is missing.
Comment 16 Andras Timar 2011-11-24 01:52:54 UTC
Tor's patch works as expected. I cherry picked it into libreoffice-3-4, too.
Comment 17 Björn Michaelsen 2011-12-23 13:23:03 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 18 sasha.libreoffice 2012-03-29 03:01:19 UTC
Problem reproduced in 3.5.1, upgraded from 3.4.3 on Windows XP 32 bit
Changing status to reopened
Comment 19 Andras Timar 2012-04-12 03:11:20 UTC
(In reply to comment #18)
> Problem reproduced in 3.5.1, upgraded from 3.4.3 on Windows XP 32 bit
> Changing status to reopened

When you upgrade, feature set and settings are taken from the old version. The .ppsx association bug is fixed in the 3.5 code line.