Bug 40457 - Place captions above tables by default
Summary: Place captions above tables by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other All
: medium enhancement
Assignee: Vikas Mahato
URL: http://nabble.documentfoundation.org/...
Whiteboard: target:6.1.0
Keywords: difficultyBeginner, easyHack, skillDesign
Depends on:
Blocks: a11y-Windows Caption
  Show dependency treegraph
 
Reported: 2011-08-29 06:10 UTC by Christophe Strobbe
Modified: 2019-05-22 20:01 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Greyed-out position menu (66.98 KB, image/png)
2013-05-27 00:37 UTC, stragu
Details
Works in LODev 4.0.4 pull 2013-05-26 (166.51 KB, image/jpeg)
2013-05-27 01:47 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Strobbe 2011-08-29 06:10:38 UTC
When adding a caption to a table in Writer, the current behaviour is as follows:
1. Create a table;
2. Right-click on the table or press Shit+F10 to open its context menu and select "Caption..."
3. The default value for "Position" is "Below".

The desired behaviour is:
1. Create a table;
2. Right-click on the table or press Shit+F10 to open its context menu and select "Caption..."
3. The default value for "Position" is "Above".

The reason for this is accessibility for users with disabilities, especially
blind users (who typically use a screen reader) and other users of
text-to-speech software (e.g. some users with dyslexia). A sighted user can
easily locate a caption visually when it is below the table (if the table is short), but when using text-to-speech software, users read from top to bottom and encounter the table before the caption. It does not make much sense to hear the announcement (in the caption) for the table after the table itself. 
For sighted users, captions for long tables (especially tables that are longer than a screen or that flow onto the next page) make more sense when above the table.
So it would be a good idea to make "Above" the default option.
Comment 1 Björn Michaelsen 2011-12-23 12:37:28 UTC Comment hidden (obsolete)
Comment 2 Christophe Strobbe 2012-01-27 04:23:31 UTC
Version info was previously LibO 3.3.1. I confirm that this feature request is still relevant to LibreOffice 3.5.0 RC1: the default position for table captions is still below the table. Remembering the position from previous tables would be nice (and probably more acceptable for other users than making 'above' the default). Changing the status from NEEDINFO to NEW.
Comment 3 stragu 2013-05-26 09:10:57 UTC
This is still the case for LO 4.0.3

Another motivation for that change is that in most scientific publications, captions for tables are situated above the table (as opposed to figures).

Giving the user the choice by letting them use the "position" drop-down menu (it is curretly greyed-out) should be a minimum (why is it greyed-out at the moment?).
Comment 4 V Stuart Foote 2013-05-26 17:57:15 UTC
No change with current build of LODev 4.1.0 beta1, or 4.1 Master, i.e. the default position in the drop list offered in the insert Caption dialog frame remains "Below".

However, the Position drop list IS fully functional for selection [Below|Above]

The Tools -> Options -> LibreOfficeDev Writer -> AutoCaption feature provides some capability in the automated Caption -> Position [Below|Above] can be selected for Writer Tables. 

Unfortunately a Position selection made with AutoCaption applies globally to Writer Table, Frame, Picture, Spreadsheet, Chart, Drawing, Presentation, Formula and OLE objects--when each is selected for AutoCaption by UI checkbox.

What is still needed is a default "Above" Position setting for caption objects. And logic so that within current document the Caption Position (or really any object with a drop list Position attribute) is retained for subsequent Caption objects.

Referring up to UX-design mail list for discussion and validation of behavior when captioning tables.
Comment 5 stragu 2013-05-27 00:37:06 UTC
Created attachment 79822 [details]
Greyed-out position menu

Thanks for the comment, Stuart.

I just want to check if you can see the same as I do in Writer (I am actually using LO 4.0.2.2):

- When selecting a table, there is no option to add a caption (nothing in contextual menu, greyed out in "Insert" menu).
- When selecting an image (as I have to take a screenshot of the table to be able to add a caption to it...), I can add a caption and select the category "Table". However, the "position" menu is greyed out (see screenshot attached).
- In "tools > options > writer > autocaption", I saw that I could use autocaptions for table, and choose between "below" or "above". However (1) this is not easily discoverable for the user, there should be an easier way to add a caption to a frame; (2) one does not always want a caption for every single table that is added in the document.

So we have several problems here, and I might need to find the corresponding bugs/create a new one. I will try to update to 4.0.3 shortly to see if those problems remain.
Comment 6 stragu 2013-05-27 01:14:52 UTC
I just tested it on 4.0.3.3 and the problem remains, exactly as described in my previous comment.
Comment 7 V Stuart Foote 2013-05-27 01:47:03 UTC
Created attachment 79824 [details]
Works in LODev 4.0.4 pull 2013-05-26

Stephane,

I just pulled down a copy of today's Windows Dev build 4.0.4 -- Version 4.0.4.0+ (Build ID: 5d174f282fadd52f11105e53a816e35e627dd72)

Works for me the same as the 4.1.0beta1+ and 4.2.0alpha, 
Screen clip attached.

But I'll go ahead and dig out a copy of 4.0.3.3 and do an /A Windows install,  And I'll poke at it from a 64-bit Fedora 18. Just to be sure ;-)

I suspect though you may be loosing the focus of the table object when you attempt to add the caption. The table has to be active, i.e. have cursor focus in one of the cells of the table, and then use <Shift>+<F10> to launch the Table context menu. Select "Caption" with point click of mouse.  Just realized that keyboard entry of C's as accelerators is borked because there are too many "C" items on sub-menus.  Another bug to submit.

Stuart
Comment 9 V Stuart Foote 2013-05-27 03:26:09 UTC
Functions correctly in 4.0.3.3 final on both Windows 7 64-bit and Fedora 18 64-bit Linux.
Comment 10 stragu 2013-05-27 03:49:43 UTC
Hi Stuart

Thanks for your replies. Actually, everything works fine (even the position menu), the problem is that I intuitively was selecting the WHOLE table (with the corner arrow) before trying to insert a caption. For some reason, this option is not available when the whole table is selected - which to me is a bug of its own :)

Thanks for your efforts to suss this out! :)

I still wonder why we can't change the position of the text when adding a caption to a picture... Any idea?
Comment 11 V Stuart Foote 2013-05-27 04:44:17 UTC
(In reply to comment #7)
>...  Just
> realized that keyboard entry of C's as accelerators is borked because there
> are too many "C" items on sub-menus.  Another bug to submit.

submitted as fdo bug 65021
Comment 12 V Stuart Foote 2013-07-11 15:05:05 UTC
moving writer to ux-advise
Comment 13 V Stuart Foote 2013-07-11 15:08:06 UTC
linked Nabble mail list item
Comment 14 mahfiaz 2015-04-08 22:37:02 UTC
I think it would be nice to remember the setting for the type forever. E.g when one inserts caption above for table then next time the caption is inserted for a table it would be above as well. It could be global (happen in any document after the change). In this case I wouldn't have a strong opinion about the placement.

As for when the save should happen? Only when actually inserting the caption, e.g when one has illustration as type, then changes it to be above and only after that changes type to table it would load the position for the table (assume it's the now default below), now user would have to change the position again to above. And when the user cancels now, it would be forgotten.
Comment 15 Robinson Tryon (qubit) 2016-08-25 05:38:58 UTC Comment hidden (obsolete)
Comment 16 Heiko Tietze 2017-11-14 12:46:38 UTC
Captions have to be above for tables as notes are added below. That's defined in the APA standard, and likely everywhere else.


Removing UX, adjusting the summary (it's not just an ally thing), and this change looks like an easy hack.
Comment 17 Vikas Mahato 2017-12-26 16:58:48 UTC
Hi! I am starting to work on this bug.
Comment 18 Vikas Mahato 2017-12-31 11:55:09 UTC
I have implemented the required feature. However I want to know wheter the caption should be positioned at the top for tables only or for images as well?
Comment 19 stragu 2017-12-31 13:22:09 UTC
Thanks Vikas! I think the idea here is that it's only for tables that the caption should be above by default.
Comment 20 Vikas Mahato 2017-12-31 14:19:04 UTC
I have submitted a patch for review.
Comment 21 Commit Notification 2018-01-02 11:18:19 UTC
vikasmahato committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=11cc1afb2fd46c3dfdd519ad51c5fb2e7e3b7837

tdf#40457 - Place captions above tables by default

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Thomas Lendo 2018-01-15 22:38:36 UTC
Verified with Version: 6.1.0.0.alpha0+
Build ID: acb43c0b8efbfb841e7b40603d75a8432eb21f21
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-01-09_01:20:44
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 23 Thomas Lendo 2018-02-07 08:49:41 UTC
(In reply to stragu from comment #5)
> - When selecting a table, there is no option to add a caption (nothing in
> contextual menu
Context menu item was suggested and refused with bug 87590.
Comment 24 laurens 2018-10-11 06:02:04 UTC
So *this* is the reason that Table captions are appearing Above by default?

Company style is to have below. So I have to change manually every time I put in a table caption - a real drag. "For sighted users, captions for long tables (especially tables that are longer than a screen or that flow onto the next page) make more sense when above the table"
There are counter arguments to this - look at many textbooks.

Any way to make the position sticky?

Propose:
default position: Above, but when it has been changed manually in document, then subsequent entries are with the last position preference.
Comment 25 laurens 2018-10-11 06:04:31 UTC
By my first sentence I meant: Aha, this is the reason - because I felt I was going crazy mis-remembering that table captions used to default "below".
Comment 26 Heiko Tietze 2018-10-11 07:39:44 UTC
Position of captions is defined by all guidelines I kwon as above the table. Nonetheless, your idea to remember the last selection could be an interesting improvement. And there is some work ongoing for the similar bug 119738.

But please file a new ticket, this request is done.