Bug Hunting Session
Bug 42382 - Scripting in JavaScript and BeanShell broken
Summary: Scripting in JavaScript and BeanShell broken
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All Windows (All)
: high critical
Assignee: Noel Power
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-10-29 12:05 UTC by clio
Modified: 2011-12-23 13:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of error message (6.83 KB, image/png)
2011-10-29 12:05 UTC, clio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2011-10-29 12:05:53 UTC
Created attachment 52900 [details]
screenshot of error message

Impossible to create a new JavaScript or BeanShell macro or run an existing macro. (Win XP + JRE 6u22)

To reproduce:
1) Open JavaScript or BeanShell macro organizer
2a) Select an existing macro 
2b) Create a new macro

Result:
a) error (see screenshot)
b) failed to create the new macro
Comment 1 vitriol 2011-10-30 06:23:16 UTC
Confirmed. Regression.
Comment 2 Rainer Bielefeld Retired 2011-10-30 08:31:10 UTC
[Reproducible] with "LibreOffice 3.4.3  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]" 

The screenshot looks similar to the one in "Bug 36915 - Beanshell scripts don't work"

@Noel
I saw you active in "Bug 37015 - Scripting other than Basic unavailable", can you help?

Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 3 vitriol 2011-11-02 07:20:31 UTC
Seems working in RC2. Any confirmation?
Comment 4 manj_k 2011-11-02 12:46:26 UTC
Yep, works for me (on WinXP) with 3.4.4 RC2.
(Failed with 3.4.4 RC1.)

Suggestion: RESOLVED WORKSFORME
Comment 5 clio 2011-11-02 13:14:14 UTC
Works for me (3.4.4rc2), too.
Comment 6 Björn Michaelsen 2011-12-23 13:25:08 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.