Bug 43519 - Cannot set default file associations
Summary: Cannot set default file associations
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Win-Installer-MAB
  Show dependency treegraph
 
Reported: 2011-12-04 10:48 UTC by empidonax
Modified: 2013-03-07 06:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description empidonax 2011-12-04 10:48:36 UTC
I would like to be able to set LibreOffice programs as the default for various file types (Calc for csv and xls, Writer for rtf and doc, etc.), but there does not seem to be a way to do this in Windows Vista. The normal means for setting default applications in Vista does not show LibreOffice programs among the options and will not let me pick them through the "Browse..." button. I do not remember this posing a problem with OpenOffice, so I assume this is a bug with LibreOffice rather than with Windows Vista.
Comment 1 sasha.libreoffice 2012-02-13 06:43:18 UTC
Indeed, with Windows this problem exist. On Windows XP I can not set LibreOffice to open pptx files. And on Windows 7 can not even set PowerPoint 2003 to open ppt files.
Comment 2 Will Thompson 2012-04-07 08:30:06 UTC
This sounds like the issue I ran into today, replacing OpenOffice.org (3.3, from go-oo, as I recall) with LibreOffice 3.5. I installed the latter before uninstalling the former (which may have been a mistake). Now, LibreOffice is not associated with .odt, .ods, etc.—and it is not even presented as an option in the Open With… dialog.

http://user.services.openoffice.org/en/forum/viewtopic.php?f=15&t=42104 suggests that this may be to do with stale “soffice.exe” etc. entries in the registry. As someone not exactly au fait with Windows, I'm not sure what extra information would be most helpful.
Comment 3 Joel Madero 2012-08-30 19:04:35 UTC
We are working hard to try to get file associations (a whole list of problems) solved. I am going to CC the appropriate developer and see if he has any feedback on this one.

@Andras: any input on this one?
Comment 4 Andras Timar 2012-08-30 19:11:19 UTC
I have Windows XP and Windows 7. I don't work with Vista. Please let me know, how I can reproduce the bug. Step by step. You know, I'm old and I socialized on UNIX workstations. :)
Comment 5 Joel Madero 2012-08-30 19:52:08 UTC
@empidonax: if you could just provide Andras with how you normally set file association in Vista (ie. where you're not seeing LibreOffice listed) that would be helpful. 

@Andras: Ultimately I think that this goes back to our previous discussion of needing some method from within LibO to associate different file types easily regardless of Operating System. I know you were going to talk to the UX team about this
Comment 6 Timur 2013-03-05 11:23:04 UTC
There are few methods to provide a proper file associations for the Windows version of Libreoffice.

1. During the command-line installation, which is convenient for mass-scale deployment
2. During the GUI installation, selecting file associations works for LibreOffice, but doesn't work for LOdev - should a new bug be filed or this can be handled in the existing bugs, such as Bug 60714?
3. Modifying the GUI installation, selecting file associations works for LibreOffice 3.6.5.2 and 4.0.1.2, but doesn't work for LOdev - related to Bug 60714 - changing file associations from the change option of add/remove programs doesn't work - so this bug should relate to LOdev only
4. Using Windows 7 Default Programs option in Control Panel is possible for LibreOffice 3.6.5.2 and 4.0.1.2 because they are registered, but it's not possible for LOdev because it's not. - related to Bug 43519 - Cannot set default file associations - I don't have Vista, but it should be same as 7. I think this bug should relate to LOdev only.
5. From within LibreOffice - not possible, and requested in Bug 44462 - Provide a proper 'File Association Manager' for the windows version of Libreoffice 

LibreOffice is found in HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications or HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\RegisteredApplications while LOdev is not.
Comment 7 Timur 2013-03-06 09:47:44 UTC
> 4. Using Windows 7 Default Programs option in Control Panel is possible for
> LibreOffice 3.6.5.2 and 4.0.1.2 because they are registered, but it's not
> possible for LOdev because it's not. - related to Bug 43519 - Cannot set
> default file associations - I don't have Vista, but it should be same as 7.
This was reported for 3.4 and doesn't seem relevant now. Upon my testing with 3.6 and 4.0, I recommend this bug be closed as INVALID or something.
Comment 8 V Stuart Foote 2013-03-06 15:37:45 UTC
I'll install a Vista box today and test against it. If a current build 4.0.1 or LOdev handles file associations correctly will go ahead and close -- Resolved Fixed. Otherwise will close it resolved against bug 44462 enhancement, and add a note there to ensure testing against Vista.
Comment 9 V Stuart Foote 2013-03-07 06:49:17 UTC
Set up a test box for 
Intel(R) Core(TM)2 CPU 4300  @ 1.80GHz
2GB RAM
Vista sp2 32-bit
Java JRE 1.6u43

LibreOffice 3.6.5 installed without issue. LibreOffice programs were available if set from the Install Wizard panel. Also when set from the Control Pannel -> Default programs panel. And also from the Open With dialog in Windows Explorer shell, although if no file association had been made to a file type on first use you had to browse to the program executable when first using that file type.

Assignments made from an Add/Remove program panel (appwiz.cpl) -> Change run as Administrator were made against the HKLM > SOFTWARE > Classes keys. While associations made as user were made against HKCU > SOFTWARE > Classes keys, and overrode the HKLM settings. And when cleared from HKCU, the HKLM associations reasserted.

Finally, for Microsoft Office file associations made with the LibreOffice Install Wizard, they could be cleared with a Add/Remove programs (appwiz.cpl) LibreOffice > Change session. Limited to those that had been set with the wizard. Associations made from Windows Explorer > Open with, or the Control Panel > Default programs could not be adjusted with the Install Wizard.

Then removed 3.6.5.2, cleaned registry and installed 4.0.1.2

With 4.0.1.2 build on a Vista system, the MS Office file types default associations remain functional although the Add/Remove -> Change file associations now change associations but also makes the selected LibreOffice programs available in the Open with dialogs for this build. And it seems the Open with availability can not otherwise be set. Behavior as reported for Windows XP in bug 60714, but the otherwise functional.

Marking as resolved fixed for Windows Vista, with a note to test with Vista if enhancement of bug 44462 proceeds.