Download it now!
Bug 43648 - : Windows 8 Incompatibility — Crashes on load
Summary: : Windows 8 Incompatibility — Crashes on load
Status: RESOLVED DUPLICATE of bug 43989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-08 16:44 UTC by Alec Taylor
Modified: 2012-01-11 07:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Debugger disassembly (4.86 KB, text/plain)
2011-12-08 16:44 UTC, Alec Taylor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Taylor 2011-12-08 16:44:23 UTC
Created attachment 54256 [details]
Debugger disassembly

Problem description: 
LibreOffice crashes on load

Steps to reproduce:
1. Install Windows 8
2. Install Oracle JDK+JRE x64 6 (update 29) [also tried with x64 7]
3. Install LibreOffice 3.4.4
4. Open LibreOffice Writer

Current behavior:
Crashes on load [soffice.bin]

Debugging info:
"Microsoft Visual Studio C Runtime Library has detected a fatal error in soffice.bin"
msvcr90.dll!__crt_debugger_hook()
[see attached for Diassembly which breaks on]
__crt_debugger_hook:
73EE1661  and         dword ptr [__debugger_hook_dummy (73F0D7A0h)],0

Expected behavior:
Load!

Platform (if different from the browser): 
              
Windows 8 x64 Developer Preview
Comment 1 Rainer Bielefeld Retired 2011-12-09 00:34:43 UTC
WIN 8 is Beta ....

Related to or DUP of?
Bug 42772 - Launch of Libreoffice 3.4.4 impossible after update from version 3.4.1
Bug 43266 - : An error: "This application has failed to start..."
Bug 38913 - Libreoffice applications crash - MSVCR90.dll
or an other of our  MSVCR90.dll bugs?

@Alec Taylor
I think WIN8 problems should be fixed for Master, so I recommend to try a Master and report your experience here.
Comment 2 Jesus Corrius 2012-01-11 07:31:24 UTC
I confirm the bug.

Windows 8 x64 Developer Preview
Oracle JDK+JRE x64 6 (update 30)
LibreOffice 3.5 Beta 2.
Comment 3 Jesus Corrius 2012-01-11 07:31:53 UTC
Add me to CC.
Comment 4 Jesus Corrius 2012-01-11 07:46:19 UTC
Resolved as a duplicate of #43989

*** This bug has been marked as a duplicate of bug 43989 ***