Download it now!
Bug 44015 - bad display of dashed table border
Summary: bad display of dashed table border
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: regression
: 64591 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-21 06:38 UTC by Nicolas Mailhot
Modified: 2014-02-14 10:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
testcase (10.09 KB, application/vnd.oasis.opendocument.text)
2011-12-21 06:38 UTC, Nicolas Mailhot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2011-12-21 06:38:39 UTC
Created attachment 54637 [details]
testcase

The border used in the attached testcase is wrongly displayed by openoffice, especially at small zoom factors (it seems libreoffice tries to compensate for the zooming and makes a huge mess of the result)

It appears very strong and coarse when it's in fact quite slight when printing

Changing it to a dotted line "fixes" the border display but makes it too slight for printing

As a result, both border styles are unsuitable to contextes when an electronic document must look good on-screen and also when printed

The same border style displays fine, WYSIWYG-style, in word 2007
Comment 1 Michael Stahl (CIB) 2012-05-22 14:44:33 UTC
uhm, something is going very wrong with how these dashed border
lines are painted; just zooming in and out on the bugdoc changes
the number of line segments; also it looks quite different on
LO 3.4.6, LO 3.5.4, and master... what is going on here?

and yes PDF looks different from on-screen display.
Comment 2 tommy27 2013-10-24 05:12:35 UTC
still present in 4.1.2.3 under Win7 64bit
Comment 3 tommy27 2013-10-24 05:13:29 UTC
*** Bug 64591 has been marked as a duplicate of this bug. ***
Comment 4 tommy27 2013-10-24 05:28:00 UTC
works fine in 3.3.4
bug already present in 3.4.3 and persists in 4.1.2
hence regression of early 3.4.x development

tested under Win7 64bit.
any Linux and Mac user could provide feedback as well?
Comment 5 Cédric Bosdonnat 2014-01-20 08:57:00 UTC
Restricted my LibreOffice hacking area
Comment 6 Michael Stahl (CIB) 2014-02-14 10:00:33 UTC
this is substantially fixed in 4.2.1 thanks to Kohei's commit
9a19e8d838753128504274e1885eb3ce8ec1dbb8
"fdo#73487, fdo#73886: Overhaul cell borders to make them look sane."