Download it now!
Bug 64591 - Dashed tables borders not properly displayed in Writer
Summary: Dashed tables borders not properly displayed in Writer
Status: RESOLVED DUPLICATE of bug 44015
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-14 16:05 UTC by Alexis
Modified: 2013-11-20 16:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
dashed border table sampe (7.49 KB, application/vnd.oasis.opendocument.text)
2013-10-24 04:32 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis 2013-05-14 16:05:30 UTC
In Writer, dashed borders ( - - - ) in tables are not correctly displayed when the page is zommed out. The border becomes visible again if I zoom in.

It looks like a display aliasing issue.

Note that it's mainly visible on horizontal borders but. I guess that vertical ones also have the problem.

Plain borders are correctly displayed...

I had no issue with previous 3.6 versions.

PDF export is correct but this is a bit annoying when editing a document with invisible borders...
Comment 1 ign_christian 2013-05-16 06:28:20 UTC
Please attach related files that show that problem & steps to reproduce it so others can clearly understand the issue.
Comment 2 Alexis 2013-05-16 07:18:24 UTC
To reproduce issue:

1. Create an empty document.
2. Insert a table with more than 2 rows/columns
3. Change all borders style to dashed one (use standard line width).
Table borders become invisible

Note 1 : it seems that double line borders have also similar behavior
Note 2 : It also looks like very large borders become visible

Suggestion for developers: If the displayed line should be < 1 pixel due to zooming, it should be at least 1 pixel large so that stays visible. This is what seems to be done with standard plain borders
Comment 3 ign_christian 2013-05-17 04:00:16 UTC
Reproduced on LO 4.0.3.3 (Win7 Home Premium 32bit), but I see missing (not invisible) horizontal line(s)
-> confirm missing with Page Preview & export as PDF

I think it's a problem with line width that is too thin by default, as on Calc. This problem not occur if I set line width above 1pt.
Comment 4 Dominique Boutry 2013-10-12 13:54:33 UTC
Reproduced with LibO 4.0.5.2 on Win7.
Comment 5 tommy27 2013-10-24 04:32:22 UTC
Created attachment 88065 [details]
dashed border table sampe

reproduced with 4.1.2.3 under Win7 64bit.
see attached file. dashed borders look invisible and they are partially visible only at some high zoom levels.

Linux and Mac users are encouraged to test this bug since it has only been reported by Windows users until now.

I add Writed expert to CC list.
Comment 6 tommy27 2013-10-24 05:13:29 UTC
issue was already reported.
let's continue discussion over there.

*** This bug has been marked as a duplicate of bug 44015 ***