Bug Hunting Session
Bug 44073 - ODF: various defects in page style layout grid export
Summary: ODF: various defects in page style layout grid export
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:3.4.5 target:3.5.0beta3 target...
Keywords:
: 38752 49575 (view as bug list)
Depends on:
Blocks: ODF-export-invalid 37390
  Show dependency treegraph
 
Reported: 2011-12-22 13:01 UTC by Michael Stahl (CIB)
Modified: 2017-05-28 14:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2011-12-22 13:01:25 UTC
investigating bug 37390 revealed:

there are 3 attributes which have been added in ODF 1.2,
but are written by OOo and LO in any ODF version:

style:layout-grid-base-width 20.297
style:layout-grid-snap-to 20.305
style:layout-grid-standard-mode 20.306

additionally, style:layout-grid-snap-to used to be written wrongly as
style:layout-grid-snap-to-characters, which does not exist in any ODF spec.

there was a supposed fix for the latter problem cited
in bug 37390 comment#3 which is bogus as far as i can tell.
Comment 1 Michael Stahl (CIB) 2011-12-22 13:57:38 UTC
how to get these attributes written at all:

1. Tools->Options, Language Settings->Languages,
   check "Enabled for Asian languages"
2. Tools->Options, LibreOffice Writer->General,
   uncheck "Use square page mode for text grid"
3. Format->Page, TextGrid tab, select
   "Grid (lines and characters"
Comment 4 Michael Stahl (CIB) 2012-01-31 06:36:05 UTC
*** Bug 38752 has been marked as a duplicate of this bug. ***
Comment 5 Michael Stahl (CIB) 2012-09-13 11:28:37 UTC
*** Bug 49575 has been marked as a duplicate of this bug. ***