Bug 38752 - ODF export: invalid "style:default-page-layout"
Summary: ODF export: invalid "style:default-page-layout"
Status: CLOSED DUPLICATE of bug 44073
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.1 RC2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-28 09:30 UTC by Olav Dahlum
Modified: 2012-02-24 04:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
simple text document (11.51 KB, application/vnd.oasis.opendocument.text)
2012-01-27 07:40 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olav Dahlum 2011-06-28 09:30:35 UTC
When putting a empty Writer ODF 1.2 Extended (but also 1.0/1.1/1.2) document from a vanilla 3.4.1 RC2 installation trough the http://tools.services.openoffice.org/odfvalidator/ and
http://opendocumentfellowship.com/validator I still get some validation errors.

Some of these errors applies to the tests for the ISO implementation of ODF as well.

From the validator in tools.services.openoffice.org I get:

Result for Navnl?s 1.odt

This file is NOT valid

Result details:

upload:///Navnl?s 1.odt/styles.xml[2,7251]:Error:tag name "style:default-page-layout" is not allowed. Possible tag names are: <bibliography-configuration>,<boolean-style>,<currency-style>,<date-style>,<default-style>,<fill-image>,<gradient>,<hatch>,<linearGradient>,<list-style>,<marker>,<notes-configuration>,<number-style>,<opacity>,<percentage-style>,<presentation-page-layout>,<radialGradient>,<stroke-dash>,<style>,<text-style>,<time-style>
upload:///Navnl?s 1.odt:Info:Generator: LibreOffice/3.4$Unix LibreOffice_project/340m1$Build-102


The OpenDocument FellowShip:

This file is not Valid OpenDocument 1.0!

    error

    in styles.xml
    /www/TOM/_temp/LDGJOUZVMkLHMGa3kGTRXa0SS4ZRu5o2/styles.xml:0: Relax-NG validity error : Element styles has extra content: default-page-layout

Some of these are probably false positives from the validation services, but this still needs to be addressed if LibreOffice is to be considered a viable option for governmental use etc.
Comment 1 Björn Michaelsen 2011-12-23 12:29:22 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-01-27 07:40:58 UTC
Created attachment 56224 [details]
simple text document

simple odt document created in LibO 3.6.0 master not validated in first link
second link not works
Comment 3 sasha.libreoffice 2012-01-27 07:44:16 UTC
@Michail
Please, see on it if have some time
Comment 4 Michael Stahl (CIB) 2012-01-31 06:00:57 UTC
the attached document evidently has nothing to do with the bug description.

please file new bugs for different elements. thanks.
Comment 5 Michael Stahl (CIB) 2012-01-31 06:36:05 UTC
"style:default-page-layout" is not in ODF 1.1, but only in ODF 1.2.

LO used to export the element erroneously also when producing a ODF 1.1
document; it seems that my fix for the related bug 44073 also fixed
this bug as well, because the element is only exported if a
style:layout-grid-standard-mode is present (though i cannot remember
if i thought about the element at all while fixing the attributes).

so resolving as a duplicate of that.

*** This bug has been marked as a duplicate of bug 44073 ***
Comment 6 sasha.libreoffice 2012-01-31 07:06:47 UTC
first found in LibO 3.6.0 master:
Bug 45446 - Writer FILESAVE: validation of odt not passed
Comment 7 sasha.libreoffice 2012-01-31 07:16:40 UTC
Bug 45447 - Writer FILESAVE: validation of odt not passed
Comment 8 sasha.libreoffice 2012-01-31 07:22:26 UTC
Bug 45448 - Writer FILESAVE: validation of odt not passed
Comment 9 sasha.libreoffice 2012-01-31 07:27:24 UTC
Bug 45449 - Writer FILESAVE: validation of odt not passed
Comment 10 sasha.libreoffice 2012-01-31 07:33:01 UTC
Bug 45450 - Writer FILESAVE: validation of odt not passed
Comment 11 sasha.libreoffice 2012-01-31 07:35:05 UTC
@ Michael
I have created 5 bugreports. Please, tell me if this job is useful, and I continue then.
Comment 12 sasha.libreoffice 2012-02-04 06:28:01 UTC
Bug 45620 - Writer FILESAVE: validation of odt not passed
Comment 13 sasha.libreoffice 2012-02-06 06:33:10 UTC
Bug 45700 - Writer FILESAVE: validation of odt not passed
Comment 14 sasha.libreoffice 2012-02-10 07:01:10 UTC
Bug 45895 - Writer FILESAVE: validation of odt not passed
Comment 15 sasha.libreoffice 2012-02-10 07:25:40 UTC
Bug 45897 - Writer FILESAVE: validation of odt not passed