Download it now!
Bug 44471 - FORMATTING: Changing character background color causes HANG
Summary: FORMATTING: Changing character background color causes HANG
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 42866 (view as bug list)
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2012-01-04 15:57 UTC by luchotres
Modified: 2012-10-03 11:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mac OS X Log file for bug 44471, LibreOffice 3.5.6.2 (65.38 KB, text/plain)
2012-09-15 14:29 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description luchotres 2012-01-04 15:57:32 UTC
Problem description: 

Steps to reproduce:
1. ....fondo de caracter
2. ....ninguno
3. ....enter

Current behavior: hangs (libreoffice closes unespectadly)

Expected behavior: ...

Platform (if different from the browser): 
              
Browser: Intel Mac OS X 10_6_8 Safari/534.52.7
Comment 1 Rainer Bielefeld Retired 2012-01-04 22:56:18 UTC
NOT reproducible with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit)
Spanish UI [Build ID: OOO340m1 (Build:501)]"

@luchotres
I believe something is broken with your Libreoffice installation
Bugzilla language is English, can you discuss your problems in a user mailing list and ask someone to submit the problems here in English language
Comment 2 luchotres 2012-01-13 08:34:33 UTC
(In reply to comment #1)
I¨ve tried uninstalling libreoffice wiyh appcleaner, and then reinstalling it, but it didn´t work. LO crashes if I use text fill empty, or try to change language preferences or ... etc ...

When I reinstall LO it gets the same extensions. I don´t get why if i had erased everything (it includes some extensions I had downloaded myself ; perhaps are bounded extensions?)

Could it be a java buissnes? I have the last version avaiable.

I use spanish because my LO version is in that language. But the same problems appeared when I tried de english version (before installing the language pack)

Finally I tried LO 3.4.5 version but everything was the same.

I would thank any clues. I have been using LO for years in windows. Just recently I changed to MAC and nothing seems to work properly; I´m really disappointed. 

> NOT reproducible with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit)
> Spanish UI [Build ID: OOO340m1 (Build:501)]"
> 
> @luchotres
> I believe something is broken with your Libreoffice installation
> Bugzilla language is English, can you discuss your problems in a user mailing
> list and ask someone to submit the problems here in English language
Comment 3 luchotres 2012-01-13 08:36:39 UTC
(In reply to comment #1)
I¨ve tried uninstalling libreoffice wiyh appcleaner, and then reinstalling it, but it didn´t work. LO crashes if I use text fill empty, or try to change language preferences or ... etc ...

When I reinstalled LO it keeps the same extensions. I don´t get why if i had erased everything (it includes some extensions I had downloaded myself ; perhaps are bounded extensions?)

Could it be a java buissnes? I have the last version avaiable.

I use spanish because my LO version is in that language. But the same problems appeared when I tried de english version (before installing the language pack)

Finally I tried LO 3.4.5 version but everything was the same.

I would thank any clues. I have been using LO for years in windows. Just recently I changed to MAC and nothing seems to work properly; I´m really disappointed. 

> NOT reproducible with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit)
> Spanish UI [Build ID: OOO340m1 (Build:501)]"
> 
> @luchotres
> I believe something is broken with your Libreoffice installation
> Bugzilla language is English, can you discuss your problems in a user mailing
> list and ask someone to submit the problems here in English language
Comment 4 luchotres 2012-01-13 14:08:58 UTC
(In reply to comment #3)

The solution is found in bug 37913

You have to uncheck Enable access for assistance devices
 
System Preferences > Universal Access > uncheck Enable access for assistance
devices 
(it's the first checkbox on the bottom of the Universal Access preference pane) 


LibreOffice does not crash on preferences anymore.

I hope this could be useful



> (In reply to comment #1)
> I¨ve tried uninstalling libreoffice wiyh appcleaner, and then reinstalling it,
> but it didn´t work. LO crashes if I use text fill empty, or try to change
> language preferences or ... etc ...
> 
> When I reinstalled LO it keeps the same extensions. I don´t get why if i had
> erased everything (it includes some extensions I had downloaded myself ;
> perhaps are bounded extensions?)
> 
> Could it be a java buissnes? I have the last version avaiable.
> 
> I use spanish because my LO version is in that language. But the same problems
> appeared when I tried de english version (before installing the language pack)
> 
> Finally I tried LO 3.4.5 version but everything was the same.
> 
> I would thank any clues. I have been using LO for years in windows. Just
> recently I changed to MAC and nothing seems to work properly; I´m really
> disappointed. 
> 
> > NOT reproducible with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit)
> > Spanish UI [Build ID: OOO340m1 (Build:501)]"
> > 
> > @luchotres
> > I believe something is broken with your Libreoffice installation
> > Bugzilla language is English, can you discuss your problems in a user mailing
> > list and ask someone to submit the problems here in English language
Comment 5 Roman Eisele 2012-07-15 17:34:39 UTC
(In reply to comment #4)
> The solution is found in bug 37913
> 
> You have to uncheck Enable access for assistance devices
> 
> System Preferences > Universal Access > uncheck Enable access for assistance
> devices 
> (it's the first checkbox on the bottom of the Universal Access preference pane) 
> 
> LibreOffice does not crash on preferences anymore.

If I understand this correctly, unchecking "Enable access for assistance devices" did also fix this (present) bug -- right? Then this is a duplicate of bug 47368.

Therefore I mark this bug report as a duplicate of bug 47368.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 6 Roman Eisele 2012-09-15 10:19:39 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

All tests done on Mac OS X 10.6.8 (Intel).

To test, I used the following steps:
0) Rename your LibO user profile folder, to make sure that
   there is no influence of any special settings on the test.
1) Start LibreOffice;
   -> the Start Center window appears.
2) Click on "Text Document";
   -> a new empty Writer document opens.
3) Type "Text".
4) Select "Text".

Now EITHER DO
5a) Select "Format > Character..." from the menu;
    -> the "Character" dialog window appears.
6a) Select tab "Background";
    -> the "Background" tab with the color table appears.
7a) Click on "Yellow".
8a) Click on the "OK" button.
9a) Repeat steps 5 to 9,
    but this time, select "No fill" (transparent background).

OR DO
5b) Click on the "Highlighting" color toolbar button,
    to show the popup color table,
6b) and select "Yellow".
7b) Click on the "Highlighting" color toolbar button,
    to show the popup color table,
8b) and select "No fill".

In some previous LibreOffice versions, LibreOffice used to crash
after step 9a) or 8b) respectively, when Mac accessibility features
were enabled or some window management utility like RightZoom
(which relied on Mac accessibility features) was running.

But now I can NOT REPRODUCE the crash anyore with 
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: cfbfa26,
  Pull time: 2012-09-07 10:35:10, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 5ca197c,
  Pull time: 2012-09-06 07:07:33, US English langpack installed

This indicates that this bug has been fixed somehow BEFORE the two
patches which fixed bug 47368 have been applied.

This means in turn that this bug is/was NOT a duplicate of bug 47368, which was fixed by the two patches cited above.

Therefore I change the status of this bug to RESOLVED/WORKSFORME, as usual when a bug is no longer reproducible but we don’t know which commit exactly has fixed it.

(
A possible candidate which *could* have fixed this issue is
http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5bbd67f675be962e294c24ee8b6ecccd1f341e8
but cf. my observations in:
  https://bugs.freedesktop.org/show_bug.cgi?id=47368#c66
  https://bugs.freedesktop.org/show_bug.cgi?id=47368#c68
)


@ Everybody:

Please reopen this bug report, IF and ONLY (!!!) if you can still reproduce this bug more or less exactly by the steps listed above in a LibreOffice 3.6.x version newer than 2012-09-07 or in a LibreOffice master (LOdev) version newer than 2012-09-06.

If you encounter a similar issue, which is not exactly the same, please file a NEW bug report for it (and CC me about it: bugs@eikota.de), and describe exactly: step by step, mouse click by mouse click, how to reproduce it.

Thank you!
Comment 7 Roman Eisele 2012-09-15 10:22:42 UTC
*** Bug 42866 has been marked as a duplicate of this bug. ***
Comment 8 Roman Eisele 2012-09-15 14:29:11 UTC
Created attachment 67208 [details]
Mac OS X Log file for bug 44471, LibreOffice 3.5.6.2

Mac Accessibility Related Bugs Survey Results
---------------------------------------------

Supplement:
The steps given in comment #6 still crash LibreOffice 3.5.6.2 (Build-ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0) on Mac OS X 10.6.8 (Intel) with RightZoom running to provoke the accessibility-related bugs.
Attached you find the log file created by Mac OS X for the crash.

But, as said above, they don’t crash anymore with LibreOffice >= 3.6.1. This confirms my statement (comment #6) that this bug has been fixed somehow BEFORE the two patches which fixed bug 47368 have been applied, probably already in the 3.6 development process.

You could ask to fix this bug also in the 3.5 branch where it is still reproducible, but the chances are bad: we don’t know which commit(s) have fixed the issue, therefore it is not possible to backport that commit(s).

Additionally, there is a workaround suitable for most users (disable any Mac accessibility features and accessibility-related utilities).

Therefore, this bug will probably not get fixed in the LibreOffice 3.5 branch, sorry. So please do NOT reopen this bug report just because this bug was not fixed in LibreOffice 3.5.x ;-)