Bug Hunting Session
Bug 44688 - (windows only) Hebrew Vowel Points are sometimes misplaced in PDF export (and printing)
Summary: (windows only) Hebrew Vowel Points are sometimes misplaced in PDF export (and...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on: HarfBuzz
Blocks: PDF-Export RTL-Hebrew
  Show dependency treegraph
 
Reported: 2012-01-11 09:27 UTC by Erwan
Modified: 2017-10-02 11:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example of ODT file with hebrew + PDF + PS + screenshot (230.28 KB, application/x-zip-compressed)
2012-01-11 09:27 UTC, Erwan
Details
A new test file that bugs on Vista and works ok on Ubuntu (15.11 KB, application/vnd.oasis.opendocument.text)
2012-05-24 12:33 UTC, Erwan
Details
PDF export by LO on Vista SP2 : bugged (31.77 KB, application/pdf)
2012-05-24 12:34 UTC, Erwan
Details
PDF export by LO on Ubuntu 12.04 : perfect (31.00 KB, application/pdf)
2012-05-24 12:34 UTC, Erwan
Details
pdf export with 4.0.1.2 (31.81 KB, application/pdf)
2013-03-19 21:21 UTC, Lior Kaplan
Details
pdf export with LO 4.0.1.2 and SBL Hebrew installed (34.42 KB, application/pdf)
2013-03-20 10:29 UTC, Erwan
Details
pdf export with LO 4.0.1.2 and SBL Hebrew installed BIS (34.42 KB, application/pdf)
2013-03-20 10:32 UTC, Erwan
Details
pdf export with LO 4.0.1.2 and SBL Hebrew installed TER (34.42 KB, application/pdf)
2013-03-20 10:34 UTC, Erwan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erwan 2012-01-11 09:27:20 UTC
Created attachment 55452 [details]
example of ODT file with hebrew + PDF + PS + screenshot

Hebrew Vowel Points are displayed correctly, when using proper Unicode font such as SBL Hebrew, but are frequently misplaced on PDF export and printing.
The comparison with PS export is interesting : Hebrew Vowel Points are correctly placed on PS export, and in PDF conversion (with GSView + Ghostscript) of this PS export.
PS export is achieved by "file printing" with Microsoft-supplied "HP Color LaserJet 4550 PS" driver.
Hebrew Vowel Points are usually not used in Modern Hebrew language spoken in Israel, but are used intensively by Bible Scholars. This bug makes LibreOffice unsuitable for Bible Scholars.
Comment 1 sasha.libreoffice 2012-05-07 08:51:28 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible

As I understand, in attachment,  כִּי should be placed that one dot beneath another. Or no?
Comment 2 Erwan 2012-05-09 01:00:44 UTC
Still reproducible in LO 3.5.3.2 (Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80) on Windows Vista SP2 (running Uniscribe usp10.dll version 1.626.2002.18244) - no changes at all.

the two points should be : 
- one (called "dagesh") in the center of the letter ki - this point is ok
- the second (called "hiriq") beneath the letter ki, vertically aligned with the first one - this one is misplaced in PDF exported by LO, but placed correctly on diplay, on postcript printing, and Ghostscript-generated PDF.
Comment 3 sasha.libreoffice 2012-05-10 06:45:50 UTC
Not reproduced in 3.5.3 on Windows 7 32 bit and Fedora 64 bit
Used File->Export as PDF, option PDF/A-1a enabled.

@ Erwan
It happens with all fonts or only with one or several specific fonts?
Comment 4 Erwan 2012-05-10 08:33:13 UTC
on LO 3.5.3 + Vista SP2, the bug happens with and without "PDF/A-1a" enabled. No difference.

It always happen with the test document I posted, but it does not always happen with any hebrew text. There is some kind of special combination between the LTR and the RTL text to have it happen. It also happens with the combination Times New Roman (for RTL) + SBL Hebrew (for LTR). But if you change line length, or justification, it sometimes solves the problem. It cannot be predicted. Since I was often encountering the problem (I'm a Bible scholar), I built many test cases before finding the one that I posted - this one always bugs on my PC.
But if I put only RTL Hebrew on the line, without any LTR text, the PDF export is perfect.

As you get good results with Win7 and Fedora, I could be related to the windows uniscribe dll - Microsoft does not ship the same version with Vista and Seven. I found a post on the internet of problems of interaction between old versions of Openoffice and Uniscribe dll.
Comment 5 Erwan 2012-05-24 12:33:30 UTC
Created attachment 62071 [details]
A new test file that bugs on Vista and works ok on Ubuntu
Comment 6 Erwan 2012-05-24 12:34:02 UTC
Created attachment 62072 [details]
PDF export by LO on Vista SP2 : bugged
Comment 7 Erwan 2012-05-24 12:34:32 UTC
Created attachment 62073 [details]
PDF export by LO on Ubuntu 12.04 : perfect
Comment 8 Erwan 2012-05-24 12:37:21 UTC
I made new tests with the last LO version (3.5.3) on Vista SP2, and I installed Ubuntu 12.04 to compare.
I installed exactly the same fonts on both systems : Linux Libertine G and SBL Hebrew, last version for both.

The bug does not occur with Ubuntu ! But occurs with Vista.

(The solution is NOT to dump Windows for Ubuntu : because I need Bibleworks that doesn't run well on linux+wine)

I have no idea how you could "include" the Ubuntu PDF-export of LO into the Windows version ! But that would be great.

I don't know what happens with Win7.
Comment 9 sasha.libreoffice 2012-05-29 07:49:18 UTC
Thanks for attachments
On my computer with Windows 7 font "SBL Hebrew" not installed, therefore bug not reproducible.
Please, attach this font also, or provide link from where it installed.
Comment 10 Erwan 2012-05-29 07:50:30 UTC
Here you are :
http://www.sbl-site.org/Fonts/SBL_Hbrw.ttf
Comment 11 sasha.libreoffice 2012-05-29 08:35:48 UTC
Thanks. Now it reproduced on Windows 7 32 bit
I downloaded font from link, right mouse click on it, "Install" from context menu. On screen text looks correct. But in PDF dots becomes in wrong place
Comment 12 sasha.libreoffice 2012-05-29 08:42:39 UTC
Changing version back to 3.4.4 because Version: is most early version where bug exist
Comment 13 Erwan 2012-05-29 09:54:08 UTC
You might be interested by the official documentation of the "SBL Hebrew" font, where they discuss some technical aspects of Unicode, Opentype and Uniscribe :
http://www.sbl-site.org/Fonts/SBLHebrewUserManual1.5x.pdf
Comment 14 Erwan 2012-06-05 12:31:06 UTC
No changes with last release 3.5.4.2 on Windows Vista SP2
Comment 15 sasha.libreoffice 2012-06-05 23:35:21 UTC
When somebody will fix this bug, hi will add comment in this bugreport.
Currently TDF has no free expert for this area (Windows/fonts).
May be in next year situation will be better.
Sorry for such situation.
Comment 16 dehcjam 2012-12-19 17:05:49 UTC
Being a biblical scholar myself I experience the same problem:
While in Writer the vowel signs in are placed correctly under the Hebrew letter, exporting the document as PDF results in dislocated vowel signs. (I used the PDF button, no options selected.) Printing the document 
Exporting the very same file as PDF with LO 3.5.4.7 in openSUSE 12.2 KDE results in a flawless PDF file.
LO 3.5.7.2 (Build ID:3215f89-f603614-ab984f2-7348103-1225ab) has the same problem in Windows 7.
I use LibreOffice since January 26, 2011 and never observed this problem before (note: I didn‘t type a lot in Hebrew in the past months).

Version 3.6.4.3 (Build ID: 2ef5aff)
OS: Windows 7 Professional
Font: SBL Hebrew (http://www.sbl-site.org/educational/BiblicalFonts_SBLHebrew.aspx)
Keyboard: Logos Biblical Hebrew Keyboard Version 1.5
Comment 17 Erwan 2012-12-19 18:21:14 UTC
Hi, I've found a workaround a few months ago, since there is a new version of "RedMon" compatible with Vista and Win7. So I used Redmon + Ghostscript to "transform" my non-postscript printer into a postscript printer, and everything prints well. I also was able to use Ghostscript as a virtual printer named "Ghostscript PDF", that creates perfect PDF with all the hebrew stuff right.
Website for Redmon is : http://pages.cs.wisc.edu/~ghost/redmon/index.htm
(it's a bit tricky to configure but you'll get to it) 
Merry Christmas !
Comment 18 Lior Kaplan 2013-03-19 21:21:08 UTC
Created attachment 76777 [details]
pdf export with 4.0.1.2

It seems the bug doesn't reproduce on Windows 7 (SP 1) and LibO 4.0.1.2. See attached comment.

Please help verify.
Comment 19 Erwan 2013-03-20 10:29:29 UTC
Created attachment 76808 [details]
pdf export with LO 4.0.1.2 and SBL Hebrew installed

Sorry Lior, but the bug still reproduces on LO 4.0.1.2 with Win7SP1.

1) on your computer, you don't have the SBL Hebrew font installed. Your computer substituted with something else.
2) even without the SBL Hebrew font, on your pdf export, there are a few problems on the last lines : dagesh not centered in the beth, yod and shewa not vertically aligned in beth or kaph, dagesh and shewa not vertically aligned.
Comment 20 Erwan 2013-03-20 10:32:25 UTC
Created attachment 76809 [details]
pdf export with LO 4.0.1.2 and SBL Hebrew installed BIS

(sorry, precedent attachment is broken)
Comment 21 Erwan 2013-03-20 10:34:15 UTC
Created attachment 76810 [details]
pdf export with LO 4.0.1.2 and SBL Hebrew installed TER

(I'm ashamed I didn't select the "type" right the first & second time).
Comment 22 dehcjam 2014-08-04 03:32:54 UTC
This may not be a bug in LibreOffice, but a problem of the font, SBL Hebrew in this case. When I use FreeSerif or Ezra SIL the problem does not occur in LibreOffice 4.3.0 in Windows. With SBL Hebrew it does.
Comment 23 QA Administrators 2015-09-04 02:49:48 UTC Comment hidden (obsolete)
Comment 24 Buovjaga 2015-11-30 14:06:54 UTC
I installed SBL Hebrew and the PDF export is still buggy.
http://www.sbl-site.org/educational/BiblicalFonts_SBLHebrew.aspx

Maybe the SBL guys should be asked regarding this.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)
Comment 25 Khaled Hosny 2016-11-11 23:36:38 UTC
Most likely this is fixed now.
Comment 26 Buovjaga 2016-11-21 09:51:57 UTC
I confirm the vowel points export OK now.
Fixed by the new layout engine, so setting to FIXED.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 172325bedf69bbc162f3c1948264451c90c105a3
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-21_05:26:40
Locale: fi-FI (fi_FI); Calc: group
Comment 27 Erwan 2016-11-21 10:07:43 UTC
I confirm the bug is fixed. Congratulations !