Bug Hunting Session
Bug 45470 - dropdown list displays over other application
Summary: dropdown list displays over other application
Status: RESOLVED DUPLICATE of bug 61623
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 15:25 UTC by Terrence Enger
Modified: 2015-05-01 15:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot with dropdown list showing over next application (288.45 KB, image/png)
2012-01-31 15:25 UTC, Terrence Enger
Details
typescript with two backtraces (33.71 KB, text/plain)
2012-01-31 15:27 UTC, Terrence Enger
Details
dropdown lists from two versions of LO displayed over emacs window (254.17 KB, image/png)
2012-03-17 18:20 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2012-01-31 15:25:45 UTC
Created attachment 56417 [details]
screenshot with dropdown list showing over next application

One particular dropdown list under particular conditions displays over
the next application given focus, and the list elements continue to
respond to the mouseover events.


I am running master commit e24a27b (pulled 2012-01-10) on
ubuntu-natty.  My autogen.lastrun shows ...
    --disable-mozilla
    --enable-symbols
    --enable-dbgutil
    --enable-crashdump
    --disable-build-mozilla
    --enable-ext-postgresql-sdbc


To reproduce the problem ...

 1. Run soffice.bin.  Program displays empty Writer document
    "Untitled 1".

 2. Take menu option File > New > Labels.  Program displays tab
    "Labels" of dialog box "Labels".

 3. Click the up-down arrow to expand the drop-down list
    Format > Type.  Program displays the dropped-down list.

 4. Move the thumbwheel to the bottom of the list.  Program displays
    the last several entries in the list, ending with
    "LPT111Laser/Copier Transparency - 100micron".

 5. Use the mouse to bring another application to the front.  I chose
    the version of LibreOffice that comes with my Linux distribution.
    Actual program action: The dropped-down list is visible above the
    activated application, as shown in screenshot attached.  Expected
    program action: The window with control appears "above" the
    Labels dialog box.

        Accidentally, at this point, I passed my mouse over the top
        displayed item in the dropdown list, selecting it.  Sorry.

        Backtrace is in the attached scriptfile after line 146.


If before step 3 you expand and collapse the dropdown list 
Format > Brand, the first mouse click on the other application
collapses the Type list, and the second mouse click activates the
other application without overlaying dropdown list.  So, to show that
better behaviour, switch back to LibreOffice showing the Labels
dialog, and ...

 6. Collapse the dropdown list Format > Type.

 7. Click the up-down arrow to expand the dropdown list Format > Brand

 8. Click once on the other application.  The program closes dropdown
    list Format > Brand; the other application does *not* come up on
    the screen.

        Backtrace is in the attached scriptfile after line 293.
Comment 1 Terrence Enger 2012-01-31 15:27:50 UTC
Created attachment 56418 [details]
typescript with two backtraces
Comment 2 Terrence Enger 2012-02-02 08:21:57 UTC
I am changing importance to "low" because

(1) The program behaviour is so obvious that it is unlikely to cause
    the user on-going confusion.  Any user with an "other application"
    where serious or persistent confusion is possible can raise the
    importance.

(2) The same problem is evident in (at least) the version distributed
    with ubuntu-natty, which identifies itself in the "About" dialog
    as

        LibreOffice 3.3.4 
        OOO330m19 (Build:401)
        tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.4-0ubuntu1

    and, unless my bugzilla search skills are deteriorating, this is
    the first report.
Comment 3 sasha.libreoffice 2012-03-16 02:36:56 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
And if reproducible, in which desktops: Gnome 2, 3, Unity?
Comment 4 Terrence Enger 2012-03-17 18:20:41 UTC
Created attachment 58628 [details]
dropdown lists from two versions of LO displayed over emacs window

Thank you for reminding me about this.

The problem described in points 1 through 5 of the description is
still evident in master cc32ce4, pulled 2012-02-09.

Contrary to what I wrote later in the description, the problem seems
arise in any dropdown list which has been repositioned using the
mouse.  For your amusement, I am attaching a screenshot of two
dropdown lists: the colour selection is being displayed by LibreOffice
as distrubuted with ubuntu-natty, and the Type selection comes from my
local build.

Synaptic shows that my gnome-desktop-data is version
1:2.32.1-0ubuntu6, and I am using un "Ubuntu Classic" session.  In
"Ubuntu" and "Ubuntu (no effects)" sessions, the behaviour is the
same.
Comment 5 sasha.libreoffice 2012-03-19 02:33:30 UTC
Thanks for additional testing.
For reproduce this in KDE, on step 5 of initial description, use Alt-Tab for switch to another window. With maximized (not fullscreen) windows also reproduced.
Can reproduce this in 3.5.1 but can not in 3.3.4, so possible regression
Comment 6 Caolán McNamara 2012-05-06 15:16:56 UTC
I wonder if this is a duplicate of, or any relation to, bug 48096 ? Which didn't get cherry-picked back to 3-5, so would be fixed in master only.
Comment 7 Terrence Enger 2012-05-07 11:36:20 UTC
I have applied the patch referenced in bug 48096, but this problem persists.  I conclude that they are different problems.
Comment 8 Terrence Enger 2013-06-13 03:42:37 UTC
I see the bug with versions of LibreOffice from 3.3.4 (as provided
with ubuntu-natty) to 4.1.0.0.beta2 and with desktops "Ubuntu Classic
(no effects)" and unity.  So, am adjusting the version in this report
and removing Keyword "regression" and Whitboard "bibisectrequest".

I also notice that the pop-up menu from the Writer document area will
persist over another application's window.  There is, of course, no
question of repositioning within the pop-up menu.
Comment 9 Julien Nabet 2013-11-17 10:29:36 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduce this.

Debian testing updated today with Gnome/Unity.

Low importance but if possible, I would put it as a Most Annoying Bug because:
- it's been there since a while
- it's quite disturbing to see this drop down whereas you're on another app
Comment 10 Terrence Enger 2013-11-18 14:17:11 UTC
I have just confirmed that the bug is still present in a debug build
of master commit 4f134c0, fetched around 2013-11-13 14:17 UTC.

@julien:

FWIW, I think that bug 39838 "It's impossible to alter the username
while opening the document from ftp", for example, might provide a
better return on developer effort.  This problem stops me from trying
to reproduce bug 62981 "FILEOPEN: Speadsheet display nothing in file
xls on ftp sever".
Comment 11 QA Administrators 2015-04-19 03:21:57 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 12 Terrence Enger 2015-04-21 19:41:43 UTC
Thank you for the reminder of this bug report.

The bug persists with my build of master commit 69262e4,
fetched 2015-04-15 21:42Z, configured
    --enable-option-checking=fatal --enable-dbgutil --enable-crashdump
    --without-system-postgresql --without-myspell-dicts
    --with-extra-buildid --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    --enable-online-update --disable-gstreamer-1-0
    --enable-gstreamer-0-10
built and running on debian wheezy.
Comment 13 Terrence Enger 2015-05-01 15:03:38 UTC
This looks like bug 61623.  Setting this bug as the fourth DUP.

*** This bug has been marked as a duplicate of bug 61623 ***