Bug Hunting Session
Bug 45618 - Implement 3d slideshow transition framework also for windows
Summary: Implement 3d slideshow transition framework also for windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Markus Mohrhard
URL:
Whiteboard:
Keywords: difficultyInteresting, easyHack, skillCpp
: 53105 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-04 04:09 UTC by Thorsten Behrens (CIB)
Modified: 2016-02-18 16:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Behrens (CIB) 2012-02-04 04:09:46 UTC
On Linux/Mac, LibreOffice has nice, 3d animated slideshow transitions (see the Slide Transition pane to your right - select one of the last transitions).

It's all opengl in the end, which in principle works on windows, too - just someone needs to hook up the windows opengl specifics (wgl) here:

 slideshow/source/engine/OGLTrans/win/
Comment 1 Florian Reisinger 2012-05-18 09:16:53 UTC
Deteted "Easyhack" from summary
Comment 2 Gerry 2012-08-03 23:07:16 UTC
*** Bug 53105 has been marked as a duplicate of this bug. ***
Comment 3 Gerry 2013-10-01 08:29:31 UTC
Since the addition of 3d transitions on Windows is an enhancement, I changed the bug entry from "normal" to "enhancement"
Comment 4 Björn Michaelsen 2013-10-04 18:48:06 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 5 Markus Mohrhard 2014-08-04 03:37:08 UTC
actually this should be much simpler now as we have a working modern OpenGL context on Windows. I think we can extend this easy hack to move the implementation to use the new OpenGL context in vcl.

The OpenGL context is known to work on Linux and Windows. Mac support is currently under development and should be ready the next days.
Comment 6 Rene Engelhard 2014-08-04 07:29:01 UTC
if you mean that glTF thingy - please no. At least not default.

At least my package builds still do --disable-gltf and that won't change until I get all of those libs packaged sanely *and* implement --with-system-* for them.

the OGLTrans thing for Linux works also without it: https://packages.debian.org/sid/libreoffice-ogltrans, so please don't (well, I don't care, but users might...) break it when changing it ;)
Comment 7 David Tardon 2014-08-04 11:31:30 UTC
(In reply to comment #5)
> actually this should be much simpler now as we have a working modern OpenGL
> context on Windows. I think we can extend this easy hack to move the
> implementation to use the new OpenGL context in vcl.
 
Actually, as the generic impl. (currently only used for UNX) has been changed to use OpenGLContext, it should compile and work on Windows without any change.
Comment 8 David Tardon 2014-08-04 11:34:12 UTC
(In reply to comment #6)
> if you mean that glTF thingy - please no. At least not default.

No, this does not mean glTF. It is just a generic OpenGL support in VCL. (And the 3D-transitions impl. for UNX already uses it in 4.3.)
Comment 9 Markus Mohrhard 2014-08-11 18:32:22 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > actually this should be much simpler now as we have a working modern OpenGL
> > context on Windows. I think we can extend this easy hack to move the
> > implementation to use the new OpenGL context in vcl.
>  
> Actually, as the generic impl. (currently only used for UNX) has been
> changed to use OpenGLContext, it should compile and work on Windows without
> any change.

There are a number of compile errors currently that I'm fixing and a lot of old code that should be replaced. I'm going to take care at least of the pieces that result in compile errors and hopefully this will give us already something useable.

I'll leave a few more comments what can be done as part of this easy hack after I made it compile again.
Comment 10 Markus Mohrhard 2014-08-13 19:08:12 UTC
This has been implemented and seems to be working correctly. I'll open a new easy hack to go through the code and switch to modern (2.0+) OpenGL. At least the efforts will benefit Windows and Linux from now on.
Comment 11 pieter kristensen 2014-11-24 16:40:39 UTC
I really wanted to test this new functionality. But in the Windows version of LibreOffice 4.4 beta 1 there is no trace of it.
It simply is not yet implemented.

At the top of this bug I read: "resolved/fixed" and in comment 10 I even read that is implemented and seems to work correctly. That is strange.
Comment 12 pieter kristensen 2014-12-20 07:11:08 UTC
To my disappointment the 3d slide transitions for Windows appear to be absent too in the first release candidate.
Comment 13 Gerry 2014-12-28 22:09:26 UTC
Hi all, I experience the same problem as described by pieter: 3D slideshow transitions are absent in 4.4 RC1 on Windows. They are not in the list of transitions, at all. Activating all OpenGL/CL related settings in LO options did not help with regard to 3D transitions on Windows.

Thanks in advance.
Comment 14 Gerry 2015-01-13 10:08:42 UTC
As "OpenGL transitions" is an advertised new feature in LO 4.4, which seems to be not working though, I feel free to REOPEN this bug. 

See comment 11, comment 12, comment 13.
Comment 15 Mike §chinagl 2015-01-22 10:52:34 UTC
If this feature is not functional now, it should not be listed in the release notes (https://wiki.documentfoundation.org/ReleaseNotes/4.4) of the coming version 4.4. (release is planned to happen in a few days: https://wiki.documentfoundation.org/ReleasePlan/4.4)

The status of the bug should also be changed by competent people.
Comment 16 Gerry 2015-01-29 18:05:16 UTC
I think it is a bit embarassing that the first line of the release email for LO 4.4 wrongly states: "Support of OpenGL transitions in Windows"

Unfortunately, this bug is still open (as there are no OpenGL transitions on Windows in 4.4 release!!!). Could someone please have a look at this?
Comment 17 Markus Mohrhard 2015-01-30 09:22:23 UTC
(In reply to Gerry from comment #16)
> I think it is a bit embarassing that the first line of the release email for
> LO 4.4 wrongly states: "Support of OpenGL transitions in Windows"
> 
> Unfortunately, this bug is still open (as there are no OpenGL transitions on
> Windows in 4.4 release!!!). Could someone please have a look at this?

That is not true. The feature is working in general but depending on your hardware/driver the transitions will not be available. There is nothing I or anyone can do about that.

There was a bug until one of the early RCs or beta2 where it only worked in developer builds but that has been fixed.

If you have another issue and it is not showing up open a new bug report with details about your graphic hardware/driver. But please note that anything only supporting OpenGL 1 is not supported anymore.
Comment 18 Dave Barton 2015-01-30 14:34:37 UTC
(In reply to Markus Mohrhard from comment #17)
> (In reply to Gerry from comment #16)
> > I think it is a bit embarassing that the first line of the release email for
> > LO 4.4 wrongly states: "Support of OpenGL transitions in Windows"
> > 
> > Unfortunately, this bug is still open (as there are no OpenGL transitions on
> > Windows in 4.4 release!!!). Could someone please have a look at this?
> 
> That is not true. The feature is working in general but depending on your
> hardware/driver the transitions will not be available. There is nothing I or
> anyone can do about that.

It most definitely IS true. Users of a standard Windows installation reading the release email offering this attractive enhancement are likely to unwittingly turn on OpenGL in the Options dialog and finish up with LO being totally unusable.
See my report: Bug 87673

"Working in general" is unacceptable. What's our next PR release going to say "It wonderfully pretty and kind of works SOMETIMES".
Comment 19 Gerry 2015-01-30 19:59:44 UTC
Dear Markus, thanks a lot for the clarification and thanks a lot for your work on the OpenGL part of LO. Now, it is clear to me where the problem is concerning this bug.

Would you agree to add some information on this to the release notes? Something like "(Depending on the hardware/graphics driver the 3D transitions may not be available on some systems)"

And I opened bug 88959 for the Intel HD graphics on Lenovo Thinkpad notebooks. There, the 3D transitions are not available.
Comment 20 Gerry 2015-02-05 11:31:24 UTC
In fact, the 3D OpenGL transitions on Windows work well, if the user activates them in the installation process from the options features "OpenGL transitions for LibreOffice Impress".

Hence, I open bug 89135 which requests the inclusion of the feature in the default install set. (And I closed bug 88959 as NOTABUG)
Comment 21 pieter kristensen 2015-02-11 21:49:25 UTC
Indeed the 3d transitions work excellent under windows now. Super fluently. But during these transitions the screen is white. 
There are no images "in" the transition.
This bug should defentately NOT be closed.
Comment 22 Gerry 2015-02-11 21:54:39 UTC
@pieter:thanks for your comment and observation. Please open a new bug entry for the problems that you encounter. You can link the bugs if you enter this bug 45618 in the "see also" field of the new bug. Please don't forget to give information on your graphics card and driver in the new bug entry. Thanks!
Comment 23 Robinson Tryon (qubit) 2015-12-16 00:41:49 UTC
Migrating Whiteboard tags to Keywords: (EasyHack SkillCpp DifficultyInteresting)
[NinjaEdit]
Comment 24 Robinson Tryon (qubit) 2016-02-18 16:37:31 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]