Bug 87673 - If OpenGL rendering is not available, LO fails to start
Summary: If OpenGL rendering is not available, LO fails to start
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 88800 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2014-12-24 08:02 UTC by Urmas
Modified: 2015-09-05 17:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (5.13 KB, image/tiff)
2014-12-24 11:37 UTC, Urmas
Details
ODT file detailing this issue (63.09 KB, application/vnd.oasis.opendocument.text)
2015-01-30 13:58 UTC, Dave Barton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2014-12-24 08:02:01 UTC
If OpenGL acceleration is enabled but hardware does not support it, LO fails to start silently.
Either error message should appear, or LO should prompt user to disable it automatically.
Comment 1 Yousuf Philips (jay) (retired) 2014-12-24 10:18:27 UTC
@Urmas, could you let us know which hardware you tested this on and how does one enable opengl acceleration.

CCing Markus as he's the OpenGL man. :D
Comment 2 Urmas 2014-12-24 10:23:58 UTC
Settings/View/Use OpenGL for all rendering

In my case that was VirtualBox VM.
Comment 3 Yousuf Philips (jay) (retired) 2014-12-24 11:11:28 UTC
I cant see any setting called 'Use OpenGL for all rendering' in master. Do you have a screenshot?
Comment 4 Urmas 2014-12-24 11:37:01 UTC
Created attachment 111276 [details]
Screenshot
Comment 5 Yousuf Philips (jay) (retired) 2014-12-24 11:46:53 UTC
Thanks for the screenshot. Seems my current build from 12-12 doesnt have it in it but i see it in the latest build. :D

I think it would be good for you to send in a backtrace so someone can see why it silently fails. I've had similar opengl crashes in the past, like in bug 80448.
Comment 6 Markus Mohrhard 2015-01-25 04:08:02 UTC
Don't use that setting right now. We have horrible issues with memory corruption and race conditions.
Comment 7 Dave Barton 2015-01-30 13:58:26 UTC
Created attachment 112955 [details]
ODT file detailing this issue
Comment 8 Dave Barton 2015-01-30 14:06:50 UTC
(In reply to Dave Barton from comment #7)
> Created attachment 112955 [details]
> ODT file detailing this issue

Looks like we have an issue with our self hosted bugzilla. The attachment was sent without the following text comment:

This issue exists in both:
Version: 4.4.0.3 Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
and
Version: 4.5.0.0.alpha0+ Build ID: 309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83
My experience is that LO does not fail to start silently, but opens in a totally unusable state, from which the "average" (non-technical) user cannot recover.
Comment 9 Robinson Tryon (qubit) 2015-02-03 19:09:14 UTC
(In reply to Dave Barton from comment #8)
> This issue exists in both:
> Version: 4.4.0.3 Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
> and
> Version: 4.5.0.0.alpha0+ Build ID: 309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83

Okay,
Status -> NEW

> My experience is that LO does not fail to start silently, but opens in a
> totally unusable state, from which the "average" (non-technical) user cannot
> recover.

(Dave: What you're experiencing might be a different issue, but markus will have more insight here)
Comment 10 Buovjaga 2015-02-04 16:51:52 UTC
*** Bug 88800 has been marked as a duplicate of this bug. ***
Comment 11 Apelsecs 2015-03-25 17:56:09 UTC
I can confirm same problem on my laptop.
here's how it looks like:
https://s.neepic.com/32lLxl2E.png
win7x64, i7 3GHz, 8GB RAM, IntelHD4000 & Nvidia NVS 5200M 1GB, 2 monitors attached to each, 4 in total.
Generally, I can run both OpenGL and DirectX games on this laptop.
Comment 12 Michael Meeks 2015-08-19 12:42:22 UTC
Wrt. focusing on the initial issue here; I believe we need to catch badness, particularly crashes during rendering operations and present a native-dialog on-start / recovery to allow the option of disabling GL. Luckily VCL provides a native dialog API to allow by-passing the necessity of using VCL, and (I hope) we could detect this rather early in the startup cf.

vcl/inc/salsys.hxx:

    virtual int ShowNativeMessageBox( const OUString& rTitle,
                                      const OUString& rMessage,
                                      int nButtonCombination,
                                      int nDefaultButton,
                                      bool bUseResources ) = 0;

Which was previously used to explain accessibility problems rather early in the startup, but seems like a great match for this use-case too.
Comment 13 Michael Meeks 2015-09-03 10:35:10 UTC
My hope is that this is handled by a combination of the white/black lists cf. bug#93662 (pending merge) - and also the crash / hang catching logic we added in bug#93547 and bug#93614.

Thanks for reporting !
Comment 14 Yousuf Philips (jay) (retired) 2015-09-05 17:09:43 UTC
When i enabled 'Use OpenGL for all rendering' and 'Force OpenGL even if blacklisted' and it crashed, it would automatically disable 'Use OpenGL for all rendering' on load but wouldnt disable 'Force OpenGL even if blacklisted' resulting in it not opening. Should i report this as a new bug?

Version: 5.1.0.0.alpha1+
Build ID: cf9fbdb379e2935677a73ced513d7faf855c299c
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-05_00:34:47
Locale: en-US (en_US.UTF-8)