Bug 45658 - Problem with templates
Summary: Problem with templates
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-05 14:14 UTC by Leopoldo Saggin
Modified: 2013-06-28 10:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Window appearing whe I perform some choices (10.36 KB, image/png)
2012-02-05 14:14 UTC, Leopoldo Saggin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leopoldo Saggin 2012-02-05 14:14:37 UTC
Created attachment 56631 [details]
Window appearing whe I perform some choices

Platform & OS: HP Compaq 8200 with Windows 7 Pro 64bit
LibOffice 3.5.0rc3
* User interface language: English
* Local settings: Italian

Situation: updating from LibOffice 3.4.5, which was working perfectly with respect to what I will submit below, it happened this.

First case
------------
I started LibOffice Writer.
In the File Menu I selected Template > Organize
As soon as I did this I heard a sound of warning and a window like the one in the attachment appeared.

Second case
------------
I started LibOffice Writer again.
In the File Menu I selected New > Presentation
The presentation wizard appeared.
I accepted the default (Empty presentation) and clicked on the "Next" button.
As in case #1, I heard a sound of warning and a window like the one in the attachment appeared.

So I uninstalled LibOffice 3.5.0rc3 and reinstalled LibO 3.4.5 *BUT* at this point I had problems also on this version which was ok.

I could re-esablish the normal sitaution only by deleting:
C:\Users\<username>\AppData\Roaming\LibreOffice\3\*.*
and using a backup of that dir and its subdirectories & files.

Leopoldo Saggin
Comment 1 Leopoldo Saggin 2012-02-10 06:29:21 UTC
I retested the problem I had.
This time, instead of UPGRADING LibO from 3.4.5 to 3.5.0rc3 directly, I:
1. Uninstalled LibO 3.4.5
2. Manually deleted what was left both in C:\Program Files (x86)\LibreOffice and in C:\Users\<username>\AppData\Roaming\LibreOffice
This way I lost every personalization I did in previous versions.

At this point I installed v. 3.5.0rc2 in a "clear" environment and this time it did work.
So something is wrong in the upgrade process while it seems ok in an ex-novo installation.

Topoldo/Leopoldo Saggin
Comment 2 Nick 2012-02-13 03:06:09 UTC
confirmed on LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

error appears and file loads correctly when opening a .odt file. No problems with LO 3.4.5
Comment 3 Nick 2012-02-13 03:25:56 UTC
(In reply to comment #2)
> confirmed on LibreOffice 3.5.0rc3 
> Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
> 
> error appears and file loads correctly when opening a .odt file. No problems with LO 3.4.5

sorry, should say .ots/.ott
Comment 4 Leopoldo Saggin 2012-02-13 06:49:33 UTC
I wrote:

> ...
> This way I lost every personalization I did in previous versions.
> At this point I installed v. 3.5.0rc2 in a "clear" environment and this
> time it did work.
> ...

Oops...
I wanted to write:
At this point I installed v. 3.5.0rc3 in a clear....
NOT
At this point I installed v. 3.5.0rc2 in a clear....


Topoldo/Leopoldo Saggin
Comment 5 ryan.jendoubi@gmail.com 2012-03-18 10:24:24 UTC
This bug persists with 3.5.1 (Ubuntu 10.4)

This Bug seems related to:
Bug 45928
Bug 47463
possibly Bug 46240 (this may describe a different aspect to the issue)
Comment 6 stragu 2012-03-26 16:37:32 UTC
Same problem here on 3.5.1 with Ubuntu 11.10.
Comment 7 dE 2012-08-28 14:41:21 UTC
From the comments, problem is cross platform, changing platform.

Not reproducible with 3.5.5.3, please check someone.
Comment 8 ign_christian 2013-06-28 09:43:54 UTC
Looks like WONTFIX according to:
https://bugs.freedesktop.org/show_bug.cgi?id=46240#c4
Comment 9 Florian Reisinger 2013-06-28 10:11:30 UTC
Hi :)
Is this happening with 3.6.x -> 4.x.y or from 4.0.x -> 4.1.x (RC needed). If so, reopen, else WONTFIX. (If I could change the status in 1 step I would put this bug into NEEDINFO status, so please answer to the question ;) )