Bug 45928 - Strange behaviour of the template management dialogue
Summary: Strange behaviour of the template management dialogue
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-11 06:40 UTC by kivi
Modified: 2013-06-08 09:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is a screen capture where you can see what happens (469.13 KB, video/mp4)
2012-02-15 09:09 UTC, kivi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kivi 2012-02-11 06:40:20 UTC
Trying to import some document templates now with Libre Office 3.5.0 RC3 is impossible if you try to use File --> Templates --> Template management.
Starting this way the Templates management from after 2 error messages opens the form for Template management but it is unusable to see available templates nor to manage them nor to import new templates.
Comment 1 Julien Nabet 2012-02-11 14:18:46 UTC
On pc Debian x86-64, 3.5 branch (so not exactly 3.5.0 rc3), I tried this :
File -> Template -> Organize
Template management appears with no specific error messages in console.
Then I can see template in mediawiki for example.

Perhaps I missed something but could you give the error messages ?

Did you uninstall completely previous version (I mean with profile, with backup of it if necessary) before trying this one ?
Comment 2 kivi 2012-02-13 05:03:45 UTC
Unfortunately I will try to reproduce the problem later today or tomorrow.
So until the end of the day tomorrow may be I will be capable to answer.

But as far I remember I had working installations of LibreOffice as it  
comes with openSUSE 12.1 with all patches plus the version 3.4.5,  
version 3.5.0 and the version before it.
Only 3.5.0 had the problem.
I will try to reproduce it again and will try to take screen snapshots too.


Quoting bugzilla-daemon@freedesktop.org:

> https://bugs.freedesktop.org/show_bug.cgi?id=45928
>
> Julien Nabet <serval2412@yahoo.fr> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |NEEDINFO
>                  CC|                            |serval2412@yahoo.fr
>      Ever Confirmed|0                           |1
>
> --- Comment #1 from Julien Nabet <serval2412@yahoo.fr> 2012-02-11   
> 14:18:46 PST ---
> On pc Debian x86-64, 3.5 branch (so not exactly 3.5.0 rc3), I tried this :
> File -> Template -> Organize
> Template management appears with no specific error messages in console.
> Then I can see template in mediawiki for example.
>
> Perhaps I missed something but could you give the error messages ?
>
> Did you uninstall completely previous version (I mean with profile,   
> with backup of it if necessary) before trying this one ?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 3 kivi 2012-02-15 09:09:55 UTC
Created attachment 57107 [details]
This is a screen capture where you can see what happens

This is done with openSUSE 12.1 and LibreOffice.org 3.5.0
Comment 4 kivi 2012-02-17 04:44:13 UTC
A fresh isnstall of openSUSE 12,1 and then deinstallation of the LibreOffice 4.2.x comming with SUSE helped.
After it the installation of LibreOffice.org 3.5.0 worked well - as expected, without my problem.
Probably your solution with renaming the folders will do the same.

Thank you very much for the valuable help and the good hint for solution.
Comment 5 ogladso@gmail.com 2012-02-21 16:43:50 UTC
I can verify a similar behavior problem. You will get a similar error if you try to change the slide template. No templates are visible and an error message stating that the template is already in use will show. Reproducible on 3.5, but not 3.45.
Comment 6 Julien Nabet 2012-03-12 13:06:17 UTC
ogladso: did you remove/backup your LO profile before the test ?
Comment 7 kivi 2012-03-13 05:17:11 UTC
Before the test where I had problems I don'n remove or replace my LO profile. It was not mentioned in the documentation and I never did it with OpenOffice.org and past versions of LO and never got any trouble about it.
Ever the OpenOffice.org had issued instructions to install it keeping this profile to make possible when the new version does install job to collect all user data from the old installation.
Comment 8 ryan.jendoubi@gmail.com 2012-03-18 10:21:38 UTC
This bug persists with 3.5.1 (Ubuntu 10.4)

For me, it also manifests itself in two other situations:

1) Simply opening any document based on a template
2) File -> New From Template...

Julien, when you say "uninstall completely previous version (I mean with profile, with backup of it if necessary)", do you mean deleting all preferences and config settings as well? So far I have tried removing the packages but leaving the prefs & conf as removing these seems like a hassle.

Also, as Krasimir pointed out, no previous update has required removing these, so if that is indeed necessary that in itself should be a bug.

I have installed the last few versions by downloading the .deb archives directly from Libreoffice.org and installing using `sudo dpkg -i ./*.deb`. If you could recommend the most efficient and comprehensive way of removing previous packages installed in this way it could help me test further.

This Bug seems related to:
Bug 45658
Bug 47463
possibly Bug 46240 (this may describe a different aspect to the issue)
Comment 9 Julien Nabet 2012-03-19 13:39:03 UTC
I sent a post about this problem of profile, you can take a look here :
http://nabble.documentfoundation.org/About-buggy-behaviour-which-disappear-when-previous-LO-OOo-is-removed-tp3837359p3837359.html
You'll find some elements here.

ryan: About .deb, if you don't use apt or front-end to apt, I suppose you know what you do and so you know how to find if there are elements from previous install.
About profile, I mean ~/.config/libreoffice, ~/.libreoffice (check both).
Remove (or backup to be sure you can retrieve what you want) them and try again for the test.
Comment 10 QA Administrators 2013-05-26 22:31:23 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 11 kivi 2013-06-08 08:52:20 UTC
wI think this problem was solved.
This is because was found why it happens.
(because it is not possible to make installation of Libre Office and Open Office together. Also it was found some folder after uninstall of the former version stay and need to be deleted in order to prevent this behaviour.)
And because in the installation instructions now is mentioned that older version or the eventually installed OpenOffice.org need to be deinstalled when a new version of LibreOffice.org will be installed.
Following this instructions one can make a fresh installation without the reported problems.
Comment 12 Julien Nabet 2013-06-08 09:29:50 UTC
Krasimir: thank you for your feedback.

Ryan: it could be interesting you give a try to what Krasimir advised.
Another thing, installing via dpkg means you may miss some dependencies. The good way is to use apt or front end to apt (eg: Synaptics). Moreover, if there was a bug about uninstalling on previous version, the bug can be fixed on a new version but the new version can't solve (at least easily) the consequences of the bug in previous version.