Download it now!
Bug 46092 - EDITING: Insertion of Text is not Possible: [a] above Sections, Tables or Indexes at the Top of Text Documents; [b] below Sections or Indexes at the Bottom of Text Documents
Summary: EDITING: Insertion of Text is not Possible: [a] above Sections, Tables or In...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 02:34 UTC by Harald Koester
Modified: 2013-11-11 16:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2012-02-15 02:34:36 UTC
Problem description: 

[A] Problem with sections:
[1] Open a new text document.
[2] Type in some words.
[3] Mark the words. -> [4a] or [4b]
[4a] Insert Section: Insert > Section... > Section > Insert. A section, within the marked words, at the top and at the same time at the bottom of the document is inserted. -> [5a]
[5a] Now there is no possibility to insert text above or below the section. You have to remove the section, to insert a line above/below your text, to mark the text again and to insert the section again. 
Expected behaviour: Possibility to insert text above/below sections at the top/bottom of a document.

[4b] Insert Section: Insert > Section... > Section > Mark "Protect", choose a password and then "Insert". A protected section, within the marked words, at the top and at the same time at the bottom of the document is inserted. -> [5b]
[5b] Equal to [5a] and additional you have to know the password in order to remove the section.
Expected behaviour: Possibility to insert text above/below protected sections at the top/bottom of a document.

[B] Contrary problem with sections, if you like to delete all text above a section:
[1] Open a new text document.
[2] Type in a word, then Enter.
[3] Type in another word and mark this word. 
[4] Insert a section within the marked word and protect the section. 
[5] Now you can delete the word in the first line, but not the line as a whole (paragraph break).
Expected behaviour: Possibility to delete the complete line above a protected section.

[C] Similar problem with tables:
[1] Open a new text document.
[2] Insert a table (2 columns, 2 rows) at the top of the document: Table > Insert > Table... 
[3] Insert one word into each cell of the table.
[4] Now there is no possibility to insert text above the table. You have to insert a line behind the table, to mark the content of the table, to move the content behind the new line and to delete the original table. A move of the whole table behind the new line is also not possible, hence you can not mark the whole table, if there is no additional character in front of the table.
Expected behaviour: Possibility to insert text above tables at the top of document.
Notice: A contrary problem like with sections does not appear: You can delete everything above a table.

[D] Similar problems with indexes. I checked this behaviour only with a Table of Contents. I assume, that the behaviour is equal with other indexes. Do this:
[1] Open a new text document.
[2] Insert a heading. Do not create a new line after heading (No Enter!). ---> [3a] or [3b]
[3a] Insert Table of Contents above the heading line: Insert > Indexes and Tables > Indexes and Tables... > Tab "Index/Table", Type: "Table of Contents" > OK. ---> [4a]
[4a] Now there is no possibility to insert text above the Table of Contents. You have to delete the table, to insert an empty line and to insert the table again after the line. If you disable the "protection against manual changes" (context menu of table > Edit Index/Table > Index/Table > Protected ...) it is possible to insert text at the beginning of the table, but not in front of the table.
Expected behaviour: Possibility to insert text above a Table of Contents at the top of a document.

[3b] Now the cursor should be positioned at the end of the heading and there is no line below the heading. Keep the cursor there! Insert Table of Contents: Insert > Indexes and Tables > Indexes and Tables... > Tab "Index/Table", Type: "Table of Contents" > OK. ---> [4b]
[4b] Now there is no possibility to insert text below the Table of Contents. You have to delete the table, to insert an empty line and to insert the table again above this line. If you disable the "protection against manual changes" (context menu of table > Edit Index/Table > Index/Table > Protected ...) it is possible to insert text at the end of the table, but not below the table.
Expected behaviour: Possibility to insert text below Table of Contents at the bottom of a document.
Notice: A contrary problem like with sections does not appear: You can delete everything above a Table of Contents.

              
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.26) Gecko/20120128 Firefox/3.6.26
Comment 1 sasha.libreoffice 2012-05-18 07:24:23 UTC
Thanks for bugreport. Situation in 3.5.3:
A: not reproducible, Alt-Enter works perfectly
B: reproducible or I can not find how to delete new line before section
(as workaround, change font size of this line to 2)
C: Not reproducible. Use Alt-Enter for entering new line and Ctrl-A (2 times) for selecting all table.
D: reproducible or I can not find how to add new line before TOC
(as temporary workaround, select this TOC in Navigator, remove "Read only" mark and add new line)
Comment 2 Harald Koester 2012-07-03 08:23:40 UTC
Hi Sasha,

during my first trials I did not know the short cut Alt+Enter. So I failed to insert new paragraphs before and after sections, tables and TOCs. As mentioned from you, Alt+Tab works fine at the beginning and the end of sections and tables and also at the end of TOC. But not at the beginning of a TOC. I also did not find another short cut for this purpose. So I think this a bug and should be corrected.

In order to avoid such problems I have had, there should be a more intuitional possibility to insert paragraphs before and after sections, tables and indexes, if they are positioned at the beginning and the end of text documents. I wrote a proposal for this issue. See bug 51689.

Case [C]: I checked this problem again with Win7 and LO 3.5.3. With cursor at the beginning of the first cell of table and "Alt+Enter" a paragraph above the table is inserted. So far OK. It seemed to be, that this problem has been fixed meanwhile. But if you press only "Enter", also a paragraph is inserted above the table and not inside the first cell of the table. Hint: "Enter" has no reaction, if the first cell is protected.

I also checked deleting text above sections and TOCs at the beginning of a document again. If a section is protected, it is still not possible to delete an empty line above the section. Also an empty line at the beginning of the document and above a TOC, which is "protected against manual changes", can not be deleted. In both cases I expect the same behaviour as with tables: If with the cursor is positioned in the empty line, pressing "Del" will delete this  line, even if the section/TOC is protected.
Comment 3 sasha.libreoffice 2012-07-06 05:06:40 UTC
Thanks for additional testing
> But if you press only "Enter", also a paragraph is inserted above
> the table and not inside the first cell of the table.
It done for compatibility with msWord. It is not a bug.
Comment 4 Robert Großkopf 2013-08-25 16:24:45 UTC
It isn't possible to change a status of a bug-description, which contains many different bugs.

I started to search how to insert text before a section at the top of the document. I read the help an see, that it works like the help says. Then I started to search the same for tables. Read the help, works. So: How should anybody handle such a bug-description?

Please report a new description for everything which doesn't work - not one description for more than one bug. And then close this bug-description.
Comment 5 Harald Koester 2013-11-11 16:31:41 UTC
Bug splitted to 6 different bugs: bug 71495, bug 71496, bug 71499, bug 71500, bug 71501, bug 71503.

All other problems mentioned in this report are not bugs. Hence status set to NOTABUG.