Bug Hunting Session
Bug 71501 - EDITING: “Enter“ in first Cell of Table Creates a Paragraph above Table
Summary: EDITING: “Enter“ in first Cell of Table Creates a Paragraph above Table
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
Depends on:
Blocks: Writer-Tables 129201
  Show dependency treegraph
 
Reported: 2013-11-11 15:31 UTC by Harald Koester
Modified: 2019-12-05 11:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2013-11-11 15:31:22 UTC
Problem description: 

Steps to reproduce:
[1] Open a new text document.
[2] Insert a table (2 rows, 2 columns).
[3] Insert a word into first cell of table.
[4] Move cursor in front of the word.
[5] “Enter“ in order to create a new paragraph inside the cell. A paragraph above the table is created. Expected: New paragraph inside cell. 

Hints: A paragraph above table can be created with Alt+Enter. See also enhance proposal in bug 51689 according creating paragraphs above and below of tables, indexes and sections.

Operating System: Windows 7
Version: 4.1.2.3 release
Comment 1 Jean-Baptiste Faure 2013-11-16 22:31:50 UTC
Reproducible with the master, 4.1.4.0.0+ and 4.0.6 under Ubuntu but only if the table is at the top of the document ie there is not a paragraph before the table. I think this precision was implicit in the bug description. 

Best regards. JBF
Comment 2 QA Administrators 2015-04-19 03:21:42 UTC Comment hidden (obsolete)
Comment 3 Gordo 2015-04-19 14:10:19 UTC
Still reproducible.

Additionally, the paragraph is created with the Text Body style.  Using Alt+Enter creates a paragraph with the Default Style.

The table doesn't have to be at the beginning of the document.  If you insert a table directly after another table and place the cursor in the first cell of the second table before any text, then pressing Enter will insert a paragraph before the table with the Text Body style.

Windows Vista 64
Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 4 Xisco Faulí 2017-09-29 08:50:44 UTC Comment hidden (obsolete)
Comment 5 Jean-Baptiste Faure 2017-10-28 14:10:12 UTC
Still reproducible with current master, but I am not sure if it is still a bug because help for master says:

Inserting Text Before a Table at the Top of Page
If you want to insert text before a table that is at the top of a page, click in the first cell of the table, in front of any contents of that cell, and then press Enter or Alt+Enter.
To insert text after a table at the end of the document, go to the last cell of the table and press Alt+Enter.

Best regards. JBF
Comment 6 Harald Koester 2017-11-01 10:52:08 UTC
(In reply to Jean-Baptiste Faure from comment #5)
> Still reproducible with current master, but I am not sure if it is still a
> bug because help for master says:
> 
> Inserting Text Before a Table at the Top of Page
> If you want to insert text before a table that is at the top of a page,
> click in the first cell of the table, in front of any contents of that cell,
> and then press Enter or Alt+Enter.

It may be that the current function is intended. But I think it's not logical that the function of the Enter key changes in the first cell of a table when the table is at the top of the page. Hence for me still a bug.

Best regards.
Comment 7 QA Administrators 2018-11-02 03:51:12 UTC Comment hidden (obsolete)
Comment 8 Timur 2018-11-05 16:33:00 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2019-11-06 03:31:15 UTC Comment hidden (obsolete)
Comment 10 Jean-Baptiste Faure 2019-11-17 11:32:56 UTC
It should be decided if this is a bug or not, according to comment #5. So added needsUXEval keyword.

Best regards. JBF
Comment 11 Timur 2019-11-17 15:47:58 UTC
What JBF wrote in Comment 5 was at https://help.libreoffice.org/4.4/Writer/Inserting_Text_Before_a_Table_at_the_Top_of_Page and it mentioned Enter and Alt+Enter (with difference from Comment 3). 
Now it's in https://help.libreoffice.org/6.4/en-US/text/swriter/01/05090100.html?DbPAR=WRITER#bm_id3154762 but it only mentions ALt+Enter.
Inherited. I'm not sure what to do. But it's trivial to avoid that Enter and maybe a nice surprise for someone who never knew about this. So maybe more NotABug.
Comment 12 Harald Koester 2019-11-28 11:41:21 UTC
Checked with version 6.3.3. Bug still exists. Furthermore there are also problems with Ctrl+Enter and Alt+Enter. Do this:

[1] Open a new text document.
[2] Insert a table (2 rows, 2 columns).
[3] Insert a word into first cell of table.
[4] Move cursor in front of the word.
[5] Ctrl+Enter in order to insert a new page in front of the table. Nothing happens.
[6] Alt+Enter. Now a new page in front of the table is inserted. Expected: Insertion of a new paragraph in front of the table.
Comment 13 Timur 2019-11-29 08:01:25 UTC Comment hidden (me-too)
Comment 14 Timur 2019-11-29 08:02:45 UTC
Harald in Comment 12 made it more complicated than it is. 
We all confirmed behavior, but mostly don't consider "Enter" a bug.
I don't know where "Ctrl+Enter" comes from and why it's mentioned, why it would do something.
UX also needs email in CC, I add now. 
My take is: convert this to Documentation to add "Enter" in addition to "Alt+Enter". Because Alt+enter is not obvious, so good addition. And MSO has similar behavior for both Enter and Alt+Enter. While Ctrl+Enter makes page break.
Comment 15 Heiko Tietze 2019-12-02 09:34:28 UTC
Ctrl+enter is placed before the table but becomes not active until a first character is inserted via at+enter.
The documentation part should have been solved with bug 112804. Bug 105333 and 84806 discuss the same/similar topic, and was solve recently by Lazlo.

Harald created also the duplicate bug 71503, one is the generic issue and the other his expectation (enter at the very first item at the table behaves special). And this is actually a question to me. Once enter at position 0 of the table adds a paragraph above, the workaround to insert a break at position 0 could be to insert a space first. Sounds reasonable simple to me, rather to point users to the documentation and to learn alt+enter. And it sounds much better than the proposed solution in bug 51689.

We should investigate how alt+enter is implemented (likely hard-coded) and free this shortcut for customization.
Comment 16 Heiko Tietze 2019-12-05 08:08:10 UTC
Enter at the very first position in the table adds the break before it now. Tested with 

Version: 6.2.8.2
Build ID: 6.2.8-3
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kde5; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 17 Mike Kaganski 2019-12-05 08:10:17 UTC
(In reply to Heiko Tietze from comment #16)

"FIXED" means there's a commit fixing it is known. Please mention it (since there's no commit notification). Thanks!
Comment 18 Heiko Tietze 2019-12-05 08:17:44 UTC
(In reply to Mike Kaganski from comment #17)
> "FIXED" means there's a commit fixing it is known. Please mention it (since
> there's no commit notification). Thanks!

I'm not QA and do not have a commit ID. Feel free to change the reason to anything else, maybe WFM.
Comment 19 Cor Nouws 2019-12-05 09:08:16 UTC
there is a good reason for the current behavior. And if a user wants to set a new paragraph in the given example, it will be possible quite simple. So let's keep it this way.
Comment 20 Timur 2019-12-05 09:42:07 UTC
Per
https://bugs.documentfoundation.org/page.cgi?id=fields.html#bug_status WFM is when used to be a problem that cannot be reproduced anymore. 
This is WontFix meaning Wont Do, not meaning that fix is needed.
Comment 21 Mike Kaganski 2019-12-05 10:08:43 UTC
Heh, the last changes to the bug make it totally confusing.

Description in comment 0 makes clear that pressing Enter in the beginning of the first cell created paragraph before the table, not before the text but inside the cell - which was the desired (and I agree).

Comment 16 claimed that the problem from OP was not reproducible anymore; and it's false statement - because it's still reproducible when the table is in the beginning of the document (but not in other positions in the document).

Comment 19, when made it WFM, stated some "good reasons" for current behaviour - without mentioning those; and overall the comment made an impression of WF resolution, without making clear who made that decision.

So comment 20 now set the bug in the state consistent with the wording of comment 19 - but the questions are unanswered.
Comment 22 Timur 2019-12-05 11:52:15 UTC
I don't understand what's not clear. 
Bug report "Expected: New paragraph inside cell." Won't Fix. Trivial to type space and enter for that. 
ENTER creating paragraph above the table is useful, simple, similar to MSO. 
I don't find further discussion useful.