Bug 46256 - CRASH when PDF export
Summary: CRASH when PDF export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-02-18 10:07 UTC by skadish1
Modified: 2012-05-05 09:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document witch causes libreoffice to crash on PDF export (15.87 KB, application/vnd.oasis.opendocument.text)
2012-04-16 04:12 UTC, Evgeny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skadish1 2012-02-18 10:07:34 UTC
Hi, I have been using LibreOffice since the start, almost exclusively Writer. I usually produce PDF versions of the texts I write after I finish them.

I installed LibreOffice 3.5 on a Windows 7 computer soon after it became available, and since then the program crashes every time I press the button to create a PDF.

The texts I produce are relatively short (average 10-20 pages) and simple (few if any graphics, tables, etc.).

In the meantime I have gone back to LibreOffice 3.4.5, which did and still does work fine with no glitches or crashes.
Comment 1 Ivan Timofeev (retired) 2012-02-19 10:07:59 UTC
Could you provide a document to reproduce the problem, please?
Comment 2 Evgeny 2012-04-16 04:12:17 UTC
Created attachment 60056 [details]
Document witch causes libreoffice to crash on PDF export
Comment 3 Evgeny 2012-04-16 04:20:17 UTC
I have windows 7 with LibreOffice 3.5.1.2 
Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66

And I experience the same problem as described above.
The only difference is my document is in Hebrew.
Comment 4 manj_k 2012-04-17 14:54:09 UTC
(In reply to comment #3)
> I have windows 7 with LibreOffice 3.5.1.2 
> Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
> 
> And I experience the same problem as described above.
> The only difference is my document is in Hebrew.


(1) Tried with LibO 3.5.1.2 (on WinXP 32b)
- Writer (Untitled 1) > File > Open > 'test.odt' (your attached file)
- Crash (FILEOPEN)

(2) Tried with LibO 3.5.2.2
- Writer (Untitled 1) > File > Open > 'test.odt' (your attached file) [OK]
- File > Export as PDF... [OK]

Works for me with LibO 3.5.2.2.
Comment 5 Sandy Kerr 2012-04-18 23:22:13 UTC
Working from Win 7 64 bit on  AM64 six core platform and Intel 64 quad core Q6600. LO 3.5.2.2 Writer crashes with both button and export menu (various settings).
May be related to hidden formatting copied from web or an online .pdf file as I have had some success after removing all formatting from text and re-formatting within LO. This had begun happening with LO 3.4.5 and did not change after un-install, directories removed, and clean install of 3.5.2.2. Doesn't affect Calc .pdf exports for us so far.

This is a major headache as almost all of our output leaves our office in .pdf format. Currently working around this issue by using print to .pdf instead, too clumsy to use except briefly.

Any other suggestions?
Comment 6 Sandy Kerr 2012-04-18 23:33:05 UTC
Have just downloaded and tested the test document (in Hebrew) which opened, displayed and exported to .pdf for me without any problem.
The bug persists with other documents...puzzling!
Comment 7 Evgeny 2012-04-19 06:04:20 UTC
For me updating to LO 3.5.2.2 solved the issue.
Thanks :)
Comment 8 Xavi Escriche Galindo 2012-04-20 14:49:20 UTC
[Not reproducible] with "LibreOffice 3.5.2.2 - Mac OS X 10.5.8 (32bits) Catalan UI"
Comment 9 Jose Manuel 2012-04-21 15:12:39 UTC
[Not Reproducible] with "LibreOffice 3.3.4 - Ubuntu 11.04 (32bit) Spanish UI"
Comment 10 Roman Eisele 2012-04-22 02:02:02 UTC
Changing Platform from 'MacOS' to 'Windows', because everybody who confirms this problem works on Windows (original description, comment #3, comment #4, comment #5).

Changing Version back to LibreOffice 3.5.0 Release, as it was in the beginning, because the Version picker should show the earliest (!) version in which the problem appeared, not the last one.
Comment 11 Roman Eisele 2012-04-22 02:06:56 UTC
Similar to bug 47511 - "PDF: Writer: exporting a document as pdf file will crash Writer". But it is hard to say whether this is the same bug or just a similar one. So I don't think we should mark one of these bugs as duplicate.
Comment 12 Roman Eisele 2012-04-22 02:40:48 UTC
[Not reproducible] with LibreOffice 3.5.2.2 (Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f), German UI, running on MacOS X 10.6.8, German UI, with Evgeny's sample document: exported to PDF without problems.

Therefore, as far as I see, the only comment which still mentions the problem with LibreOffice 3.5.2 (!) is comment #5 by Sandy Kerr. Howevery, Sandy Kerr mentions in comment #6 that she could export Evgeny's sample document without problems. So the problem mentionend by Evgeny in comment #2 and #3 with LibreOffice 3.5.1 seems to be fixed in LibreOffice 3.5.2 for everybody (cf. comment #4!). Therefore, it seems probable that the problems mentioned by Sandy Kerr in comment #5 have a different root that the problems mentioned in comment #2, comment #3, comment #4; and, while Evgeny's problem seems fixed with LibreOffice 3.5.2, Sandy Kerr's problems are not.

@Sandy Kerr:
Is it possible for you to provide a sample document like the ones you mention in comment #5, that still crashes when LibreOffice 3.5.2 when you try to export it as PDF? If your documents contain confidential informations, could you please try to anonymize such a document, I mean, replace confidential information by 'xxxx' or so, in order to get a file which is no longer confidential but still triggers the bug, i.e. still crashes LibreOffice? This would be very very helpful. Thank you in advance!

@skadish1@gmail.com (original reporter):
Could you please try if LibreOffice 3.5.2 still crashes when you export your documents as PDF? It would be very helpful to know if the bug you see is of the kind fixed in LibreOffice 3.5.2 (see comment #7), or if the bug you see still persists in LibreOffice 3.5.2. Thank you in advance!

Keyword 'regression' added, because both the original description and comment #5 tell us that earlier versions did not have this bug.
Comment 13 Vicent Vendrell 2012-04-24 07:55:51 UTC
[Not Reproducible] with LibreOffice 3.5.2.2 - Debian 6.0.3 squeeze (32bit) Catalan UI

[Not Reproducible] with LibreOffice 3.5.2.2 - Win XP (32bit) Spanish UI
Comment 14 Cody 2012-04-28 16:38:26 UTC
LibreOffice 3.5.2.2
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45
Running on Windows 7 Pro, SP1, 64 bit edition

I was unable to reproduce the results. It seems that this bug has been fixed in LibreOffice 3.5.2.2.
Comment 15 Roman Eisele 2012-04-30 09:09:53 UTC
Some more related/duplicate bug reports:
Bug 39041 - "WRITER PDF Export with bookmarks crashes"
Bug 32771 - "Writer crashes while exporting big PDF file."
Bug 46750 - "PDF export crash on ODT document"
Bug 46891 - "CRASH when PDFEXPORT"
Comment 16 Julien Nabet 2012-04-30 10:49:19 UTC
If you haven't already done it, to be sure to be on a good basis, could you (those who have still the problem) try to reproduce the problem with a clean install of last stable version of LO, I mean :
- uninstall LO
- remove or backup LO profile (see http://wiki.documentfoundation.org/UserProfile)
- clean registry with a tool (for example ccleaner which is free)
- install again

If you still got these problems and if you have got some time and are authorized to do so (in professional context), you can try to give more information by following this excellent video :
http://www.youtube.com/watch?v=fppBTs215yc
Comment 17 Rainer Bielefeld Retired 2012-05-03 03:03:14 UTC
NOT reproducible with "Document witch causes libreoffice to crash on PDF export " and "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) (i tested various settings). 

#Comment 16
A very simple way for a test with a clean installation would be to do a Server installation due to <https://wiki.documentfoundation.org/Installing_in_parallel#Windows> (don't forget to modify bootstrap.ini).
Comment 18 Caolán McNamara 2012-05-05 09:36:04 UTC
The only reproducer we've got here is one which is reportedly fixed in 3.5.2.2 while we have reports but no reproducers of crashes on systems where the first attachment works but something else doesn't. We can't progress without a reproducer, so closing :-(

Feel absolutely free to reopen this if there is a reproducer that can be attached here that we can work with