Download it now!
Bug 46635 - FILESAVE Endless loop during autorecovery if format not writable
Summary: FILESAVE Endless loop during autorecovery if format not writable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.2 target:4.2.7
Keywords:
: 69131 71240 71898 72010 72136 74047 76874 83714 85293 85624 (view as bug list)
Depends on:
Blocks: AutoSave-AutoRecovery-Backup mab4.2
  Show dependency treegraph
 
Reported: 2012-02-26 01:06 UTC by Urmas
Modified: 2017-10-07 09:38 UTC (History)
20 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot on 'how to reproduce...' (43.95 KB, image/jpeg)
2014-01-25 12:07 UTC, Luuk
Details
zip file with temporary files (710.15 KB, application/x-zip-compressed)
2014-02-04 04:41 UTC, Robert Gonzalez MX
Details
Strace during one iteration (39.14 KB, text/plain)
2014-04-15 19:02 UTC, Arnaud Versini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-02-26 01:06:51 UTC
If the document being edited has a format in which Writer cannot save, the autosave attempt will cause an endles loop.
Comment 1 Rainer Bielefeld Retired 2012-02-26 03:43:33 UTC
@Urmas:
Please attach a sample document or at least contribute information what document types you are talking about.
Comment 2 Rainer Bielefeld Retired 2012-03-07 21:27:31 UTC
Closing Bug due to reporter's inactivity as WFM.

@reporter:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to <http://wiki.documentfoundation.org/BugReport> (especially BugReport Details)!
Comment 3 Urmas 2012-03-12 21:57:14 UTC
Update: autosave loop can also be caused if there is an error preventing a manual save.
Comment 4 Rainer Bielefeld Retired 2012-03-12 22:41:55 UTC
@Urmas:
Please keep in mind " ... if you can contribute requested additional ..."
Currently your Bug report is completely useless because any relevant information is missing and there is no chance to reproduce it.

May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- Your results with a new user profile
  -- everything else crossing your mind after you read linked texts

Even  if you can not provide all demanded information, every little new information might bring the breakthrough.
Comment 5 ign_christian 2013-06-27 08:21:55 UTC
NEEDINFO per comment 4
Comment 6 Urmas 2013-09-14 14:16:15 UTC
Marking as new as all necessary information has been given.
Comment 7 Urmas 2013-11-05 17:46:07 UTC
*** Bug 71240 has been marked as a duplicate of this bug. ***
Comment 8 Linus Drumbler 2013-11-07 20:54:43 UTC
Steps to reproduce (at least, I assume): open a document in Writer or Calc (I also experienced this bug in Calc), make some changes, and leave it open for a while without saving to a file. Eventually it will begin to autosave infinitely.
Comment 9 Urmas 2013-11-15 11:08:17 UTC
*** Bug 71625 has been marked as a duplicate of this bug. ***
Comment 10 Jorendc 2013-11-25 12:09:35 UTC
*** Bug 71898 has been marked as a duplicate of this bug. ***
Comment 11 Jorendc 2013-11-25 12:10:49 UTC
Also reported on Linux (see bug 71898). And I think Bug 69131 is also a dupe of this one (can someone please verify?).

Kind regards,
Joren
Comment 12 43884928 2013-11-25 19:19:20 UTC
"If the document being edited has a format in which Writer cannot save, the autosave attempt will cause an endles loop."
i dont understand : That was a new document, in office calc, not yet saved and whith no name !
Comment 13 43884928 2013-11-25 19:21:52 UTC
i discover that when you save the document (with a name) at the very beginning of jour work, then there is no more endless loop...
Comment 14 Urmas 2013-11-25 22:51:15 UTC
*** Bug 72010 has been marked as a duplicate of this bug. ***
Comment 15 Petar Velkovski 2013-11-25 23:38:20 UTC
Urmas, how about instead of trying to list every setting option I have set in Libreoffice, I just zip the whole libreoffice configurations directory, this might be the wiser and is also easier thing to do, at leat when Libreoffice on linux is concerned.
Then some of the developrs will have to back up their settings and use mine insted since this bug is triggered with just starting the Writer applications and trying to work on a new document. I'll also add some 4-5 steps that could possibly lead to entering the endless loop.
Would that work?
Comment 16 Jean-Baptiste Faure 2013-12-21 23:15:18 UTC
*** Bug 72136 has been marked as a duplicate of this bug. ***
Comment 17 Jean-Baptiste Faure 2013-12-21 23:17:41 UTC
Set component to LibreOffice as it concerns not only Writer.

Best regards. JBF
Comment 18 43884928 2013-12-22 00:39:49 UTC
i am very disgusted about libre office.
1 : it is not possible to ask anything in french.
2 : i receive a lot of undesired mails from thjis site.
3 : the bug that i descibed is a know bug and  no one propose a solution ! ! !

I have uninstalled libre office and i have buy microsoft office, That 's MY solution.
4 : i dont want to receive any mail from this site : no way !

You are not professionals !
Comment 19 Linus Drumbler 2013-12-22 00:42:24 UTC
I'm sorry you feel that way, lebi@outlook.com. You can disable emails by going to your account preferences (the "Preferences" link at the top of the page).
Comment 20 retired 2013-12-22 12:14:28 UTC
43884928@opayq.com it’s all a matter of preferences. Set your account properly and you will not receive any mails. I’ve now removed your mail from this bug. No more mail will arrive.

Urmas: Does this persist with LO 4.2.0.1? Without a test document I find this hard to reproduce.

Please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information.

A step-by-step description of how to reproduce the issue is most helpful and will help to speed up the processing of this problem a lot.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 21 Jean-Baptiste Faure 2013-12-22 12:28:49 UTC
Hi Foss,

I encountered the same bug with version 4.1.x and a test document is irrelevant in this case because endless loop occurs for unsaved documents ("Untitled 1").
The problem is that I am not able to say what trigger the endless loop.

Best regards. JBF
Comment 22 Arnaud Versini 2013-12-22 12:55:32 UTC
Hi,

Same for me, modify the delay to 1 or 2 min, create a writer document and wait, in few minutes, will make an infinite loop, or not. No trigger currently detected.
Comment 23 Maxim Monastirsky 2013-12-22 12:59:24 UTC
Same here with 4.1. The trigger is Tools->Options..->Load/Save->General->Automatically save the document too. With unsaved document it saves many copies under 'backup' folder of the user profile.
Comment 24 Arnaud Versini 2013-12-22 13:36:16 UTC
Hi,

The problem is this is not all times. doing that on my machine not always reproduce the bug. No idea for a all time trigger
Comment 25 Petar Velkovski 2013-12-23 02:16:20 UTC
Firs of all. I would like to notice that it seams that a person has to be a bit rude in order to get any response over here, at least when this bug is concerned. 

In Comment 15, I offered to send my settings, but i didn't get any feedback (whether it is a good or bad idea). Since I have a big document to work on (graduation paper/work), I've decided to erase the previous LibreOffice settings, as this is fairly simple under Linux.

I've configured the basic settings and set Save AutoRecovery information every X minnutes to 2 minutes.
This didn't trigger the bug.

Then I've set Tools->Options..->Load/Save->General->Automatically save the document too (Comment 23 from Maxim Monastirsky) and this time the bug was triggered.

So anyone trying to trigger the bug, should try with that setting.

If that doesn't work for you (the bug is still not triggered), I can propose that you also try setting Language Settings->Languages->Default languages for Documents to something else that the default setting. In my case I use Macedonian, as for the first time since LO 4.1 this allows fonts to be rendered with respect to the locale set (inroduced in LO 4.1 and mentioned in the release notes). Other than that, the other settings I have changed are milimetres to be used instead of inches, and  the graphic cache to be 100MB, instead of 20MB.

After that insert some picture into your document, insert some table, write some text, the bug should be triggered very fast (probably after 2 minutes from starting to work on your document).
Comment 26 johnmking_uk 2014-01-11 20:33:23 UTC
I can confirm that this bug occurs in:

Opensuse 12,3
both KDE 4.12 (but also occurred with 4.11)
and Gnome 3.6.2
Libreoffice 4.1.4.2 (also occured with 4.1.3)

in Kubuntu 13.1, Xubuntu 12.04, with the same version of Libreoffice.

It doesn't seem to happen in Windows XP Windows8, but I haven't been able to run extensive tests on these OS's.

If the setting 'Automatically save the document too' is ticked in Tools-Option-Load/Save-General and a file is created in writer or calc, but not saved and thereby given a file name, then at the end of the period set in Tools-Option-Load/Save-General for saving autorecovery information, libreoffice saves, and then keeps on saving every 5-10 seconds, with the result that the ~/.config/libreoffice/4-suse/user/backup/ directory builds up a series of untitled -n.odt files.

Sometimes, and in particular when both calc and writer are open with untitled files, the saving becomes so frequent that the program is unmanageable and has to be killed.
Comment 27 cleyfaye+lo 2014-01-12 19:36:49 UTC
Regarding the issue described in the previous comment, I did the following test in a different environment:

As a quick test on my current computer (Windows 7 64Bit, LO 4.1.4.2) I did this:
- Set autosave to 1 minute
- Check the "save document too" option
- Open a new blank writer document
- Type a few words​​
- Wait a minute. It created an untitled_1.odt file in the backup directory, and nothing else
- Typed a few more words
- After a while, the backup file updated. No extra files where created, and LO doesn't seem to go crazy with I/O either.

Either this issue depend on some specific settings/situations, or it is platform dependant. 

Additionnaly, on a Debian system (with only LO 4.1.3.2) I observe the same behavior: a single file named untitled_0.odt is created, and is only updated every minutes or so.
Comment 28 johnmking_uk 2014-01-13 21:02:30 UTC
I've now done further tests with the distributions I have easy access to.

In the case of both the ubuntu-based distributions and opensuse KDE and Gnome, Libreoffice was installed from the distribution repositories (as recommended on the Libreoffice web site). In all these cases, ticking
Tools-Option-Load/Save-General-Automatically save the document too
results in the constant saving.

However, in Kubuntu and Opensuse 12.3 - Gnome, I deinstalled the repository provided version and installed the versions from the Libreoffice website to see if there was any difference. Libreoffice was run with completely new profiles, and on first run worked fine, not showing any constant saving. However, after logging out and logging in and rerunning the test, the same constant saving occurred on every subsequent occasion, so it doesn't seem to be repository version specific.
Comment 29 Jean-Baptiste Faure 2014-01-25 11:37:28 UTC
*** Bug 74047 has been marked as a duplicate of this bug. ***
Comment 30 Luuk 2014-01-25 12:07:21 UTC
Created attachment 92768 [details]
screenshot on 'how to reproduce...'

I was able to reproduce this bug on Windows7, LO release 4.4.4.2

steps to reproduce
1) Tools/Options/'Load/Save'/General: 
         check 'Save AutoRecovery information every 1 minute'
         check 'Automatically save the document too'
2) type some text (i.e. 'test'), select it
3) wait (1 minute) for the 1st autorecovery-doc to be created
3) from the menu 'Format/Character/Font Effects', change 'Font color', but do not select is (see attachment)
4) wait 2 minutes.
5) press 'Cancel'
Comment 31 Luuk 2014-01-25 12:09:35 UTC
oops, typo, the version number should be 4.1.4.2, not 4.4.4.2
Comment 32 Luuk 2014-01-26 15:07:46 UTC
Bug 74047 and this bug are indeed 'related', but not duplicate (=not the same)

In bug 74047 a file is created every x minutes (depending on the auto-recovery setting)

This bug is related to the problem of auto-recovery files created constantly (lots of files per minute, depending on the speed of your hard-drive ;)
Comment 33 Robert Gonzalez MX 2014-02-04 04:29:13 UTC
I have noticed this bug since versión 4.1.1, 
With the load save options general save autorecovery information every 1 minute
and automatically save document too,
new file, write some text and wait for the first autosave, then it began every 10 seconds to do a save file.
if you activate the menu tools outline numbering, (o any option that has a window), it began to do the saving, if you cancel the option, it continues doing the saving.
i atach a set of temporary files created in the user backup directory with a secuence number. Please notice the date and time of creation, that confirm the behavior.
It happens with writer, draw and calc.
Comment 34 Robert Gonzalez MX 2014-02-04 04:41:01 UTC
Created attachment 93333 [details]
zip file with temporary files

this happens with draw and calc too.
Comment 35 Teo91 2014-02-10 18:45:16 UTC
*** Bug 69131 has been marked as a duplicate of this bug. ***
Comment 36 Teo91 2014-02-10 18:53:10 UTC
I can confirm this bug in LO 4.2.0 on Windows and Linux.
It happens also in 4.0.x and 4.1.x

This bug can heavy affect User Experience, especially new users: with autosave enabled, LO can go in endless loop potentially every time you use it.

Set importance to HIGH normal.
Comment 37 Luuk 2014-02-13 19:31:49 UTC
I even put it on 'critical' because this bug seems to be around since 3.5...
Comment 38 Luuk 2014-02-13 19:33:01 UTC
(In reply to comment #37)
> I even put it on 'critical' because this bug seems to be around since 3.5...

ooops, i meant 'blocker', but its also critical to solve this asap... ;)
Comment 39 Tomoko Goddard 2014-02-18 06:27:44 UTC
Summary:

Comments #23 describes how to reproduce the bug.

#23: "Tools->Options..->Load/Save->General->Automatically save the document too." 


Comments #21, #26, #28, and #32 include updates 

#21: "...endless loop occurs for unsaved documents ("Untitled 1")."

#26: "...keeps on saving every 5-10 seconds, with the result that the ~/.config/libreoffice/4-suse/user/backup/ directory builds up a series of untitled -n.odt files."

#28: "...deinstalled the repository provided version and installed...Libreoffice was run with completely new profiles, and on first run worked fine, not showing any constant saving. However, after logging out and logging in and rerunning the test, the same constant saving occurred on every subsequent occasion..."

#32: "This bug is related to the problem of auto-recovery files created constantly"


Comment #34 contains attachment showing a set of temporary files created in the user backup directory
Comment 40 Luuk 2014-02-18 20:41:35 UTC
The summary seems to be missing the fact that (as far as i have seen)
the user has to use a menu on the moment the auto-save is triggered.....

This at lease helps in reproducing the bug.
Comment 41 cleyfaye+lo 2014-02-25 12:15:43 UTC
Today, I installed Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Debian 64bit.

And although I was unaffected in previous versions (up to 4.1.4.2), it started happening on Impress. I can see how it is a show-stopper, freezing the whole programe while filling storage.
Comment 42 Björn Michaelsen 2014-04-01 19:49:44 UTC
*** Bug 76874 has been marked as a duplicate of this bug. ***
Comment 43 Luuk 2014-04-11 14:39:40 UTC
LO 4.2.3.3 under Windows 7 still has this bug....
Comment 44 Conley Moorhous 2014-04-11 14:52:15 UTC
I experience this with unsaved documents in LO 4.2.3. I don't mean to add another 'me too', but I want to confirm that it is still present in the latest build.
Comment 45 nwaldyd@yahoo.co.uk 2014-04-15 09:04:55 UTC
I am experiencing this bug too. 

LO Version: 4.1.5.3
Build ID: 4.1.5.3-7.fc19
Comment 46 nwaldyd@yahoo.co.uk 2014-04-15 09:09:46 UTC
Please look at the file at: https://bugs.freedesktop.org/show_bug.cgi?id=77158
Comment 47 Arnaud Versini 2014-04-15 19:02:48 UTC
Created attachment 97422 [details]
Strace during one iteration
Comment 48 Arnaud Versini 2014-04-20 15:22:03 UTC
Can't reproduce it on  4.3.0.0.alpha0+
Comment 49 Arnaud Versini 2014-04-20 16:59:16 UTC
Still on master but less times
Comment 50 Arnaud Versini 2014-04-21 17:24:55 UTC
Seems for me this bug is in http://opengrok.libreoffice.org/xref/core/sfx2/source/doc/docfile.cxx#651
Comment 51 Arnaud Versini 2014-04-26 14:24:33 UTC
There is two different bugs I think :

First is issue if the file format is not writable, this is the original bug. Modified summary according to this.

Second is if the file is not saved, this bug is 4.1+ only, not this bug as it was reported in 2012 before 4.1. This bug is fdo#71625
Comment 52 Robert Gonzalez MX 2014-06-22 01:26:14 UTC
I have tested this with 4.3 RC1 on Win 8, and it is not present.
I created a new writer file, then write some text, configure autosave to 1 minute and open the backup folder to observe the behaviour, and this is the secuence:

File test for autosave
starting al 7:02 pm


saved at 7:03 ok untitled_0odt
saved at 7:49 ok untitled_1odt
saved at 7:57 untitled_0odt
saved at 7:58 untitled_1odt
saved at 8:00 untitled_0odt
saved at 8:01 untitled_1odt
saved at 8:02 untitled_0odt
saved at 8:03 untitled_1odt
saved at 8:04 untitled_0odt

change interval to 4 minutes
starting at 8:06
saved at 8:10 untitled_0odt

It seems that it only saves in two files, not creating a secuence, that's alright.

There was not change int the interval of saving. If no change to the file, no autosaving is performed. So no endless loop.
Comment 53 Reinhard Lamsfuss 2014-06-28 12:27:04 UTC
Bug is still there in Version: 4.3.0.1
Build-ID: 9ed0c4329cf13f882dab0ee8b9ecd7b05e4aafbb
Linux (Debian)

LO creates more than 1K "untitled.odt" autosave files in a quarter of an hour.
Comment 54 Vera 2014-07-08 14:18:10 UTC
Still in Version: 4.3.1.0.0+
Build ID: 30d5ee596d725377cec38cfc99e5d5891b42b35d

Ubuntu 12.04.4 LTS
3.11.0-18-generic x86_64
Comment 55 Vera 2014-07-30 22:31:10 UTC
I just checked the new released LO, but the bug is still in there.

Version: 4.3.0.4
Build ID.: 62ad5818884a2fc2e5780dd45466868d41009ec0
Ubuntu 12.04.4 LTS
3.13.0-32-generic x86_64
Comment 56 Reinhard Lamsfuss 2014-07-31 08:34:26 UTC
Can also confirm that bug is still there:

Version: 4.3.0.4
Build-ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

Debian Version 7.6 (wheezy) (64-Bit)
Kernel Linux 3.2.0-4-amd64
Comment 57 Maxim Monastirsky 2014-08-10 13:08:07 UTC
I commited a fix in Bug 71625 which may fix this one as well. Please test with a daily build that contains that fix, and close the bug if it's fixed. Thanks!
Comment 58 John Russell 2014-09-19 22:30:19 UTC
LibreOffice Version: 4.2.6.3
Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
OSx 10.9 Mavericks

I have this problem too - With Save Autorecovery Information, Save the Document Too and Always Create Backup Copy checked, LibreOffice Calc went into a constant loop of saving the file. 
I think I had been doing something in a LibreOffice menu when it first tried to autosave. When I managed to save it with a name, it stopped the loop.
Comment 59 Urmas 2014-10-21 15:59:42 UTC
*** Bug 85293 has been marked as a duplicate of this bug. ***
Comment 60 Ales 2014-10-23 07:35:18 UTC
Affects me too: LibreOffice 4.2.6.3, Windows 8.1

Steps to reproduce:
1. open new document, start writing but don't save it manually
2. wait for automatic save time (e.g. 5 mins)

Writer starts to autosave the document and tries it over and over again. Saving progress bar blinks repeatedly and all UI is pretty much frozen. When you want to save the document you have to try many times. Ones you save it, everything is all right. Maybe LibreOffice writes someplace where it doesn't have rights or something like that.
Comment 61 m.a.riosv 2014-10-30 01:27:14 UTC
*** Bug 85624 has been marked as a duplicate of this bug. ***
Comment 62 Maxim Monastirsky 2014-10-30 08:08:23 UTC
To avoid further confusion, and since most of the reports here are about the same bug as in (the already fixed) Bug 71625, I think the best is to close this bug. (And the original report is not reproducible anyway. autorecovery actually uses odf regardless of the original format.)
Comment 63 Jean-Baptiste Faure 2015-04-10 07:06:29 UTC
*** Bug 83714 has been marked as a duplicate of this bug. ***