Bug 47011 - Add an auto save option (not auto recovery)
Summary: Add an auto save option (not auto recovery)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Krisztian Pinter
URL:
Whiteboard: target:4.1.0
Keywords: difficultyInteresting, easyHack
Depends on:
Blocks:
 
Reported: 2012-03-06 10:39 UTC by Kohei Yoshida
Modified: 2015-12-16 05:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2012-03-06 10:39:05 UTC
Provide an option to automatically save the document (not save the backup of the document for crash recovery which we already do provide) at specified intervals.
Comment 1 Kohei Yoshida 2012-03-06 10:40:21 UTC
This is an easy hack.  I won't be able to provide code pointers yet, but if you are interested, do ask for a code pointer and I'll do my best to dig into the code to find out.
Comment 2 Jan Holesovsky 2012-05-23 06:38:08 UTC
The implementation of the AutoRecovery is in:

framework/source/services/autorecovery.cxx

Particularly see implts_saveDocs() and implts_saveOneDoc() that implement the saving itself.

The UI of AutoRecovery is here:

cui/source/options/optsave.cxx

Ideally the AutoSave should use the above mentioned code; when turned on (that means, new checkbox to enable AutoSave should be introduted), we would first copy the current document to the AutoRecovery area, and then write directly over the document being edited, instead of writing to the AutoRecovery area as it is now.
Comment 3 Michael Stahl (CIB) 2013-02-05 22:10:57 UTC
"write directly over the document being edited" sounds awful, wouldn't it be better to write to a temp file and rename that over the file being edited?

at least i hope we're doing that kind of thing when saving...
Comment 4 Commit Notification 2013-03-07 09:14:05 UTC
Krisztian Pinter committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=895898596c72fd14db2abec3aeaab74d583769e5

WIP: fdo#47011 autosave feature



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-03-11 14:44:37 UTC
Krisztian Pinter committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8933f19100adbf9f2601db0f3ac67dd3b1887ef7

fdo#47011 autosave feature



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-03-11 14:57:39 UTC
Krisztian Pinter committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=4337668c56b83d04649591820d2fb243537b7dad

fdo#47011 added autosave help description



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl (CIB) 2015-10-05 09:00:17 UTC
*** Bug 94706 has been marked as a duplicate of this bug. ***
Comment 8 Cor Nouws 2015-10-05 09:37:11 UTC
For the record: 
You can find this in:
Tools > Options > LibreOffice > Advanced .. Expert configuration search AutoSave.

(Submitted bug 94780 for the Help.)
Comment 9 Robinson Tryon (qubit) 2015-12-16 05:27:02 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting)
[NinjaEdit]