Bug 94706 - Libreoffice AUTOSAVE functionality, option to retain last save to protect when a document is closed without saving
Summary: Libreoffice AUTOSAVE functionality, option to retain last save to protect whe...
Status: RESOLVED DUPLICATE of bug 65509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-02 15:14 UTC by Patrick Smits
Modified: 2015-10-05 14:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Smits 2015-10-02 15:14:29 UTC
I just closed a document via keystrokes without saving it. By doing so I lost lost about half a day of work. I though I had set an Autosave, however this was just AutoRecover in Tools, Options, Load/Save. General, "Save AutoRecovery information every x minutes". This option just recovers documents in case of crashes, grrr.

The autosave function in Microsoft Office really saves the original document every 10-15 minutes. So if you close a document without saving it you only loose a few minutes of work.

I guess the AutoRecover function in Libre/Openoffice was implemented because the suite crashed quite a lot. It almost seems as if none of the developers envisioned a use case where the suite would survive a complete working day without crashing ;-)

I really would like to advise the developers to set the priority as high, since more and more governmental agencies and corporations are switching to LibreOffice. The perception of the suite will decrease quite a bit once people loose a significant amount of time due to this missing feature.
Comment 1 Cor Nouws 2015-10-02 15:40:42 UTC
(In reply to Patrick Smits from comment #0)
> This option just recovers
> documents in case of crashes, grrr.

That is what I read in the Help, yes.
Thanks for your help with filing this issue.

Cor
Comment 2 Michael Stahl (CIB) 2015-10-05 09:00:17 UTC
Feature exists since LO 4.1, see bug 47011:

Tools->Options -> Load/Save -> General -> Save -> "Automatically save the document too"

Of course you're still going to lose the work you did since the last
auto-save (up to 15 minutes by default), but i'd claim that's good
enough in case of user error.

*** This bug has been marked as a duplicate of bug 47011 ***
Comment 3 Cor Nouws 2015-10-05 09:28:05 UTC
(In reply to Michael Stahl from comment #2)
> Feature exists since LO 4.1, see bug 47011:
> 
> Tools->Options -> Load/Save -> General -> Save -> "Automatically save the
> document too"

What the * - great joy of expert configuration (not).
Tools > Options > LibreOffice > Advanced .. Expert configuration search AutoSave.
Comment 4 V Stuart Foote 2015-10-05 14:08:57 UTC
Conversion of option to save to .UI (ref optsavepage.ui) with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c0dd406207e42aae4d3dbaca8235cc5ab01bc6b

apparently did not get done correctly.  Setting this duplicate of Bug 65509 - "FILESAVE "Automatically save" is not running" is open against the function.  

Also, not at all clear when setting from Expert Configuration which stanzas would need to be adjusted--and that disconnect between the checkbox in .UI implementation and elements in Expert Config may be the cause of bug 65509.

*** This bug has been marked as a duplicate of bug 65509 ***