Download it now!
Bug 94042 - Improving autorecovery/autosave
Summary: Improving autorecovery/autosave
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0
Keywords: needsUXEval
: 67080 (view as bug list)
Depends on:
Blocks: AutoSave-AutoRecovery-Backup Document-Recovery
  Show dependency treegraph
 
Reported: 2015-09-08 23:54 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-08-12 10:09 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-08 23:54:58 UTC
It is always a problem when LO crashes that users will loose data and in order to help reduce that large amount of lost data, i think we should change the autorecovery from 15 minutes to 10.

We should also consider implementing a smart autorecovery algorithm that can work within the set autorecovery time, so that if a user for example stops working on a document for a given amount of time (e.g. 5 minutes), that it smart autosaves. A similar algorithm would also be applied when LO has lost focus from the user (e.g. he switches to his browser to grap a picture to add to his document), that it smart autosaves after a given amount of time. There are many possible scenarios when the smart autorecovery can kick and i think it should possibly take into consideration the amount of time it last took to save and autorecovery save. So if a user is working on a small document and save/autorecovery last took 3 seconds, we could smart autorecovery save if a user hasnt done anything in 1 minute, while if a user is working on a large spreadsheet that takes 30 seconds to save/autorecovery, we could smart autorevoery save if a user hasnt done anything in 5 minutes.

Also it would be useful to save a copy of the last autosaved document when a user closing an application and says not to save the changes. I've personally fallen victim to this because of the switching between windows and linux where the buttons are in different places and also within LO itself as 4.0 has the buttons as Save, Close without saving, Cancel, while master has it as Dont Save, Cancel, Save.
Comment 1 Buovjaga 2015-09-12 17:33:43 UTC
Agree. Setting to NEW.
Comment 2 Cor Nouws 2015-09-14 12:24:57 UTC
Hi Jay,

(In reply to Yousuf (Jay) Philips from comment #0)
> It is always a problem when LO crashes that users will loose data and in
> order to help reduce that large amount of lost data, i think we should
> change the autorecovery from 15 minutes to 10.


Agree - easyHack..

> We should also consider implementing a smart autorecovery algorithm that can
> work within the set autorecovery time, so that if a user for example stops
> [...]  So if a user is working on a small
> document and save/autorecovery last took 3 seconds, we could smart
> autorecovery save if a user hasnt done anything in 1 minute, while if a user
> is working on a large spreadsheet that takes 30 seconds to
> save/autorecovery, we could smart autorevoery save if a user hasnt done
> anything in 5 minutes.

Agree - separate issue?

> Also it would be useful to save a copy of the last autosaved document when a
> user closing an application and says not to save the changes.

Agree - separate issue?
Comment 3 Patrick Smits 2015-10-02 15:01:27 UTC
Hi Cor,

I just entered the last case you mentioned: I closed a document via keystrokes without saving it, I think I've lost about half a day of work. I was under the impression that the autosave function would save me, but boy was I wrong. It's just recovers documents in case of crashes, grrr.

The autosave function in Microsoft Office really saves the original document every 10-15 minutes. So if you close a document without saving you only lose about 10 minutes of work. I guess the function in Libre/Openoffice was needed because the suite crashed quite a lot. It almost seems as if none of the developers envisioned a use case where the suite would survive a complete working day without crashing ;-)

I will file a new bug report. I really would advise to set the priority as high, since with increasing popularity comes increasing responsibility.
Comment 4 Patrick Smits 2015-10-02 15:15:51 UTC
Bug was filed as Bug 94706.
Comment 5 V Stuart Foote 2015-10-02 15:27:00 UTC
Adjusted summary of derivative bug 94706 - Libreoffice AUTOSAVE functionality, option to retain last save to protect when a document is closed without saving
Comment 6 Cor Nouws 2015-10-02 15:31:26 UTC
(In reply to Patrick Smits from comment #3)
> Hi Cor,
> 
> I just entered the last case you mentioned: I closed a document via
> keystrokes without saving it, I think I've lost about half a day of work. I
> was under the impression that the autosave function would save me, but boy
> was I wrong.

I would suggest that you test functionality with test content and not a half day unsaved work ;)
But sad that it happened to you :\

> It almost seems as if none of
> the developers envisioned a use case where the suite would survive a
> complete working day without crashing ;-)

Long ago, way before OOo, I learned to hit Ctrl+S regulary..

> I will file a new bug report. I really would advise to set the priority as
> high, since with increasing popularity comes increasing responsibility.

Of course. Thanks!
Comment 7 Yousuf Philips (jay) (retired) 2015-10-04 20:34:43 UTC
I've put in a patch which i hope is enough to change the autorecovery to 10 minutes. https://gerrit.libreoffice.org/19136

Regarding Patrick's comment, his suggestion is that he wants an autosave option so that he doesnt have to press Ctrl+S often to save his work. I have set a similar option in gedit ( Edit > Preferences > Editor > File Saving > Autosave files every X minutes ). This suggestion is different from my suggestion of keeping the last autorecovered version of a file incase a user wants to recover data he dismissed at closing time.
Comment 8 Yousuf Philips (jay) (retired) 2015-10-13 14:39:32 UTC
So bug 94706 was closed as a duplicate of bug 65509 where it states that an autosave functionality was implemented in 4.1 but never worked correctly, so the autosave checkbox was removed in that bug report from the options dialog until the functionality functions correctly.
Comment 9 Commit Notification 2015-10-13 14:42:18 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2e0b9891764bb4cae6ed9a1b111d9b6dafeee92d

tdf#94042 Change autorecovery & autosave to 10 minutes

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 MM 2015-10-20 20:59:48 UTC
(In reply to Yousuf (Jay) Philips from comment #0)
> It is always a problem when LO crashes that users will loose data and in
> order to help reduce that large amount of lost data, i think we should
> change the autorecovery from 15 minutes to 10.
> 

Well that's all nice that you've changed the default to 10 mins, but the users who need that option could already set that to 10 mins (or any other) before. So for them there's not really a big change.
Comment 11 Bastián Díaz 2015-10-20 23:49:50 UTC
Hello, you might consider using remote file case?

Using remote files, it is not necessary LO crashes, just the internet connection is lost or there is a problem on the server to lose data.

LO would be quite useful to keep a local copy of the file and update the copy in the cloud once you reconnect or save the document in a shorter period (in cloud applications automatic autosave is the default).

Cheers
Comment 12 Yousuf Philips (jay) (retired) 2015-10-21 08:47:55 UTC
(In reply to MM from comment #10)
> Well that's all nice that you've changed the default to 10 mins, but the
> users who need that option could already set that to 10 mins (or any other)
> before. So for them there's not really a big change.

As most users dont change defaults, it useful to have good defaults.

(In reply to Bastián Díaz from comment #11)
> Hello, you might consider using remote file case?

Likely should be submitted as a new bug report, so it can be further discussed.
Comment 13 Bastián Díaz 2015-10-21 14:38:39 UTC
(In reply to Yousuf (Jay) Philips from comment #12)
> (In reply to MM from comment #10)
> > Well that's all nice that you've changed the default to 10 mins, but the
> > users who need that option could already set that to 10 mins (or any other)
> > before. So for them there's not really a big change.
> 
> As most users dont change defaults, it useful to have good defaults.
> 

So why it is not enabled by default backup copies?
Comment 14 Jean-Baptiste Faure 2016-01-10 11:28:53 UTC
(In reply to Commit Notification from comment #9)
> Yousuf Philips committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2e0b9891764bb4cae6ed9a1b111d9b6dafeee92d
> 
> tdf#94042 Change autorecovery & autosave to 10 minutes
> 

Did you really change the default value for _autosave_, that is an option which is disabled by default and hidden (available only from expert configuration)?

Best regards. JBF
Comment 15 Yousuf Philips (jay) (retired) 2016-01-20 20:23:57 UTC
(In reply to Jean-Baptiste Faure from comment #14)
> Did you really change the default value for _autosave_, that is an option
> which is disabled by default and hidden (available only from expert
> configuration)?

Only autorecovery was changed as autosave was disabled by default in bug 65509.
Comment 16 Cor Nouws 2016-04-30 13:56:31 UTC
*** Bug 67080 has been marked as a duplicate of this bug. ***
Comment 17 Robinson Tryon (qubit) 2016-08-25 05:49:31 UTC Comment hidden (obsolete)
Comment 18 Leevanj 2017-02-09 20:01:52 UTC
This would have made a friend and several others lifetime devotees - autosave works fine, unless you haven't saved document, I'd suggest when the autosave time is up - if document hasn't been named yet then the dialog is displayed to do so - would have saved another person a days work ....
Comment 19 Heiko Tietze 2020-08-12 10:09:15 UTC
Request was to run autosave more often, which is done. The "intelligent" autosave feature might be interesting but rather in a different ticket.