Bug Hunting Session
Bug 47944 - Can't insert OLE Object in external application (old title : Unable to insert ods document in Microsoft Word)
Summary: Can't insert OLE Object in external application (old title : Unable to insert...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.0
Keywords:
: 48757 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-27 08:06 UTC by Maxime de Roucy
Modified: 2012-12-12 17:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime de Roucy 2012-03-27 08:06:23 UTC
How to reproduce the bug :
- install LibO and create a simple ods,
- open Microsoft Word,
- insert > Object > "create from a file",
- choose the ods file.
The ods is include as a icon.
- install OpenOffice,
- retry to insert the document in Word.
It works.

I don't know if it's a Word or a LibO bug but I guess it's related to the LibO installer.

I already try to modify the registry to force Word to insert ods files as OLE elements (I tried to match the LibO install to the OpenOffice install) but my modification make Word crash…
Comment 1 Maxime de Roucy 2012-03-27 08:43:47 UTC
In fact, I just try with WordPad and it doesn't work either, so it's not . It seams the whole OLE part of the installer is broken…
Comment 2 Maxime de Roucy 2012-03-28 01:38:28 UTC
- In fact, I just try with WordPad and it doesn't work either, so it's not .
+ In fact, I just try with WordPad and it doesn't work either, so it's not a Microsoft Word bug.
Comment 3 mrmarinelli 2012-04-16 01:40:04 UTC
Hi, i have the same problem.
I try to embed an opendocument in a standalone application that use OLE controls.
I try to embed, link or create new opendocument in a OLE control, but every test fails.
Please, i don't want to install openoffice because i like libreoffice and their philosophy.
Comment 4 Maxime de Roucy 2012-04-16 01:48:50 UTC
It seems it’s related to activex components which have been disabled on the official released since it creates more bug than it solves.
Comment 5 mrmarinelli 2012-04-16 02:07:28 UTC
Thanks for your comment.
So, if i want to embed opendocument in any application or other document, i must install openoffice? Very sad thing...
Comment 6 Andras Timar 2012-04-26 03:58:57 UTC
It is true that embedding OLE objects feature (more precisely the needed registry settings) was bound to the ActiveX component that we don't install by default, but in fact it is not necessary to have that ActiveX component for OLE embedding. 

I'm not sure what problems can occur, if I enable those registry settings unconditionally. Please test.
Comment 7 Not Assigned 2012-04-26 04:04:11 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13ca063c9f32e1ffdbdc409d447d038e69c580a5

fdo#47944 enable insertion of OLE objects into external applications
Comment 8 Andras Timar 2012-05-02 04:50:59 UTC
*** Bug 48757 has been marked as a duplicate of this bug. ***