Download it now!
Bug 48089 - Writer FILEOPEN: some documents does not show some or all images (EMF) in docx file
Summary: Writer FILEOPEN: some documents does not show some or all images (EMF) in doc...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-30 04:41 UTC by Andrey
Modified: 2015-09-07 10:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
7z archive containing files with problems. (2.56 MB, application/x-7z-compressed)
2012-03-30 04:41 UTC, Andrey
Details
Compare EMF fonts in diff. LO versions (279.24 KB, image/png)
2015-05-13 08:23 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey 2012-03-30 04:41:00 UTC
Created attachment 59269 [details]
7z archive containing files with problems.

Problem description: 
Some images (and text after them not visible since 3.5)

Steps to reproduce:
1. Open Document containing images. Some or all not visible at all.
Current behavior:
some images not visible
Expected behavior:
should be visible

Platform (if different from the browser): 
Windows 7 Pro (64-bit) - tested on 2 PC
              
Browser: Opera/9.80 (Windows NT 6.1; WOW64; U; en) Presto/2.10.229 Version/11.62

1) Attached document edited in LibreOffoice, but saved as Word document. saving as ODT - not help. PDF - shows how document should look (generated in MS-Office and exported to PDF)
2) Attached pptx - after editing and saving in LO - since 3.5 image (slide MSC ShipIT environments) not visible. Sendid both before changes (still visible) and after (image not visible).

BOTH - oroginally created in Ms-Office, then edited in LO and saved as Ms documents.
This very critical for me. Please contact if wave fix/workaround.
Comment 1 sasha.libreoffice 2012-04-05 07:40:27 UTC
reproduced problem with attached docx file. It contains emf pictures inside. Writer not shows them. Reproduced in 3.3.4 and 3.5.2 on Fedora 64 bit and in 3.5.1 on Windows 7.
Changing version to 3.3.4 as most early reproducible

@ Andrey
Currently workaround is: find somewhere computer with msOffice 2007 or more new. Opens documents docx, xlsx, pptx and save them to odt, ods, odp. It should not consume much time. Then those documents will work properly.

PS: do not save presentation in Impress to format pptx, otherwise part of content will be lost silently. Save instead to odp or pdf.
Comment 2 Carmelo 2012-12-11 12:27:38 UTC
Me too  I encountered the same problem with some documents produced with Office 2007: in some file there are corrupted images,i.e. wrong dimensions compared to Office,in at least other file I see misplaced images.
I still have the incriminated files and I'll upload if necessary.
Comment 3 Timur 2014-03-25 13:45:29 UTC
I think this bug should split into 3:
- fonts in EMF images in docx are unclear (while EMF images are shown)
- saving docx doc doesn't save EMF images 
- saving pptx doc in LO 4.1.5.3 or 4.2.3.1 doesn't save table colour (while it saves table, unlike in the one attached)
Comment 4 Timur 2014-10-20 15:27:16 UTC
As noted:
1. fonts in EMF images in docx are unclear (while EMF images are shown)
tested again with LO 4.3.2.2, reproduced
bug title changed from "Writer FILEOPEN: some documents does not show some or all images (EMF) in docx file" to "Writer FILEOPEN: fonts garbled in EMF images from DOCX"

2. saving docx doc doesn't save EMF images 
tested again with LO 4.3.2.2, cannot reproduce missing EMF images, must've been fixed
but, saved DOCX has unreadable fonts in EMF, which can still be open clear with double click

3. saving pptx doc in LO 4.1.5.3 or 4.2.3.1 doesn't save table colour (while it saves table, unlike in the one attached)
cannot test again with LO 4.3.2.2 due to Bug 79731
Comment 5 Timur 2014-11-11 21:23:59 UTC
(In reply to Timur from comment #4)
> 3. saving pptx doc in LO 4.1.5.3 or 4.2.3.1 doesn't save table colour (while
> it saves table, unlike in the one attached)
> cannot test again with LO 4.3.2.2 due to Bug 79731

For problem with export to PPTX there are already at least Bug 62255 and Bug 80340.
Comment 6 Timur 2015-05-13 07:55:04 UTC
Background color of table set to dark blue on roundtrip PPTX export: fixed in Lo 5.0.
Comment 7 Timur 2015-05-13 08:23:54 UTC
Created attachment 115546 [details]
Compare EMF fonts in diff. LO versions

The remaining problem here is: 
Fonts in EMF images in "iBox infrastructure development.docx" from attachment 59269 [details] are unclear.
Attached picture compares EMF fonts in diff. LO versions:
Fonts were previewed fine up to LO 3.5.7. From 3.6.0 up to 5.0-dev they are unclear. Roundtrip saving and opening PPTX garbles them even more, as shown here in LO 4.4.3.
EMF can still be open clear with fine fonts by double click on a diagram.
Comment 8 Timur 2015-09-07 10:56:03 UTC
It's unlikely that any bugs of type "multiple problems/bad rendering", will be fixed.
Each issue (section break, paragraph break, text box, picture/WMF/EMF...) should be reported separately, after a search for already reported bugs.
I was wrong to change this bug, so I correct that by closing this one as WFM for the original "some images not visible" and opening a new Bug for fonts problem.