Download it now!
Bug 48402 - EDITING: Misaligned cursor with proportional fonts on OSX
Summary: EDITING: Misaligned cursor with proportional fonts on OSX
Status: RESOLVED DUPLICATE of bug 64957
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: All Mac OS X (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 40212 72677 78289 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-06 14:55 UTC by muelltonne
Modified: 2015-05-11 06:05 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot showing misaligned cursor in arial and times new roman font (107.60 KB, image/jpeg)
2012-04-06 14:55 UTC, muelltonne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muelltonne 2012-04-06 14:55:14 UTC
Created attachment 59607 [details]
screenshot showing misaligned cursor in arial and times new roman font

Problem description: 

Steps to reproduce:
1. write text
2. set letter spacing to expanded by 2.0pt
3. move with cursor through words

Current behavior:
cursor is getting misaligned.

Expected behavior:
cursor keeps aligned.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Ian Stevenson 2012-04-13 22:07:14 UTC
Perhaps related to Bug 40212. I did not follow the steps below but this is occurring for me on Mac OS X 10.7.3 (11D50b), LibreOffice 3.5.2.2.
Comment 2 Vicent Vendrell 2012-04-24 08:38:26 UTC
[Not Reproducible] with LibreOffice 3.5.2.2 - Debian 6.0.3 squeeze (32bit)
Catalan UI

[Not Reproducible] with LibreOffice 3.5.2.2 - Win XP (32bit) Spanish UI
Comment 3 Andrew Harrington 2012-04-25 18:13:52 UTC
Without expanded spacing, I have the same problem on Mac with Lion OS.
I just downloaded latest stable
LibreOffice 3.5.2.2 
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f

Same problem on 3.5.
The issue seems to be specifically with a sequence of space characters in a variable width font like Times New Roman.
No problem with fixed width fonts or an artificial example with no spaces, but if I have set up a layout with spaces, I cannot edit in any reasonable fashion.

In particular in a new document, with Time New Roman 12 font, if I set spaces to be visible, and start entering a sequence of spaces, the last space dot appears further and further to the right of the cursor as I add more spaces, though *logically* the cursor should be at the right end of the spaces.
Comment 4 Linus Gasser 2012-05-28 01:20:42 UTC
Still not solved in

LibreOffice 3.5.3.2 
Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

on MacOSX 10.7.2

For me, a line of spaces looks OK, but if I enter a text like

Il m'est un plaisir de venir auprès de vous pour présenter notre 1ère formation d'enseignants qui

towards the end of the line it get's difficult to place the cursor. Notably around the "'", where it's really one caracter off!
Comment 5 Linus Gasser 2012-05-28 01:23:30 UTC
*** Bug 40212 has been marked as a duplicate of this bug. ***
Comment 6 Ian Stevenson 2012-07-16 22:57:48 UTC
This problem is apparent with "View>Non-printing characters" enabled.

A work around is to de-select "Preferences>Writer>Formatting Aids>Display of>Spaces"
Comment 7 Alex Thurgood 2014-06-04 15:39:07 UTC
*** Bug 78289 has been marked as a duplicate of this bug. ***
Comment 8 Alex Thurgood 2014-06-04 15:41:12 UTC
Upping priority, as it makes typing anything in Writer with proportional fonts an exercise in futility.
Comment 9 Alex Thurgood 2014-06-04 15:42:23 UTC
Tor, any idea who might be our coretext experts ?
Comment 10 Alex Thurgood 2014-06-04 15:44:23 UTC
Edited summary to reflect situation
Comment 11 Matthew Francis 2014-08-17 05:45:02 UTC
Can reproduce on 4.3.0.4, but seems fixed on 4.4 master
Comment 12 Norbert Thiebaud 2014-08-17 08:48:38 UTC
for info: the issue is related to spaced-charaters font (the proportional font is just making thing more easy to see)
or even with non spaced-character if one put more than one space between word.
This has been fixed in 4.4, but the patches are fairly invasive, so not a good or easy candidate for back-port
Comment 13 Norbert Thiebaud 2014-08-17 08:50:25 UTC
and let's be serious here.. this is not 'critical' by any definition of the term... there is no loss of data, no crash....
Comment 14 Alex Thurgood 2014-10-07 10:34:36 UTC
*** Bug 72677 has been marked as a duplicate of this bug. ***
Comment 15 Alex Thurgood 2014-10-07 10:39:14 UTC
(In reply to Norbert Thiebaud from comment #13)
> and let's be serious here.. this is not 'critical' by any definition of the
> term... there is no loss of data, no crash....

We'll have to agree to differ then, because I can assure you that trying to edit a 3 page existing ODT document that showed this behaviour made me switch to Word in order to get my work done.
Comment 16 Adolfo Jayme 2015-05-11 06:05:57 UTC

*** This bug has been marked as a duplicate of bug 64957 ***