Bug 49103 - EDITING: Changing font colour on a bullet list does not change the colour of bullet points or list numbering
Summary: EDITING: Changing font colour on a bullet list does not change the colour of ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 35686 47517 (view as bug list)
Depends on:
Blocks: Impress-Bullet-Number
  Show dependency treegraph
 
Reported: 2012-04-24 03:16 UTC by Dave Neary
Modified: 2015-01-29 10:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A simple document with a bullet list created on a clear background, which is then changed to "grey 80%" (12.60 KB, application/vnd.oasis.opendocument.presentation)
2012-04-24 03:16 UTC, Dave Neary
Details
The same document, after selecting all the text in the bullet list and changing font colour to white (13.20 KB, application/vnd.oasis.opendocument.presentation)
2012-04-24 03:18 UTC, Dave Neary
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Neary 2012-04-24 03:16:59 UTC
Created attachment 60518 [details]
A simple document with a bullet list created on a clear background, which is then changed to "grey 80%"

Problem description: 

Steps to reproduce:
1. Create a bullet list in a light background with text colour set to "Auto"
2. Change slide background to a dark colour - say grey 80% (see test case - note that text colour is not very readable - a different but also annoying bug)
3. Select all the text in the bullet list, and change text colour to something more appropriate - like white

Current behavior:

The bullet points in the list stay mid-grey.

Expected behavior:

I would expect that when I change a background from light to dark with text colour set to "Auto" that the text would automatically become light. In the absence of that, when I select all the text in a bullet list (with Ctrl-A) and change the text colour to white, I expect the bullet points or list numbering to also change colour, as part of the text.
Comment 1 Dave Neary 2012-04-24 03:18:36 UTC
Created attachment 60519 [details]
The same document, after selecting all the text in the bullet list and changing font colour to white

There are two attachments - the "after changing background" and "after changing text colour" documents. This shows both of the unexpected behaviours I observe when using the default text settings in LibreOffice.
Comment 2 Dave Neary 2012-04-24 03:27:10 UTC
*** Bug 35686 has been marked as a duplicate of this bug. ***
Comment 3 Dave Neary 2012-04-24 03:28:40 UTC
In addition to these two problems, there is a third: I have been unable to find any way to modify the colour of bullet points in an existing bullet list. Does one exist? If not, that's a functional gap. If so, it's pretty well hidden!
Comment 4 Thorsten Behrens (allotropia) 2012-04-24 04:06:04 UTC
(In reply to comment #3)
> In addition to these two problems, there is a third: I have been unable to find
> any way to modify the colour of bullet points in an existing bullet list. Does
> one exist? If not, that's a functional gap. If so, it's pretty well hidden!
>
It's "Customize" in the Bullets & Numbering dialog - there's a color dropdown there. Suggestions as to improved discoverability appreciated, though we'd possibly shelve larger UI reworks until we have a better dialog engine...
Comment 5 Thorsten Behrens (allotropia) 2012-04-24 04:09:47 UTC
(In reply to comment #0)
> I would expect that when I change a background from light to dark with text
> colour set to "Auto" that the text would automatically become light. In the
> absence of that, when I select all the text in a bullet list (with Ctrl-A) and
> change the text colour to white, I expect the bullet points or list numbering
> to also change colour, as part of the text.
>
I tend to agree - editeng/source/outliner/outliner.cxx is the place to dig at, specifically Outliner::ImpCalcBulletFont() - there's this pEditEngine->GetAutoColor() call that apparently returns black unconditionally ...
Comment 6 Dave Neary 2012-04-24 04:54:46 UTC
I found a way to modify bullet colour of an existing bullet list. It's not easy.

1. Select all the text in the bullet list
2. Format->Bullets and numbering
3. Tab "Customize" find "Font colour", change to white.
Comment 7 Dave Neary 2012-04-24 04:58:21 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > In addition to these two problems, there is a third: I have been unable to find
> > any way to modify the colour of bullet points in an existing bullet list. Does
> > one exist? If not, that's a functional gap. If so, it's pretty well hidden!
> >
> It's "Customize" in the Bullets & Numbering dialog - there's a color dropdown
> there. Suggestions as to improved discoverability appreciated, though we'd
> possibly shelve larger UI reworks until we have a better dialog engine...

Thanks for the heads-up!

I did notice that when I did that, it only changed the colour of the bullet associated with the current cursor position - if I do not have an active text cursor, it changes the colour of new bullets. But existing ones (including new bullets on existing bullet lists) stay the same. To change all the bullet colours, you need to select all the text (as I say in comment #6).

Thanks again!
Comment 8 sasha.libreoffice 2012-04-25 09:00:21 UTC
@ Dave Neary
Thanks for bugreport
IMHO it is done intendedly that changes color of bullets applied only for selected text. In presentation we need often change only part of list to attract attention of listeners to those particular items of list.
Comment 9 Dave Neary 2012-04-27 13:45:57 UTC
(In reply to comment #8)
> Thanks for bugreport
> IMHO it is done intendedly that changes color of bullets applied only for
> selected text. In presentation we need often change only part of list to
> attract attention of listeners to those particular items of list.

Thanks for your comment Sacha. I definitely get the use-case you're suggestion. However, I think if you've done a Ctrl-A to select all the text in a list that it's pretty clear that you also want the bullets to change colour. Add to this that it's not at all obvious how to modify a style to change the default colour for bullets. Personally I think of the bullet as being part of the text, rather than a separate element.

Dave.
Comment 10 sasha.libreoffice 2012-04-28 01:43:37 UTC
About Ctrl-A You are right.
Comment 11 sasha.libreoffice 2012-04-28 01:45:53 UTC
Workaround: select frame with text instead of text and do Format->Bullets and numbering, change color of list.
Comment 12 Rob Snelders 2012-11-09 20:45:04 UTC
*** Bug 47517 has been marked as a duplicate of this bug. ***
Comment 13 QA Administrators 2015-01-05 17:52:31 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 14 Buovjaga 2015-01-29 10:03:02 UTC
Attached documents look identical -> WFM.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36