Bug Hunting Session
Bug 49179 - FILEOPEN: FILESAVE: Image anchored 'to page' in .doc result in 'to character' when reopening
Summary: FILEOPEN: FILESAVE: Image anchored 'to page' in .doc result in 'to character'...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5 Daily
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
: 61346 123245 (view as bug list)
Depends on:
Blocks: DOC-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2012-04-26 09:35 UTC by Tim Short
Modified: 2019-02-09 09:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test anchor.odt (20.92 KB, application/vnd.oasis.opendocument.text)
2012-04-30 01:13 UTC, Tim Short
Details
test anchor word.doc (19.00 KB, application/msword)
2012-04-30 01:13 UTC, Tim Short
Details
attachment-19632-0.html (3.45 KB, text/html)
2013-05-27 17:22 UTC, Tim Short
Details
attachment-19632-1.dat (1 bytes, multipart/alternative)
2013-05-27 17:22 UTC, Tim Short
Details
Libreoffice Anchor Bug (27-05-2013).doc (326.00 KB, application/msword)
2013-05-27 17:22 UTC, Tim Short
Details
Libreoffice Anchor Bug (27-05-2013).odt (345.34 KB, application/vnd.oasis.opendocument.text)
2013-05-27 17:22 UTC, Tim Short
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Short 2012-04-26 09:35:55 UTC
Objects do not hold the desired anchor position and revert to the default position "Character" when the file is re=opened e.g. an object I wanted to anchor to "Page" defaults to "Character".
Comment 1 Cody 2012-04-29 12:47:35 UTC
Created attachment 60782 [details]
test anchor.odt

LibreOffice 3.5.2.2
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45
Running on Windows 7 Pro, SP1, 64 bit edition

I was unable to reproduce the results. Can you please attach a test file?
Comment 2 Tim Short 2012-04-30 01:13:00 UTC
On 29/04/12 20:47, bugzilla-daemon@freedesktop.org wrote:
Thanks for your prompt reply. I attach two test files one saved as Word 
and the other as ODT. The ODT holds its anchor when the file is 
retrieved, however, the Word reverts to "Character".

Many thanks.

Tim


> https://bugs.freedesktop.org/show_bug.cgi?id=49179
>
> Cody<ctbrk23@gmail.com>  changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|UNCONFIRMED                 |NEEDINFO
>       Ever Confirmed|0                           |1
>
> --- Comment #1 from Cody<ctbrk23@gmail.com>  2012-04-29 12:47:35 PDT ---
> LibreOffice 3.5.2.2
> Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45
> Running on Windows 7 Pro, SP1, 64 bit edition
>
> I was unable to reproduce the results. Can you please attach a test file?
>
Comment 3 Tim Short 2012-04-30 01:13:01 UTC
Created attachment 60783 [details]
test anchor word.doc
Comment 4 QA Administrators 2013-05-26 22:31:29 UTC Comment hidden (obsolete)
Comment 5 Tim Short 2013-05-27 17:22:44 UTC
Created attachment 79855 [details]
attachment-19632-0.html

QA Team
Thank you for your email. I originally replied on 29-04-2012, but 
perhaps they were insufficient, for which i apologize. Bug still in 
existence, two further test files attached.

Thank you.

Tim
On 26/05/13 23:31, bugzilla-daemon@freedesktop.org wrote:
> QA Administrators <mailto:qa-admin@libreoffice.org> changed bug 49179 
> <https://bugs.freedesktop.org/show_bug.cgi?id=49179>
> What 	Removed 	Added
> QA Contact 		qa-admin@libreoffice.org
>
> *Comment # 4 <https://bugs.freedesktop.org/show_bug.cgi?id=49179#c4> 
> on bug 49179 <https://bugs.freedesktop.org/show_bug.cgi?id=49179> from 
> QA Administrators <mailto:qa-admin@libreoffice.org> *
> Dear Bug Submitter,
>
> This bug has been in NEEDINFO status with no change for at least 6 months.
> Please provide the requested information as soon as possible and mark the bug
> as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in
> NEEDINFO status with no change in 30 days the QA team will close the bug as
> INVALID due to lack of needed information.
>
> For more information about our NEEDINFO policy please read the wiki located
> here:
> https://wiki.documentfoundation.org/QA/FDO/NEEDINFO
>
> If you have already provided the requested information, please mark the bug as
> UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.
>
>
> Thank you for helping us make LibreOffice even better for everyone!
>
>
> Warm Regards,
> QA Team
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 6 Tim Short 2013-05-27 17:22:44 UTC
Created attachment 79856 [details]
attachment-19632-1.dat
Comment 7 Tim Short 2013-05-27 17:22:44 UTC
Created attachment 79857 [details]
Libreoffice Anchor Bug (27-05-2013).doc
Comment 8 Tim Short 2013-05-27 17:22:44 UTC
Created attachment 79858 [details]
Libreoffice Anchor Bug (27-05-2013).odt
Comment 9 Joel Madero 2013-05-27 18:29:12 UTC
Please remember to set the bug as UNCONFIRMED after you provide the info requested, we generally ignore NEEDINFO bugs because the status implies that the reporter needs to append more info/attachment(s)

Also in the future please don't reply via email as we get a bunch of extra text that makes following the bug difficult.

Thanks for the update!
Comment 10 Jorendc 2013-05-27 19:05:57 UTC
Hi Tim,

Thanks for your information and patience!

I can reproduce this using Linux Mint 15 x64 with LibreOffice 4.0.3.3.

Looks like a duplicate of Bug 37002, but I'm not 100% sure (maybe export is affected too). So I mark this one as NEW.

Kind regards,
Joren
Comment 11 Tim Short 2013-05-28 14:22:08 UTC
Thank you Joren.

Regards,
Tim

On 27/05/13 20:05, bugzilla-daemon@freedesktop.org wrote:
> Jorendc <mailto:joren.libreoffice@telenet.be> changed bug 49179 
> <https://bugs.freedesktop.org/show_bug.cgi?id=49179>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEW
> CC 		joren.libreoffice@telenet.be
> See Also 		https://bugs.freedesktop.org/show_bug.cgi?id=37002
> Ever confirmed 		1
>
> *Comment # 10 <https://bugs.freedesktop.org/show_bug.cgi?id=49179#c10> 
> on bug 49179 <https://bugs.freedesktop.org/show_bug.cgi?id=49179> from 
> Jorendc <mailto:joren.libreoffice@telenet.be> *
> Hi Tim,
>
> Thanks for your information and patience!
>
> I can reproduce this using Linux Mint 15 x64 with LibreOffice 4.0.3.3.
>
> Looks like a duplicate ofBug 37002  <show_bug.cgi?id=37002>, but I'm not 100% sure (maybe export is
> affected too). So I mark this one as NEW.
>
> Kind regards,
> Joren
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 12 Jorendc 2013-05-31 00:16:35 UTC
*** Bug 61346 has been marked as a duplicate of this bug. ***
Comment 13 Yousuf Philips (jay) (retired) 2014-12-25 23:01:56 UTC
When opening attachment 79858 [details] in MS Word 2010, MS Word translates this image set to 'To Paragraph' and 'Optimal' to :-

Horizontal: Absolute position: 0", to the right of: Column
Vertical: Absolute position: 1.54", below: Paragraph
Text Wrapping: Square

When opening attachment 79857 [details] in MS Word 2010, MS Word showed :-

Horizontal: Absolute position: 0", to the right of: Column
Vertical: Absolute position: 1.54", below: Paragraph
Text Wrapping: Square

So i dont think there is a problem with this as the document looks the same in both cases, but that the ODF and DOC formats dont translate 1 to 1, so i believe this is NOTABUG.
Comment 14 Robinson Tryon (qubit) 2015-12-09 18:43:15 UTC
Migrating Whiteboard tags to Keywords: (filter:doc)
Comment 15 Oliver Specht (CIB) 2016-04-27 14:09:37 UTC
This is definitely not a bug as there is no to-page anchoring in Word. (And there is no need to use it in Writer BTW)
Comment 16 Joel Madero 2016-04-27 14:59:20 UTC
(In reply to Oliver Specht (CIB) from comment #15)
> This is definitely not a bug as there is no to-page anchoring in Word. (And
> there is no need to use it in Writer BTW)

Can you explain the second part of the statement? I anchor to page all the time. First part makes sense (thanks for clarification.
Comment 17 Oliver Specht (CIB) 2016-04-28 11:25:17 UTC
> Can you explain the second part of the statement? I anchor to page all the
> time. First part makes sense (thanks for clarification.
Years ago page anchoring was the only way to put a frame/picture to any position on the page. A frame anchored to a paragraph could not be located e.g. on top of the page. 
Later other anchor types were extended to make that possible. So now page anchoring has no advantages anymore.
Disadvantages are that other applications might not be able to put the object to the right page because they might create a different layout or they might not have any layout at all (e.g. xslt transformations)
Comment 18 Telesto 2019-02-09 09:30:09 UTC
*** Bug 123245 has been marked as a duplicate of this bug. ***