Bug Hunting Session
Bug 49464 - Add Ctrl-Shift-F for repeated search in basic IDE
Summary: Add Ctrl-Shift-F for repeated search in basic IDE
Status: RESOLVED DUPLICATE of bug 94498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2012-05-04 02:05 UTC by Cor Nouws
Modified: 2015-12-18 10:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-05-04 02:05:09 UTC
Ctrl-F works fine with the slimm search tool bar in the basic IDE

Ctrl-Shift-F for repeated search would be great :-)
Comment 1 Cor Nouws 2012-07-07 08:40:28 UTC
could this be set to an easy hack ? Any code pointers ?
Comment 2 Cor Nouws 2012-07-07 08:41:42 UTC
or maybe better to ask Noel ..
Comment 3 Cor Nouws 2012-07-18 19:30:06 UTC
Note to myself or any other: 
see pointer in https://bugs.freedesktop.org/show_bug.cgi?id=46438#c11
Comment 4 Noel Power 2012-07-26 09:23:24 UTC
(In reply to comment #3)
> Note to myself or any other: 
> see pointer in https://bugs.freedesktop.org/show_bug.cgi?id=46438#c11

you still want some additional key binding when one already exists ? and f3/shift-f3 is a global binding ( afaik ) for all uses of the find toolbar, I think it would make things more confusing to do that
Comment 5 Cor Nouws 2012-07-26 11:00:43 UTC
(In reply to comment #4)

> you still want some additional key binding when one already exists ? and
> f3/shift-f3 is a global binding ( afaik ) for all uses of the find toolbar, I
> think it would make things more confusing to do that

F3/Shft-F3 don't work in my basic IDE
(And In Writer do somthng else)
Comment 6 Noel Power 2012-07-26 11:10:05 UTC
(In reply to comment #5)
> (In reply to comment #4)
> 
> > you still want some additional key binding when one already exists ? and
> > f3/shift-f3 is a global binding ( afaik ) for all uses of the find toolbar, I
> > think it would make things more confusing to do that
> 
> F3/Shft-F3 don't work in my basic IDE
> (And In Writer do somthng else)

do you do cntrl-f first to get focus in the search bar? works for me ( master ) both basic-ide and writer
Comment 7 Cor Nouws 2012-07-26 15:55:07 UTC
(In reply to comment #6)

> do you do cntrl-f first to get focus in the search bar? works for me ( master )
> both basic-ide and writer

Ah, in the 3.6. line that works. Thanks. Still does not allow me to search again after having done some work in the code.
But if it's a great deal ... ;-)
Comment 8 Cédric Bosdonnat 2014-01-20 09:00:33 UTC
Restricted my LibreOffice hacking area
Comment 9 Cor Nouws 2015-12-03 14:28:44 UTC
that moment that I can't find my own bugs :\

*** This bug has been marked as a duplicate of bug 94498 ***
Comment 10 Robinson Tryon (qubit) 2015-12-18 10:25:56 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]