Download it now!
Bug 49806 - FILEOPEN pptx font messed
Summary: FILEOPEN pptx font messed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta2 tar...
Keywords: regression
: 49808 50283 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-05-11 09:29 UTC by Korrawit Pruegsanusak
Modified: 2012-06-15 22:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot comparing LO 3.5.3.1 and daily build (205.04 KB, image/png)
2012-05-11 09:41 UTC, Korrawit Pruegsanusak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-05-11 09:29:24 UTC
1. Download attachment 46857 [details]
2. Open in daily build
3. Click the white text in the middle of slide, the text cursor should appear and blinking
4. [Not expected] Font name is "+mj-lt", and the font face shown at the characters is incorrect

[REPRODUCE] in Windows XP, daily build from Win-x86@6-fast, Build ID: 7f3f6e4,
pull time 2012-05-08 21:43:52

[NOT REPRODUCE] in Windows XP, official 3.5.3.1
  [Expected and Actual] It show font name as "Century Gothic", and font face is similar to PowerPoint 2007. See the numerals ("2009") for a sample.
Comment 1 Korrawit Pruegsanusak 2012-05-11 09:41:00 UTC
Created attachment 61460 [details]
screenshot comparing LO 3.5.3.1 and daily build

See also: attachment 46858 [details] for PowerPoint screenshot.
Comment 2 s-joyemusequna 2012-05-12 01:26:32 UTC
Confirmed with LOdev 3.6 (2012-05-10) version 3.6.0alpha0+ (Build ID: 9980e69)
from Win-x86@6-fast under Windows Vista 64.
Comment 3 Korrawit Pruegsanusak 2012-06-09 00:45:31 UTC
[REPRODUCIBLE] with my own build on Windows XP, git core at 34513fe619aee112b11a0a90dc2e981dccdb408e (May 6, 2012)

[NOT REPRODUCIBLE] with my own build at same commit plus Muthu's patch at http://cgit.freedesktop.org/libreoffice/core/commit/?id=25dd603fe2044f35341fe0c6d0b632c9295a824e

So FIXED

Note that this problem does *not* occur in official windows build.
Comment 4 Korrawit Pruegsanusak 2012-06-09 00:47:14 UTC
*** Bug 49808 has been marked as a duplicate of this bug. ***
Comment 5 Korrawit Pruegsanusak 2012-06-09 00:59:24 UTC
Muthu's patch in comment 3 is currently in master branch => target 3.7.0
Comment 6 Korrawit Pruegsanusak 2012-06-09 01:00:45 UTC
*** Bug 50283 has been marked as a duplicate of this bug. ***