Bug 49893 - FILEOPEN: RTF: Image in header not displayed
Summary: FILEOPEN: RTF: Image in header not displayed
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.0.0 target:5.1.0
Keywords: filter:rtf
Depends on:
Blocks: RTF-Images
  Show dependency treegraph
 
Reported: 2012-05-14 01:59 UTC by Jesus Corrius
Modified: 2019-09-30 14:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF document with the broken table (196.98 KB, application/msword)
2012-05-14 01:59 UTC, Jesus Corrius
Details
Screenshot of the document viewed in Microsoft Word Viewer (95.17 KB, image/png)
2012-05-14 02:01 UTC, Jesus Corrius
Details
Screenshot of the document opened in LibreOffice (71.95 KB, image/png)
2012-05-14 02:01 UTC, Jesus Corrius
Details
Shape with picture, no extra groups (38.16 KB, application/msword)
2015-02-10 12:14 UTC, Vasily Melenchuk (CIB)
Details
Shape with picture, extra RTF groups inside shape (38.16 KB, application/msword)
2015-02-10 12:15 UTC, Vasily Melenchuk (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesus Corrius 2012-05-14 01:59:39 UTC
Created attachment 61597 [details]
RTF document with the broken table

Problem description: 

Steps to reproduce:
1. Launch LibreOffice master
2. Open the attached document

Current behavior:

The table in the document doesn't look as it should.

Expected behavior:

The document looks exactly as in Microsoft Office.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727)
Comment 1 Jesus Corrius 2012-05-14 02:01:09 UTC
Created attachment 61598 [details]
Screenshot of the document viewed in Microsoft Word Viewer
Comment 2 Jesus Corrius 2012-05-14 02:01:52 UTC
Created attachment 61599 [details]
Screenshot of the document opened in LibreOffice
Comment 3 s-joyemusequna 2012-05-14 04:08:24 UTC
Confirmed with LOdev 3.6 (master - 14-May-2012 02h55 x86@6-fast; Build ID: 347e345). No regression though, was even worse with LibO 3.3.4 and 3.4.5. Tested with Windows Vista 64 and XP.
Comment 4 Julien Nabet 2013-06-23 12:31:28 UTC
It's better with 4.0.3 or with master sources (future 4.2.0).
The only thing I noticed is the content of the two first columns are no center aligned vertically.
Comment 5 Alexandr 2014-08-06 08:58:05 UTC
In LibreOffice 4.2.5 and 4.3.0 on Debian I see 3 issues:
1) the content of the two first columns are no center aligned vertically as it said in comment 4;
2) black rectangle in left top corner of the table instead of a picture;
3) no margins in the cells
Comment 6 Vasily Melenchuk (CIB) 2015-02-10 12:13:56 UTC
(In reply to Alexandr from comment #5)
> In LibreOffice 4.2.5 and 4.3.0 on Debian I see 3 issues:
> 2) black rectangle in left top corner of the table instead of a picture;

Partial fix for problem 2 (blank rectangle instead a picture) was pushed to gerrit (https://gerrit.libreoffice.org/#/c/14396/)

There are several reasons of this problem:
1) FIXED: "pib" object in shape was skipped while detected shape type was #1 (rectangle), but RTF parses pib only for shape type #74 (picture frame). As far as I see in MS Word and from RTF specification, there are no limitations on pib object usage: it is drawn always, not depending on shape type.

2) FIXED: size of "pib" picture: it looks like image should be stretched to fit shape area.

3) NOT FIXED: strange lines on top left of shape. reason of this behavior lies in extra grouping in shape, so one shape object is treated as 2 objects: one frame with wrong dimensions (black lines to top and to left) and shape with pib (picture). Looks like this must be fixed in general RTF parser.
Comment 7 Vasily Melenchuk (CIB) 2015-02-10 12:14:53 UTC
Created attachment 113287 [details]
Shape with picture, no extra groups
Comment 8 Vasily Melenchuk (CIB) 2015-02-10 12:15:30 UTC
Created attachment 113288 [details]
Shape with picture, extra RTF groups inside shape
Comment 9 Commit Notification 2015-03-08 13:13:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0ae97c39134a73feeea718e81669fd42e5ceb627

tdf#49893: fix for missing header on page 2

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-07-28 08:21:19 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=611d8ee6fe141f9af39c76a864b365d57776db10

tdf#49893: final fix for blank rectangle problem

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2015-12-14 11:26:31 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2016-09-15 22:26:39 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 13 Dennis Roczek 2016-09-17 12:18:16 UTC
no. problem still persists that the header with the image is not displayed (see image of word viewer)

tested with:
Version: 5.2.1.2 (x64)
Build-ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 14 Xisco Faulí 2017-07-13 09:21:40 UTC
Setting Assignee back to default. Please change it back if you're still working on this issue
Comment 15 Alexandr 2017-10-21 18:43:09 UTC
The picture in the original document is not visible in LibreOffice 5.2.7 and 6.0.0.0.alpha1 on Debian Jessie. Vertical alignment in the first 2 columns is broken too.

The picture is visible in the last 2 simple documents.
Comment 16 QA Administrators 2018-10-23 02:48:50 UTC Comment hidden (obsolete)
Comment 17 Jinpo 2019-09-27 05:46:49 UTC
problem still persists that the header with the image is not displayed.

LibreOffice info:
版本: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded