Bug Hunting Session
Bug 50091 - EDITING: Drag and drop images into Impress opens Draw
Summary: EDITING: Drag and drop images into Impress opens Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 69481 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-18 05:46 UTC by r.vauchez
Modified: 2015-09-16 15:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
test png image (72.28 KB, image/png)
2012-08-21 13:46 UTC, Alex Thurgood
Details
Drag and drop of pictures into Impress partially works. (405.16 KB, image/png)
2015-01-30 14:51 UTC, cytan299
Details

Note You need to log in before you can comment on or make changes to this bug.
Description r.vauchez 2012-05-18 05:46:24 UTC
Problem description: 

Steps to reproduce:
1. ....select on the desktop an image 
2. ....drag it to LibrOffice Impress presentation to insert it
3. ...

Current behavior: a new LibreOffice document is created with the image inside

Expected behavior:placing the image in the presentation

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2
Comment 1 Rainer Bielefeld Retired 2012-07-07 23:40:52 UTC
NOT reproducible  with Server Installation of  "LibreOffice 3.6.0.0.beta3  German UI/Locale [Build-ID: 3e2b862] on German WIN7 Home Premium (64bit) 

NOT reproducible with "LibreOffice 3.5.3.1 (RC1) Italian UI / German Locale [Build-ID: 21cb047-d7e6025-9ba54fc-b4a51a8-f42372b] on German WIN7 Home Premium (64bit) 

Drag and drop leaves picture on Desktop and shows a copy in the presentation slide.
Comment 2 Roman Eisele 2012-08-17 15:31:00 UTC
NOT REPRODUCIBLE with
* LibreOffice 3.5.6.2 (Build-ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0)
* LibreOffice 3.6.1.1 (Build ID: 4db6344),
both with German langpack installed and on MacOS X 10.6.8 (Intel).

After step 2 (of comment #0), the image is placed correctly at the current page of the presentation. I have tried with .jpg, .png, and .svg images.


@ r.vauchez:

Thank you very much for your bug report!

But we can’t reproduce the issue. Could you please try to find out some more details, e.g., which kind of images do you try to drag to the Impress presentation (which file type, etc.)? Can you please attach an image which causes this problem for you to this bug report (just click on "Add an attachment" on this page)? Is there something special about the Impress presentation you edit? Which version of MacOS X do you use?

Thank you very much in advance!
Comment 3 Alex Thurgood 2012-08-21 13:38:19 UTC
I can reproduce this on :
Version 3.7.0.0.alpha0+ (Build ID: 9e04ae0)

daily build from today on Mac OSX 10.8 (Mountain Lion)

1) Start LO
2) Select Presentation
3) The basic blank Impress template containing 2 text areas.
4) Drag and drop a PNG file from the desktop onto the open presentation.
5) LO opens a new Draw document and pastes the image inside it. 


So, confirming.

Alex
Comment 4 Alex Thurgood 2012-08-21 13:42:53 UTC
Also tested with 
LibreOffice 3.5.5.3 
Version ID : 7122e39-92ed229-498d286-15e43b4-d70da21

I can also reproduce the described buggy behaviour.


Alex
Comment 5 Alex Thurgood 2012-08-21 13:44:49 UTC
LOL, I also get the same behaviour in LO 3.3.4 on Mac OSX 10.8


Alex
Comment 6 Alex Thurgood 2012-08-21 13:46:47 UTC
Created attachment 65885 [details]
test png image

Adding test png image
Comment 7 Alex Thurgood 2012-08-21 13:50:25 UTC
Also tested with JPG image, same result.

Alex
Comment 8 Alex Thurgood 2012-08-21 13:56:17 UTC
Also tried with gif files, same result.


Alex
Comment 9 Alex Thurgood 2012-08-21 13:58:27 UTC
Retried on a second OSX 10.8 machine (OSX Server), and same results, i.e. the buggy behviour is reproducible.


The problem might well be specific to OSX 10.7 and upwards, since Roman couldn't reproduce on OSX 10.6.




Alex
Comment 10 r.vauchez 2012-08-21 13:59:25 UTC
I am using OS 10.7.4, LibreOffice 3.5.5.3 and I still can reproduce the buggy behavior with JPEG and PNG images.
Comment 11 Roman Eisele 2012-08-21 14:07:37 UTC
(In reply to comment #9)
> The problem might well be specific to OSX 10.7 and upwards, since Roman
> couldn't reproduce on OSX 10.6.

Yes, I think this is the answer. I still can’t reproduce the issue on MacOS X 10.6.8, even when exactly following Alex’ steps in comment #3 and using his sample PNG image (see attachment). But the original reporter (using MacOS X 10.7.4, see comment #10) and Alex (using Mac OSX 10.8) can reproduce it.

But this does not change the fact that this is a LibreOffice bug -- obviously, LibreOffice does not understand the drag and drop information given by MacOS X >= 10.7. So we still need a fix for this.
Comment 12 Roman Eisele 2012-08-21 14:10:04 UTC
@Thorsten Behrens:
I am sorry to CC you about so many bugs, but this is yet another bug specific to MacOS X. It is interesting in that it occurs only on MacOS X >= 10.7. But nevertheless it is a LibreOffice bug because drag and drop works fine in other applications on MacOS X > 10.7. So please take a look at it ... maybe it is rather easy to fix this?!

Thank you very much in advance!
Comment 13 tommy27 2013-09-17 20:04:33 UTC
*** Bug 69481 has been marked as a duplicate of this bug. ***
Comment 14 cytan299 2013-11-02 13:08:01 UTC
This is still a bug in Mac OSX 10.8.5 (Mountain Lion) running LibreOffice 4.1.3.2. This bug is really annoying.
Comment 15 iamahat 2014-04-23 12:53:44 UTC
Just going to add that this bug persists, the latest version is 4.2.3.3 and every single image requires an extra 5-15 clicks. It is insanely annoying.
Comment 16 cytan299 2014-06-20 15:21:54 UTC
Can this bug be pushed to a higher priority? It has been there since 2012! I'm using the latest version of MacOSX 10.9.3 and the latest version of LibreOffice 4.2.5.2 and this D&D bug is still there.
Comment 17 cytan299 2014-07-31 01:03:43 UTC
Bug persists in LibreOffice 4.3.0.4 and Mavericks (MacOSX 10.9.4)
Comment 18 cytan299 2014-08-29 12:30:57 UTC
Problem continues in 4.3.1.2
Comment 19 cytan299 2015-01-30 14:51:00 UTC
Created attachment 112956 [details]
Drag and drop of pictures into Impress partially works.

Drag and drop from the upper graphics panel, the picture drops into Impress fine. However, drag and drop from the text part of the finder panel, and Draw pops up instead.
Comment 20 cytan299 2015-01-30 14:52:21 UTC
Comment on attachment 112956 [details]
Drag and drop of pictures into Impress partially works.

This is on Yosemite 10.10.2 and LibreOffice 4.4.03
Comment 21 cytan299 2015-02-26 13:27:00 UTC
Bug persists in LibreOffice 4.4.1.2
Comment 22 tommy27 2015-02-28 10:55:49 UTC
(In reply to cytan299 from comment #21)
> Bug persists in LibreOffice 4.4.1.2

thanks for the update but please do not change version field.
it must indicate "earliest affected" version, not latest.

reverting it to 3.5.3
Comment 23 cytan299 2015-04-02 18:08:39 UTC
Bug persists in 4.4.2.2.
Comment 24 cytan299 2015-05-11 15:29:18 UTC
Bug persists in LibreOffice 4.4.3.2
Comment 25 Alex Thurgood 2015-05-11 16:58:41 UTC
(In reply to cytan299 from comment #24)
> Bug persists in LibreOffice 4.4.3.2

Please check with the latest daily developer build for OSX, a fix has gone in for the problem with Writer (bug 44621), perhaps that has also solved this bug.
Comment 26 Alex Thurgood 2015-05-12 08:33:46 UTC
This now works on master daily build OSX, since :

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cfdd89f10fdc15b36bd0d1023e49ca3752feb51e

Thanks to Manik for some great work here !
Comment 27 Adolfo Jayme 2015-05-14 21:12:33 UTC

*** This bug has been marked as a duplicate of bug 44621 ***
Comment 28 cytan299 2015-06-30 14:20:52 UTC
I just downloaded and installed 4.4.4.3 and this bug persists! Was the fix left out of this latest build?
Comment 29 tommy27 2015-06-30 14:26:18 UTC
you should try a 5.0.x or 5.1.x daily build from here:
http://dev-builds.libreoffice.org/daily/

the fix is in one of those branches, not in the 4.4.x so there's no surprise the bug is still present in 4.4.4.3