Bug Hunting Session
Bug 61233 - EDITING: Drag and drop images into Calc opens Draw
Summary: EDITING: Drag and drop images into Calc opens Draw
Status: RESOLVED DUPLICATE of bug 44621
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 74517 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-21 14:45 UTC by crazyskeggy
Modified: 2015-12-15 11:03 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect log (3.31 KB, text/plain)
2013-05-29 22:27 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crazyskeggy 2013-02-21 14:45:04 UTC
From IRC, can be reproduced by me.

Repro steps:

1. Open a new calc spreadsheet.
2. Drag an image onto the spreadsheet.
3. Observe what happens

Expected result:

Image is inserted like in Insert > Picture > From File

Actual result:

Image is opened in Draw

Additional info:

This is believed to be a regression from LO 3.5
Comment 1 Jesse 2013-03-15 20:06:42 UTC
This is present in 4.0.1.2 as well.
Comment 2 Owen Genat (retired) 2013-04-16 13:40:13 UTC
Problem does not occur with TDF/LOv3.5.7.2 under Ubuntu 10.04 x86_64. It does occur with TDF/LOv4.0.2.2 under both Ubuntu 10.04 x86_64 and Win7HP. I have changed the platform from "Windows (All)" to "All" as a result. Drag and drop behaviour is normal for (TDF/LOv4.0.2.2) Writer and Impress.
Comment 4 tommy27 2013-09-17 19:58:59 UTC
reproduced in LibO 4.1.1.2 and 3.6.7.2 under Win7 64bit.
works fine in 3.5.7. I haven't tried 3.6.0 to 3.6.6 releases
Comment 5 cytan299 2013-09-17 20:08:31 UTC
Reproduced in MacOSX 10.8.5 and LibreOffice 4.1.1.2
Comment 6 Owen Genat (retired) 2014-01-31 23:01:03 UTC
(In reply to comment #3)
> range:
> http://cgit.freedesktop.org/libreoffice/core/log/
> ?qt=range&q=699e7d9e4081942bb0ad73e9be73f90a26d0c2f7..
> 2a360b68475d6fff5b6618feddb0b52f3a4a2373

I had a look through these changes and the only one I can see that might be related to Draw is:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d10305bbcf98088ef3d7eeee2299e4a21de6e48f

Is it possible this commit caused the change in behaviour?
Comment 7 tommy27 2014-02-04 17:17:50 UTC
*** Bug 74517 has been marked as a duplicate of this bug. ***
Comment 8 Olav Peeters 2014-03-11 00:18:31 UTC
There are indeed several treads describing the same problem for dragging into Writer, Impress and Calc. I started having this problem after upgrading from MacOSX 10.6.8 to 10.9 (apparently a problem from 10.7+). This still persists in LO 4.2.0.4. On Fedora 20 I don't have the problem.
Comment 9 Matthew Francis 2015-01-23 07:58:37 UTC
The behaviour changed as of the below commit.

commit 3da8f3680556e0163f660a0a159930337c8c32ff
Author: Kohei Yoshida <kohei.yoshida@gmail.com>
Date:   Tue Jun 5 15:45:52 2012 -0400

    fdo#50694: Honor the preferred filter returned by type detection.
    
    Because that filter is more reliable.
    
    Change-Id: Ifbab294bf4f344301410cd671a9245bffa03fa11
Comment 10 Yousuf Philips (jay) (retired) 2015-02-04 23:08:59 UTC
Didnt reproduce this on 4.1.6, 4.3.5, 4.5 master on Windows 7 when dragging an image from Windows Explorer, and didnt reproduce this on 4.1.6 or 4.5 master on Linux Mint 13 when dragging it from the desktop, so if this is only mac related, then it should be closed as a duplicate of bug 44621.

Version: 4.5.0.0.alpha0+
Build ID: 802b80fcd378d5788adff1c7c98af526651a30c2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-25_10:20:28

Version: 4.5.0.0.alpha0+
Build ID: d1c9bd13ec7af93f5368dfda6d6d3c955f0b0816
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-01-28_00:25:56
Comment 11 Jean-Baptiste Faure 2015-02-24 08:14:51 UTC
Didn't reproduce too with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64. 
I agree with Jay, it seems to be a MacOS only issue, so a duplicate of bug 44621.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 44621 ***
Comment 12 Robinson Tryon (qubit) 2015-12-15 11:03:30 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]