Download it now!
Bug 50185 - FILEOPEN MSO2007 .doc with wrong FORMATTING, Title missing underline (bottom border)
Summary: FILEOPEN MSO2007 .doc with wrong FORMATTING, Title missing underline (bottom ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 14:06 UTC by junk_2010
Modified: 2014-09-15 19:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description junk_2010 2012-05-21 14:06:39 UTC
This bug is split out from bug 49046.
In LibreOffice 3.5.2, for a doc file, on both Mac OSX 10.6 and Ubuntu 12.04, the title is longer underlined as it was in Word 2007 on Windows 7.
The doc file example is attachment 60428 [details] 
Attachment 60430 [details] shows a pdf of how the doc file looked in Word 2007
Attachment 60436 [details] shows a pdf of how the doc file looks in LibreOffice
If the same document, as a docx file, attachment 60429 [details], is imported the title is underlined correctly. Attachment 60437 [details] is a pdf saved from the LibreOffice docx import and it has the title correctly underlined.
Comment 1 Roman Eisele 2012-05-22 00:00:18 UTC
REPRODUCIBLE with LibreOffice 3.5.3.2 (Build-ID:
235ab8a-3802056-4a8fed3-2d66ea8-e241b8), German langpack installed, on MacOS X
10.6.8 German UI.

Also REPRODUCIBLE with LOdev version 3.6.0alpha0+ (Build ID: abb26f5; installation file: master~2012-05-18_07.09.33_LibO-Dev_3.6.0alpha0_MacOS_x86_install_en-US).

The title has a blue bottom border line both in the .doc and in the .docx file
(visible in the PDF files attached by junk_2010 and confirmed myself with MS Office 2010 on Win 7). But when I open the files with LibreOffice 3.5.3.2 or a Master build (dated 2012-05-18), only the .docx file shows a line below the title; in the .doc file, LibreOffice does not import the line below the title at all.

-> Changed 'Status' field to 'NEW'.
Comment 2 Roman Eisele 2012-05-22 00:10:15 UTC
The same issue already appears in LibreOffice 3.4.4, therefore changed the 'Version' field accordingly. (Can't test with 3.3.x for now, sorry.)

The same problem also appears in Apache OOo 3.4; therefore probably a long-standing issue.

Changed 'Summary' according to the sample of bug 50190 etc., including keywords.
Comment 3 Roman Eisele 2012-05-22 00:17:55 UTC
@Cédric:
Looks like a long-standing .doc file import issue. It seems not terrible, but it may affect many users, because it concerns a simple and widely used feature. It would be wonderful if you could have a look at this issue ...
Comment 4 Roman Eisele 2012-05-23 07:40:51 UTC
@mstahl:
I took the liberty to insert your address into the CC list -- maybe this bug is of some interest for you, because you are our border expert ;-) The underline missing from the title of the sample file is indeed a (bottom only) border line.
Comment 5 junk_2010 2012-07-23 22:14:19 UTC
I have just checked this is LibreOffice v3.6.0.2 on Mac OSX and the title underline is still missing.
Comment 6 junk_2010 2013-01-12 17:45:56 UTC
I have just checked this in LibreOffice v4.0.0.1 on Mac OSX and the title underline is still missing.
Comment 7 junk_2010 2013-08-03 18:34:05 UTC
This bug is still present in LibreOffice 4.1.0.4.
This was checked on both Linux and MacOSX.
Comment 8 junk_2010 2013-10-05 09:05:56 UTC
Still present in 4.1.2.3 on Intel Mac OSX
Comment 9 Cédric Bosdonnat 2014-01-20 08:57:46 UTC
Restricted my LibreOffice hacking area
Comment 10 junk_2010 2014-02-22 19:03:58 UTC
Still present in 4.2.1 on Mac OSX
Comment 11 Luke Deller 2014-03-30 09:34:37 UTC
fixed in LibreOffice 4.3
(commit ad51d4952dc30e0d1cdcc6037556cd7c66a61542)
Comment 12 junk_2010 2014-09-15 19:57:34 UTC
I can confirm that this is fixed in the released version of 4.3.1.2, running on Windows 8.1.

Thank-you for fixing this.