Download it now!
Bug 49046 - FORMATTING: Incorrect Display of Bullets Points, Table Borders and Heading Underlining when Reading doc/docx Documents
Summary: FORMATTING: Incorrect Display of Bullets Points, Table Borders and Heading Un...
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-21 13:17 UTC by junk_2010
Modified: 2015-09-19 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original doc file (83.00 KB, application/msword)
2012-04-21 13:17 UTC, junk_2010
Details
Original docx file (30.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-04-21 13:21 UTC, junk_2010
Details
PDF file created from Word 2007 of doc file (310.62 KB, application/pdf)
2012-04-21 13:21 UTC, junk_2010
Details
PDF file created from Word 2007 of docx file (310.94 KB, application/pdf)
2012-04-21 13:22 UTC, junk_2010
Details
Screenshot 1 of LibreOffice Viewing doc file on macbook (185.04 KB, image/png)
2012-04-21 13:23 UTC, junk_2010
Details
Screenshot 2 of LibreOffice Viewing doc file on macbook (144.82 KB, image/png)
2012-04-21 13:24 UTC, junk_2010
Details
Screenshot 1 of LibreOffice Viewing docx file on macbook (184.43 KB, image/png)
2012-04-21 13:25 UTC, junk_2010
Details
Screenshot 2 of LibreOffice Viewing docx file on macbook (138.65 KB, image/png)
2012-04-21 13:26 UTC, junk_2010
Details
LibreOffice created Pdf from doc file (41.21 KB, application/pdf)
2012-04-21 13:27 UTC, junk_2010
Details
LibreOffice created Pdf from docx file (35.73 KB, application/pdf)
2012-04-21 13:27 UTC, junk_2010
Details
Ubuntu 12.04 Libreoffice Created Pdf from doc file (36.09 KB, application/pdf)
2012-05-01 12:59 UTC, junk_2010
Details
Ubuntu 12.04 Libreoffice Created Pdf from docx file (35.32 KB, application/pdf)
2012-05-01 13:00 UTC, junk_2010
Details

Note You need to log in before you can comment on or make changes to this bug.
Description junk_2010 2012-04-21 13:17:57 UTC
Created attachment 60428 [details]
Original doc file

Problem description: 

I have LibreOffice 3.5.2 installed on a macbook running OSX 10.6 (Snow Leopard).
It does not correctly display bullets points, table borders and title underlining of documents created in Word 2007.

1) Bullets Points Incorrect

For both doc and docx formats the bullet points do not display correctly when viewed on the macbook screen. The "black filled in circle bullets" display as "square boxes with a cross in". The document also spreads onto two pages.
However, if from within LibreOffice the documents are saved as pdf files, the bullet points are almost correct in the resultant pdf files for both pdfs (much better than when viewed on the macbook screen). In the pdf files the document still spreads onto two pages.


2) Table Borders Missing When Viewing docx file

In LibreOffice the table borders are present for both the doc and docx versions when viewed on the macbook screen. 
However, the table borders are missing from the pdf created from the docx version. It is correct for the doc version.


3) Title Underlining Missing When Viewing doc file

In LibreOffice for the doc version, in both the screen display and the created pdf, the "Title" is not correctly underlined. It is correct for the docx version.

Steps to reproduce:

1) Open the attached doc and docx files in LibreOffice to see the display issue. I have attached pdf showing the correct display behaviour as reference.

2) From within LibreOffice save doc and docx files as pdf files.


I have attached a number of relevant files to this ticket.

The original file (single page A4 document) created in Word 2007 used the default theme, bullets etc, on a machine running Windows Vista). I created both doc and docx versions of the document. These two files are:

Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.doc
Word 2007 Defaults Basic Headings Table and Bullet Point Checks.docx

I created (saved from within Word 2007) two pdf files that matched the display of the documents seen on the Windows Vista machine. These are the files:

Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.pdf
Word 2007 Defaults Basic Headings Table and Bullet Point Checks.pdf

Full list of attached files:

Original doc file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.doc

Original docx file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks.docx

PDF file created from Word 2007 of doc file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.pdf

PDF file created from Word 2007 of docx file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks.pdf

Screenshots of LibreOffice Viewing doc file on macbook:
OSX10.6 Screenshot1 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.png
OSX10.6 Screenshot2 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.png

Screenshots of LibreOffice Viewing docx file on macbook:
OSX10.6 Screenshot1 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks.png
OSX10.6 Screenshot2 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks.png

LibreOffice created Pdf from doc file:
OSX10.6 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.pdf

LibreOffice created Pdf from docx file:
OSX10.6 LO3.5.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks.pdf

Current behavior:
LibreOffice does display the file as expected and LibreOffice does not create the pdf file as expected.

Expected behavior:
LibreOffice display of documents to match that in word.
LibreOffice pdf creation to match that displayed in LibreOffice.

Platform (if different from the browser): 
LibreOffice 3.5.2 installed on a macbook running OSX 10.6 (Snow Leopard)
Comment 1 junk_2010 2012-04-21 13:21:05 UTC
Created attachment 60429 [details]
Original docx file
Comment 2 junk_2010 2012-04-21 13:21:48 UTC
Created attachment 60430 [details]
PDF file created from Word 2007 of doc file
Comment 3 junk_2010 2012-04-21 13:22:44 UTC
Created attachment 60431 [details]
PDF file created from Word 2007 of docx file
Comment 4 junk_2010 2012-04-21 13:23:45 UTC
Created attachment 60432 [details]
Screenshot 1 of LibreOffice Viewing doc file on macbook
Comment 5 junk_2010 2012-04-21 13:24:27 UTC
Created attachment 60433 [details]
Screenshot 2 of LibreOffice Viewing doc file on macbook
Comment 6 junk_2010 2012-04-21 13:25:30 UTC
Created attachment 60434 [details]
Screenshot 1 of LibreOffice Viewing docx file on macbook
Comment 7 junk_2010 2012-04-21 13:26:22 UTC
Created attachment 60435 [details]
Screenshot 2 of LibreOffice Viewing docx file on macbook
Comment 8 junk_2010 2012-04-21 13:27:21 UTC
Created attachment 60436 [details]
LibreOffice created Pdf from doc file
Comment 9 junk_2010 2012-04-21 13:27:57 UTC
Created attachment 60437 [details]
LibreOffice created Pdf from docx file
Comment 10 junk_2010 2012-05-01 12:56:52 UTC
Install Ubuntu 12.04-i386 desktop (32 bit)

This came with LibreOffice 3.5.2.2
Build ID:350m1(Build:202)

Repeated same exercise with the same doc and docx document as I used on the mac.
I got:
  Some errors the same as before
  Some errors did not appear (ie the document rendering was correct)
  New errors not seen before

****

Using file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks.docx

Title on two lines (it should be on one line).
Document on two pages (it should be on one).
Numbered bullet points correct. Some symbol Bullet points were incorrect.
On screen display had borders on table but on export to pdf table borders missing.

pdf file produced:
Ubuntu 12.04 lo3.5.2.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks.pdf

****

Using file:
Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.doc

Title on one line, but not underlined (it should be underlined).
Document on two pages (it should be on one).
Header text on two lines (rather than one as it should be).
Bullet points looked about right
Table has borders as it should
PDF looked like on screen display (as it should)

pdf file produced:
Ubuntu 12.04 lo3.5.2.2 Word 2007 Defaults Basic Headings Table and Bullet Point Checks 97-2003Doc.pdf
Comment 11 junk_2010 2012-05-01 12:59:38 UTC
Created attachment 60865 [details]
Ubuntu 12.04 Libreoffice Created Pdf from doc file
Comment 12 junk_2010 2012-05-01 13:00:23 UTC
Created attachment 60866 [details]
Ubuntu 12.04 Libreoffice Created Pdf from docx file
Comment 13 Roman Eisele 2012-05-09 08:33:42 UTC
Thank you very much for your report and your investigation!
However, it would have been better if you would have created one bug report per issue (instead of such a mega-bug containing at least 3 separate issues ;-) ...

A first remark (I refer to the numbering of issues in your original description):

Issue no. 1, "Bullet Points incorrect", is a known issue with many duplicates; the main bug report for this is bug 34814. Fortunately, this bug has been fixed now; the fix will appear in the upcoming version LibreOffice 3.5.4 (and later in 3.6.0, of course). This fix should also fix your issue no. 1.
Comment 14 junk_2010 2012-05-12 12:43:36 UTC
Sorry if bug not reported correctly.

It started off as a simple "bullet points not correct with docx document on OSX".

It was only when I started to capture output, ie pdf from LibreOffice on OSX, that did match onscreen display.
Then thought I will check with a doc version, and got "different" issues.
Then thought I could check in same LibreOffice version in Ubuntu 12.04 and again "different" issues.

I thought however I tried to break down the issues into different bugs could cause an issue.

Word vs LibreOffice
LibreOffice doc vs docx
LibreOffice OSX vs Linux

I think all of the "multiple" bugs came about as a results of trying to provide information on the original bug on bullet points, which I see from you reply is already known and is fixed in a future release.

If for the future you have any advice, I would be happy to try to follow it.
It is a bit of a pain having to load documents up one at a time, and most of the up loaded documents go with all the multiple "bugs".

Are the range of documents and/or output I uploaded useful, or just overkill?
Would you just prefer a few words of description on each issue in separate bug entries?
Comment 15 Roman Eisele 2012-05-13 02:21:54 UTC
@junk_2010:
I am sorry if my remark (comment #13) has irritated you; I did not mean to criticize you! On the contrary, your bug report is a good sample of accuracy and care; I (and I think I can say also the other QA people) would be happy if all or at least most bug reports would be so clear, well-written and well-documented with example files and screenshots.

I also completely understand that you have taken all care to make up a good and precise bug report, and I appreciate the work this must have made for you very much.

> Are the range of documents and/or output I uploaded useful,
> or just overkill?
The count of attachments may be a matter of taste, but again, most bug reports have not enough documentation (sample files, screenshots ...), so I think that too much is always better than not enough.

There is just a single point I wanted to make with my remark. If we have three issues in one report, the handling of this report becomes a bit harder. For example, I said that issue (1) in your report is more or less identical to bug 34814. This is not intented as criticism of your report (I know it is hard to find specific issues or duplicates in this database!); it is just an observation which, if right, makes the handling of the specific issue far easier: if a new report is about a known and already well-documented issue, I can just mark the new report as a duplicate of the old one. This allows to go on fast and to concentrate on the new or not yet identified issues ... But if there is more than one issue in a report, I can't use this easy solution, as marking the report as a duplicate would hide the other, still valid issues.

There are more similar problems in the further process. When a developer has fixed a bug, he (or someone else) marks the bug report as RESOLVED/FIXED; but if the report contains more than one issue, it is unlikely that all issues are fixed at once. Therefore, the 'Status' field, which is important for finding the bugs needing confirmation and bug fixes, becomes difficult when there is more than one issue in a bug report.

Therefore, your report is already (as said above) a good sample of accuracy and very helpful; but if you report more bugs in future, the reports would be even more helpful if you could make a separate bug report for each issue. I know that this means even more work for you, and feel sorry for that, but it would help a lot to prevent us from making mistakes, overseeing issues, etc.

> It is a bit of a pain having to load documents up one at a time,
> and most of the up loaded documents go with all the multiple "bugs".

You are right, addding attachments is annoying in this bugtracker, and adding one attachment more than once is even more annoying. You can, of course, try to upload an attachment only to one bug report and then just make references in the text of the next reports to it, without adding the attachment again. For example, it should be posible to link your 1st screenshot for this report via just typing 'attachment 60432 [details]' (you see the number of an already added attachment when you move the mouse over or click on the desired attachment in the 'Attachments' table at the top of a bug report), or via copying the link
https://bugs.freedesktop.org/attachment.cgi?id=60432
from the same 'Attachments' table. In this way, you can add an attachment only once, but link it from the text of other bug reports. This is still not easy to use, but maybe a bit easier/faster.

Thank you very much again for your report and your patience!
Comment 16 Roman Eisele 2012-05-13 02:25:49 UTC
I wrote: 
> For example, it should be posible to link your 1st screenshot for this report
> via just typing 'attachment 60432 [details]' ...

Sorry, this is not clear. Better: You just have to type the word 'attachment', then a space (blank), and then the number of the attachment, followed by another space or a period etc. The website CGI will make the link and add the '[details]' all by it own.

I will now look into the other issues (2) and (3) of your description, and try to confirm then. Thank you again!
Comment 17 Roman Eisele 2012-05-13 03:34:11 UTC
From originald description:
> 2) Table Borders Missing When Viewing docx file
> 
> In LibreOffice the table borders are present for both the doc and docx
> versions when viewed on the macbook screen. 
> However, the table borders are missing from the pdf created from the docx
> version. It is correct for the doc version.

REPRODUCIBLE with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b8), German langpack installed, on MacOS X 10.6.8 German UI.

The table has a 1/2 inch border both in the .doc and in the .docx file (confirmed with MS Office 2010 on Win 7). But when I open the files with LibreOffice 3.5.3.2, only the .doc file shows a table border; in the .docx file, the table has no border at all. Therefore, also on PDF export the table has a border when exported from the .doc file, but no border when exported from the .docx file.

So, there is definitely a problem with the import of TABLES FORMATTING from .docx files.

The difference between my observations and the observations of the original reporter (junk_2010 sees a table border in both files, when opened with LibO, just no table boder in the PDF file exported from the .docx file) may be explained by the fact that the table *seems* to have a border also in the .docx file opened by LibreOffice, but the grey border line displayed by LibreOffice 3.5.3.2 is not a real (printing) border line, but just some kind of guide line which LibreOffice shows for every table which has no border.
Comment 18 Roman Eisele 2012-05-13 03:38:02 UTC
From original description:
> 3) Title Underlining Missing When Viewing doc file
> 
> In LibreOffice for the doc version, in both the screen display and the created
> pdf, the "Title" is not correctly underlined. It is correct for the docx
> version.

REPRODUCIBLE with LibreOffice 3.5.3.2 (Build-ID:
235ab8a-3802056-4a8fed3-2d66ea8-e241b8), German langpack installed, on MacOS X
10.6.8 German UI.

The title has a blue bottom border line both in the .doc and in the .docx file
(confirmed with MS Office 2010 on Win 7). But when I open the files with
LibreOffice 3.5.3.2, only the .docx file shows a line below the title; in the .doc file, LibreOffice does not import the line below the title at all.

-> Changed 'Status' field to 'NEW'.
Comment 19 Roman Eisele 2012-05-13 04:05:59 UTC
All three issues are also REPRODUCIBLE with LibreOffice 3.5.3.2, German UI, on WinXP German; therefore changed the 'Platform' from 'MacOS' to 'All'.

*

But I have to correct myself, sorry:

(In reply to comment #17)
> The table has a 1/2 inch border both in the .doc and in the .docx file
> (confirmed with MS Office 2010 on Win 7). But when I open the files with
> LibreOffice 3.5.3.2, only the .doc file shows a table border; in the .docx
> file, the table has no border at all.
                  ^^^^^^^^^^^^^^^^^^^^
                  ^^^ This ^^^ is wrong. When I open the .docx file with LibreOffice 3.5.3.2, the table HAS a border, but the border width is wrong: only 0.05pt instead of 0.5pt, therefore near to invisible.

So what is wrong is the import of the width of table borders from .docx files.
Comment 20 junk_2010 2012-05-14 12:14:13 UTC
Roman Eisele said:

> I am sorry if my remark (comment #13) has irritated you; I did not mean to
> criticize you!(In reply to comment #15)

No problem. I am not irritated at all. What I was looking for was advice for the future as to the best way of splitting the report up into multiple bugs so as to best help you.

The information about linking to imports in other documents is useful, that will same some effort. Thank-you.

For future reference would splitting up into the following bug reports have been helpful:

1) Error with LibreOffice MacOS/Ubuntu doc import of bullets
2) Error with LibreOffice MacOS/Ubuntu docx import of bullets
3) Error with LibreOffice MacOS/Ubuntu doc import of Title, missing underline
4) Error after LibreOffice MacOS/Ubuntu docx import, save to pdf has missing table borders
5) Error with LibreOffice MacOS/Ubuntu doc import, no longer fits a single page
6) Error with LibreOffice MacOS/Ubuntu docx import, no longer fits a single page
7) Error with LibreOffice Ubuntu docx import, title now on two lines rather than one
8) Error with LibreOffice Ubuntu doc import, header text on two lines rather than one
Comment 21 Roman Eisele 2012-05-15 00:44:12 UTC
(In reply to comment #20)
> For future reference would splitting up into the following bug reports have
> been helpful:
> 
> 1) Error with LibreOffice MacOS/Ubuntu doc import of bullets
> 2) Error with LibreOffice MacOS/Ubuntu docx import of bullets
> 3) Error with LibreOffice MacOS/Ubuntu doc import of Title, missing underline
> 4) Error after LibreOffice MacOS/Ubuntu docx import, save to pdf has missing
> table borders
> 5) Error with LibreOffice MacOS/Ubuntu doc import, no longer fits a single page
> 6) Error with LibreOffice MacOS/Ubuntu docx import, no longer fits a single
> page
> 7) Error with LibreOffice Ubuntu docx import, title now on two lines rather
> than one
> 8) Error with LibreOffice Ubuntu doc import, header text on two lines rather
> than one

Well, good question. This may be a matter of taste. Some of these problems may be related, but it often turns out only after some testing which problems are really related and which are not (e.g. the problem with the import of bullets from .doc and .docx files may have the same roots, or may not). My suggestion would be to report the .doc and .docx issues together in one bug report, if the reminder of the problem is the same; i.e. to report
1 and 2 together,
5 and 6 together,
7 and 8 together (?),
but to report 3 and 4 each on their own. Other people could suggest other ways to proceed, but I think this is at least reasonable.
Comment 22 junk_2010 2012-05-15 11:46:46 UTC
Thanks for the reply.
Would you like to me file separate bug reports (referencing the attachments in this one) for:

5 and 6 together,
7 and 8 together,
3 and 4 each on their own.

No point in reporting 1 and 2 as you have already identified them as duplicates.
That would then enable this bug report to be closed off.
I guess I would add a final update to this report referencing the new bugs filed.

Or is it not worth it now?
Comment 23 Roman Eisele 2012-05-15 12:58:50 UTC
(In reply to comment #22)
> Would you like to me file separate bug reports (referencing the attachments in
> this one) for:
> 
> 5 and 6 together,
> 7 and 8 together,
> 3 and 4 each on their own.
> 
> No point in reporting 1 and 2 as you have already identified them as
> duplicates.
> That would then enable this bug report to be closed off.
> I guess I would add a final update to this report referencing the new bugs
> filed.

Well, I still want to search once more if we can identifiy more of the points as duplicates of existing bug reports; on my first search, I did not find anything matching, but finding a specific bug report is sometimes rather difficult here (because of vague summaries, different emphasis, and even typos) ;-). I have not much time these days, of course, therefore I have not completed my search yet, sorry. If we then know that there are really no duplicates/related reports, separating the remaining issues would, indeed, be very nice.

> Or is it not worth it now?
It is worth it, I think, because your report and your excellent sample files have pointed out some really important problems in LibreOffice.
Comment 24 junk_2010 2012-05-21 14:37:07 UTC
As requested I have split out the bugs into their own filings.

Bug split filed:

Bug 50185 Formatting - Error with LibreOffice MacOS/Ubuntu doc import of Title, missing underline

Bug 50186 Formatting - Error after LibreOffice MacOS/Ubuntu docx import, save to pdf has missing table borders

Bug 50187 Formatting - Error with LibreOffice MacOS/Ubuntu doc and docx import, no longer fits a single page

Bug 50188 Formatting - Error with LibreOffice Ubuntu docx import, title now on two lines rather than one

Bug 50189 Formatting - Error with LibreOffice Ubuntu doc import, header text on two lines rather than one

Bug 50190 Formatting - Error with LibreOffice MacOS/Ubuntu docx import, title is centre aligned rather than left aligned

As the bullets point issue is already known and reported I have not filed a report for that.
Comment 25 Roman Eisele 2012-05-22 09:27:55 UTC
(In reply to comment #24)
> As requested I have split out the bugs into their own filings.

@junk_2010:
Hello, thank you very much for splitting out the separates issues! I am sorry that I have not completed the task I mentioned in comment #23 before. But I was just too busy in the last week with other issues (our car did not drive anymore ... had to find a new one ...), therefore I found no time to continue any LibreOffice testing work. Sorry again.
Comment 26 Roman Eisele 2012-05-23 12:42:01 UTC
(In reply to comment #13)
> Issue no. 1, "Bullet Points incorrect", is a known issue with many duplicates;
> the main bug report for this is bug 34814. Fortunately, this bug has been fixed
> now; the fix will appear in the upcoming version LibreOffice 3.5.4 (and later
> in 3.6.0, of course). This fix should also fix your issue no. 1.

(In reply to comment #24)
> As the bullets point issue is already known and reported I have not filed a
> report for that.

Just a hint:
The bullet list issue is fixed now for Windows and Linux (see bug 34814), but IMHO not yet on MacOS X. For the remaining problems with bullet lists from .doc and .docx files on MacOS X, please see the special bug 50284.
Comment 27 Roman Eisele 2012-05-23 12:44:05 UTC
Closing this bug report, because all issues have now special bug reports on their own -- see the list in comment #24, and cf. comment #26.

Thank you again very much!