Bug 50189 - Font type picker in Format Bar should show that selected font type is not available on PC
Summary: Font type picker in Format Bar should show that selected font type is not ava...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:4.1
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 14:19 UTC by junk_2010
Modified: 2017-05-17 08:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF showing document once Microsoft ClearType fonts installed (72.75 KB, application/pdf)
2012-06-03 13:26 UTC, junk_2010
Details

Note You need to log in before you can comment on or make changes to this bug.
Description junk_2010 2012-05-21 14:19:43 UTC
This bug is split out from bug 49046.

In LibreOffice 3.5.2, for a doc file on Ubuntu 12.04, the header text in the document is now on two lines rather the one it was in Word 2007 on Windows 7.

The doc file example is attachment 60428 [details] 
Attachment 60430 [details] shows a pdf of how the doc file looked in Word 2007
Attachment 60865 [details] shows a pdf of how the doc file looks in LibreOffice on Ubuntu
Comment 1 Rainer Bielefeld Retired 2012-05-21 21:58:13 UTC
Effect is NOT reproducible with "LibreOffice 3.5.4.1 (RC1) German UI/Locale [Build-ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8] on German WIN7 Home Premium (64bit)

May be that is a missing Font / different font replacing problem? When I open the document in LibO everything looks very similar as in MS WORD viewer, but in your PDF (so it looks in LibO) for example text in text body looks like Arial (something sans serif), I see something similar to "Times New Roman". In reporter's PDF attachment "how the doc file looked in Word 2007" I see some "normal" looking Font contents in document properties, in "how the doc file looks in LibreOffice" I see a very strange reduced Font set.

Currently I can't see a LibO bug.

@junk_2010@live.co.uk
Please make sure that all required fonts are available on your PC, without correct font the comparison is inadmissible / useless.
Comment 2 Roman Eisele 2012-05-22 09:13:26 UTC
I think that Rainer Bielefeld's suggestion is right. The original .doc file and the PDF file exported from Word 2007 use 'Calibri' for the page header, but the PDF exported from LibreOffice on Ubuntu uses 'DejaVu Sans' instead, probably because 'Calibri' is a Microsoft font which comes with newer Windows and Office versions but is not available on Ubuntu (correct me if I am wrong).

If I open the .doc file with LibreOffice on MacOS X, it looks fine as long as 'Calibri' is installed. If I change the font of the header manully to 'DejaVu Sans', it looks exactly like in the PDF exported on Ubuntu -- two lines, with a break before 'Format'.
Comment 3 junk_2010 2012-05-24 15:14:09 UTC
I have re-opened the doc file in LibreOffice 3.5.3.2 in Ubuntu. When I place
my cursor in the header line the font in the menu font box is shown as
"Calibri", as it was in Word 2007. I had therefore assumed that the "Calibri"
font is installed.

The header text size is as Word 2007 (size 11), the font is also "unbold" as Word 2007. In case it was an issue like that in comment #2 in bug 50188.
Comment 4 junk_2010 2012-06-03 13:26:02 UTC
Created attachment 62463 [details]
PDF showing document once Microsoft ClearType fonts installed
Comment 5 junk_2010 2012-06-03 13:38:23 UTC
I have in Ubuntu 12.04 installed the Microsoft ClearType fonts, ie Calibri and Cambria.

Now the header text is only on one line, as it was in Word 2007. So the header text being on 2 lines is a font issue as suggested, thank-you for the feedback. This was with LibreOffice 3.5.3.2.

A pdf showing the result is attachment 62463 [details].

However, I do still believe there is an issue here. In both cases, with and without the Microsoft ClearType fonts installed, as a user in LibreOffice I could see no difference in the information about the header text. ie in both cases the text was listed as "Calibri" in the font box. Even though in one case, when the header text was on two lines, it was not.

I presume a font substitution has occurred in the "incorrect" two header line case, but this was not obvious to me as a user. I believe it should be. At least then I would not think it was an issue with LibreOffice, and I would be pointed in the direction of the real "missing font" issue.
Comment 6 Rainer Bielefeld Retired 2012-06-12 10:22:25 UTC
@junk_2010@live.co.uk 
I agree, it's difficult to fine out whether shown font type really is available on PC or only has been selected by author, but is replaced for VIEWING on different PC
Comment 8 junk_2010 2013-02-08 18:41:28 UTC
Samual M. said in comment 6:
Is this the solution to the bug?

I believe it is.

One further thing that might be nice is if the "combo tool tip" message talked about in:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=17d86df23e7be3ab0a161f69ff0f703728e0e135
also said what font it had used as a substitute.
Comment 9 Samuel Mehrbrodt (allotropia) 2013-02-11 07:22:50 UTC
Luboš, would you have a look at Comment #8?
Comment 10 Luboš Luňák 2013-02-18 14:59:11 UTC
As said in previous comments, the UI now has a way to show this, so closing.

As for actually naming the font used, that's done in a completely unrelated code (and since the 'Character' dialog doesn't show the information either, it's a question how difficult it would be to find out). If you want such a feature, a suggest a separate enhancement request.
Comment 11 junk_2010 2013-02-19 20:07:47 UTC
I have filed bug 61134 for the enhancement suggestion "When A Substitute Font is Being Used In The Font Combo Tooltip Say Which Substitute Font is Being Used"
Comment 12 Robinson Tryon (qubit) 2015-12-16 22:31:20 UTC Comment hidden (obsolete)