Bug 50371 - CONFIGURATION: JRE 7.x incompatibility not resolved
Summary: CONFIGURATION: JRE 7.x incompatibility not resolved
Status: RESOLVED DUPLICATE of bug 50584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA
Keywords:
: 50863 (view as bug list)
Depends on: 50254
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 07:49 UTC by Hermann Mucke
Modified: 2012-09-07 18:17 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hermann Mucke 2012-05-26 07:49:36 UTC
Problem description: 

The known issue with JRE 7.x is still present with LibO 3.4.5 RC2 and JRE 1.7.0_04. JRE 1.6.0_32 works fine.

Steps to reproduce:
1. Install JRE 1.7.0_04
2. Install JRE 1.6.0_32
3. Activate either & load any document

Current behavior: With JRE 1.7.0_04, error msg "JRE not installed" or "JRE corrupted" when opening odt in Writer; can be clicked away but there's no Java functionality. odb files open in Base but no tables, queries ect. can be accessed, error msg "No JRE"

Expected behavior: With JRE 1.6.0_32 everything works.

Platform (if different from the browser): Win7 Pro 64
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Hermann Mucke 2012-05-26 07:58:57 UTC
Forces users to keep outdated & unsafe JRE6 even if other applications work fine with JRE7. Less proficient users are likely to suppose LibreOffice is broken if it stops working after JRE upgrade.
Comment 2 Hermann Mucke 2012-05-27 02:04:18 UTC
Oops, sorry, legasthenic error -- that should be LibO 3.5.4RC2 (the most recent), not 3.4.5RC2. Just makes it more annoying.
Comment 3 Timo Ollech 2012-06-07 04:03:45 UTC
LibOo 3.5.4.2 recognizes JRE 1.7.0_04, so I think this bug can be closed.
Comment 4 NoOp 2012-06-09 11:04:28 UTC
Confirm on Win7
LibreOffice 3.5.4.2 
Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d1

From Writer: File|Send - results in Java is not compatable error message on first try. Also crashes LO.
Comment 5 mrmarinelli 2012-06-11 01:43:39 UTC
Confirm on WinXPSP3
LibreOffice 3.5.4.2 

From Calc: File|Open - results in Java is not compatable error message on
first try.
Comment 6 aironmail 2012-06-21 07:02:37 UTC
My experience here:

I have two machines, one with XP 32 bits and the other with Windows 7 64 bits.

On XP 32 bits there's no problem.

On Windows 7 64 bits what happens is the following:

As should be normal, I have the 64 bits release from the java 7 JRE. LibreOffice should work with this as I'm on a 64 bits machine. But it does not. It finds the JRE, I can select it, but when I restart it says that it will not work.
I noticed that LibreOffice installs on C:\Program Files (x86) instead of just C:\Program Files. That made me to suspect that it could have someproblem with the 64 bits JRE.
After that, I installed in addition the 32 bits release of the java 7 JRE and restarted LibreOffice. Then I had to versions of the java 7 JRE, one with 32 bits (installed on C:\Program Files (x86)) and another for 64 bits (on C:\Program Files ). From LibreOffice I selected to use the JRE installed on C:\Program Files (x86) (32 bits) and restarted LibreOffice.
Java 7 worked fine since that.

So what I see is that in a Windows 64 bits machine, LibreOffice doesn't work with 64 bits JRE, just with 32 bits. Strange...
Comment 7 Heinrichmeyer 2012-06-27 04:15:37 UTC
@aironmail@gmail.com:
this does not work here, i am also on windows 7 64 bit, deleted all libreoffice files in AppData/Roaming, no way, i had to install a jre-6-32 bit after i tried jre7-32, jre7-64 and jdk7-64.

After installation of this jre, my additions to classpath and start parameter in the options -> java dialog where forgotten.

This is maybe another bug so i think there are more problems that explain our inconsistent experiences.
Comment 8 Heinrichmeyer 2012-06-27 06:38:06 UTC
maybe it depends on installation history and i should install a fresh libreoffice, not only delete the AppData/Roaming/libreoffice directory.
Comment 9 Heinrichmeyer 2012-06-27 06:39:07 UTC
(In reply to comment #8)
> maybe it depends on installation history and i should install a fresh
> libreoffice, not only delete the AppData/Roaming/libreoffice directory.

i meant deinstall and install fresh libreoffice.
Comment 10 V Stuart Foote 2012-06-27 07:18:35 UTC
*** Bug 50863 has been marked as a duplicate of this bug. ***
Comment 11 DukeUnleashed 2012-06-29 12:12:00 UTC



Lots of reports are being made about this problem to java.com
Users are now being directed to this bug to add their information. 


This problem is likely due to the order of installation. Given that it is not reproducible for all users seems to make it an environment issue. I have not tired this theory myself. 

Java 7 is installed in a new directory on windows, along these lines:
c: program files/ java/ jre7 .......
I suspect that Open Office, Libra Office, Oracle Open Office, etc,  if already installed, is still looking in c: program files / java /jre6 for the Java binaries. 

Possible user fixes:
1) change settings in office to point to the new correct location. 
2) uninstall office and reinstall


office should be able to check and handle the installed location of Java. If that is indeed the issue. 

Take care, 
Duke
Comment 12 Hermann Mucke 2012-06-30 00:51:38 UTC
(In reply to comment #11)
> 
> 
> 
> Lots of reports are being made about this problem to java.com
> Users are now being directed to this bug to add their information. 
> 
> 
> This problem is likely due to the order of installation. Given that it is not
> reproducible for all users seems to make it an environment issue. I have not
> tired this theory myself. 
> 
> Java 7 is installed in a new directory on windows, along these lines:
> c: program files/ java/ jre7 .......
> I suspect that Open Office, Libra Office, Oracle Open Office, etc,  if already
> installed, is still looking in c: program files / java /jre6 for the Java
> binaries. 
> 
> Possible user fixes:
> 1) change settings in office to point to the new correct location. 
> 2) uninstall office and reinstall
> 
> 
> office should be able to check and handle the installed location of Java. If
> that is indeed the issue. 
> 
> Take care, 
> Duke

If it only were so easy... unfortunately, it is not.

The problem arose (at least in my original case, on Win7/64) precisely because when you call up Java options and point LibO to the new Java7 directory (which *is* recognized at this stage, and presented as a radio button selection option), LibO will state at the first Java-requiring occasion that no JRE exists, or that it is corrupted. If you then point LibO back to the old JRE6 & restart it, everything works as it should. The problem still exists with the newest Java 7v5.
-Greetings, HM
Comment 13 Malrog 2012-06-30 15:22:37 UTC
I've been directed here by Sun Microsystems, as Duke has already identified they're pointing people to this bug report, so I thought it would be worth me adding my experience.

My repro steps:
Start LibreOffice
Select Tools->Macros->Run Macro
Error message appears saying JRE is defective.

My spec:
Windows 7 Ultimate N SP-1 64-bit with latest Java 7.x

Java 1.6.0_33 does not have this issue.

I did not have any JRE installed when I installed LibO.

As Hermann states, Java 7.x is detected by LibO, it just doesn't work!  Maybe it is the installation order, and I need to reinstall LibO - has anyone tested this?
Comment 14 Hermann Mucke 2012-07-01 00:55:18 UTC
With several people independently confirming that this is actually a bug (at least with Win64), may I ask the administrator to make the case appear in the LibO bug list, and assign it to further processing? We've been at this for over a month now, resolving it will certainly take much longer, and Java 6 won't get security updates forever. - Greetings, HM
Comment 15 V Stuart Foote 2012-07-01 09:00:55 UTC
Actually the problem is not with LibreOffice, but rather the configuration of Oracle Java on your Windows system.

Oracle's installers are not very fastidious about cleaning up prior releases of Java. Also they copy the last installed Java executables into the Windows\System32 directory rather than correctly establishing a system JAVA_HOME environment variable to direct to the program. And they establish Windows registry keys that are not fully removed during uninstallation.

LibreOffice can not include a dedicated Java Runtime Environment package due to licensing issues, so it is dependent on what YOU provide in your Windows system. If your system is misconfigured--it is NOT a LibreOffice bug.

LibreOffice does correctly function with a Java JRE 1.7 build.  If you want to run with an Oracle Java 1.7 JRE, and you should, you have to fix your JRE installation Windows. A LO enhancement to try to fix Oracle's mess of JRE instllation on Windows would be helpful, but that is not the present capability and the responsibility lies with us as users of these two software packages to accomodate.

As a general rule in Windows OS maintain only one JRE, either a 1.6 or a 1.7 release, but not both! Also, LibreOffice is a 32-bit program--if on a 64-bit Windows system, be sure to provide a 32-bit JRE.

Fortunately you can leave the LibreOffice 3.5.x installation intact, with minor configuration changes. And to get things running most work is with the JRE:

First, fully remove the Java JRE 1.6 (and JRE 1.7) including manual editing of the Registry and some clean up of the file system. 

(1) Run the Windows Add/Remove programs as Administrator and uninstall ALL Sun/Oracle Java components. You'll probably want to remove/reinstall any 3rd Party Java applets as they will have configurations pointing to old installation, the Java Access Bridge as an example.

(2) Open a command window "Run as Administrator" and run "regedit.exe"--navigate to the Key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft (for 64-bit Windows) and HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft (for both 32-bit AND 64-bit Windows) and delete it.  And while still in registry editor, also delete the JreMetrics Keys.

(3) Also delete the JavaSoft keys for each user account HKEY_CURRENT_USER\Software\JavaSoft, starting with the Administrator account. And then from a new regedit.exe session for each user

(4) Use Windows Explorer and navigate to the C:\Program Files\Java folder. Delete jre6. Delete jre7.  And, if on 64-bit Windows, navigate to C:\Program Files (x86)\Java. Delete jre6. Delete jre7.

(5) Check in the C:\Windows\System32 folder for java.exe, javaw.exe, javaws.exe--running the uninstallers should have removed them but if still present delete.

(6) All Java should be off the Windows sytem at this point. Search the registry for Java, and the Windows file system for java.exe if you'd like to be certain.

(7) Reboot!

Now locate and download for installation the "Windows Offline" Oracle JRE 1.7 installers. 32-bit (and 64-bit if applicable). Use this Oracle provided link:  http://www.java.com/en/download/manual.jsp

(1) if on 64-bit windows, run the 64-bit JRE 1.7u5 installer.

(2) run the 32-bit JRE 1.7u5 installer.

(3) the 32-bit install should have placed 32-bit versions of Java into the C:\Windows\System32 folder. But it could also end up being the 64-bit version on 64-bit windows.  So you need to force use of the 32-bit Java. Delete the java.exe, javaw.exe, javaws.exe from the system32 folder--they are just copies and you'll be establishing a location for them on the Path variable.

(4) Create a system environment variable JAVA_HOME (by Java programming convention). Done either from Computer --> Properties --> Advanced system settings --> Environment Variables, in the System variables portion of the panel.  Or set directly in the registry in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment key. Assign the path to the 32-bit Java installation to the JAVA_HOME variable, e.g. "C:\Program Files (x86)\Java\jre7".  Mind the spaces.

(5) from the Advanced system settings, or the Environment key in the registry edit the PATH variable to insert the value "%JAVA_HOME%\bin;"--after the %SystemRoot% entries.  Note: setting the JAVA_HOME variable does nothing by itself--it is the addition of JAVA_HOME\bin in the Path variable that is doing the correction.

(6) verify that the correct JRE will run by entering on the start menu or from command window '"%JAVA_HOME%\bin\java.exe" -version'

Now clear the LibreOffice configruation file for Java and allow it to be rebuilt.

(1) In each user account C:\Users\<userName>\AppData\Roaming\LibreOffice\3\User\Config there will be a configuration file "javasettings_Windows_x86.xml" simply delete it. It will be rebuilt with now correct Java Runtime Environment settings.  Adjust to C:\Documents and Settingon Windows XP

(2) Launch LibreOffice. Navigate to Tools --> Options --> Java, check the radio button to use a Java Runtime Environment. Should have no error, and should see just a single value offered. An Oracle Corp Vendor entry, Version 1.7.0_u5 (or the version just installed). And below a "Location" value showing the entry for the version just installed, e.g. C:\Program Files (x86)\Java\jre7.

Configuring this way will disrupt some of Oracles auto configruation for JRE use on 64-bit system--defaulting most to use 32-bit JRE. But for most users this is going to be more functional.
Comment 16 V Stuart Foote 2012-07-03 07:18:28 UTC
(In reply to comment #14)
> With several people independently confirming that this is actually a bug (at
> least with Win64), may I ask the administrator to make the case appear in the
> LibO bug list, and assign it to further processing? We've been at this for over
> a month now, resolving it will certainly take much longer, and Java 6 won't get
> security updates forever. - Greetings, HM

Hermann,

Could you take a moment and verify that: with correct removal of all Java JREs; reinstallation of just a single Java JRE 1.7uX; removal of the java.exe, javaws.exe and javaw.exe from the C:\Windows\System32 folder; and finally establishing an entry in the system PATH pointing to the 32-bit Java JRE; clearing your javasettings_Windows_x86.xml configuration, can verify that you have correct function of Java with LibreOffice 3.5.4 (and perhaps the 3.6.0 beta).

If so, please consider marking this Bug report as INVALID

Feel free to PM if you would like to discuss.

Regards,

V. Stuart Foote
Comment 17 Hermann Mucke 2012-07-03 08:44:48 UTC
(In reply to comment #16)

> Hermann,
> 
> Could you take a moment and verify that: with correct removal of all Java JREs;
> reinstallation of just a single Java JRE 1.7uX; removal of the java.exe,
> javaws.exe and javaw.exe from the C:\Windows\System32 folder; and finally
> establishing an entry in the system PATH pointing to the 32-bit Java JRE;
> clearing your javasettings_Windows_x86.xml configuration, can verify that you
> have correct function of Java with LibreOffice 3.5.4 (and perhaps the 3.6.0
> beta).
> 
> If so, please consider marking this Bug report as INVALID
> 
> Feel free to PM if you would like to discuss.
> 
> Regards,
> 
> V. Stuart Foote

Stuart,

Thanks for your detailed instructions, I'm sure this will work; but I can't try it right now -- this is a production system, and I am in the midst of a scheduled project that uses other software requiring Java (and which does not seem to have any problems). It will probably be two weeks until I can get at this. Perhaps some other participant in this thread can get at it earlier?

How widespread is this problem anyway? Does anybody know any LibO users who upgraded Java to v7 w/o a hitch? And if anybody knows people who made a first-time LibO installation together with version 7 as a first-time Java installation, I presume there would be no problem at all; it would be good to hear about this too.

Kind regards, Hermann
Comment 18 Harald Koester 2012-07-04 04:31:49 UTC
According a post on the German mailing list LO crashes together with Java 7 if the find function of the LibreOffice Help is performed. I reproduced this behaviour with LO 3.5.3.2, Win 7 (32 bit), Java 7 Update 5. In my system Java has been updated from Version 6 Update 32.

If I delete the file "javasettings_Windows_x86.xml" mentioned in comment 15, LO creates a new file and does not crash any longer by using the find function. 

Bug 51384 may be duplicate of this behaviour.
Comment 19 vulcain 2012-07-07 00:14:13 UTC
(In reply to comment #15)
I try ton install LibO 3.6 bet 3 on Windows 8 x86_64 with java 1.7.
Don't work. :'-(
I try to follow the comment #15 but it's hardiest for me and my knowledge of english. I understand that the directory of java's programm in x86_64 change and libreoffice can't found why ?? 
My lesson keep Java 1.6 the more longer time (but i will be hardiest, Oracle hide java 1.6 for a fresh install).

Dev, i wish in a little time, LibO don't need java.
Comment 20 V Stuart Foote 2012-07-07 07:49:00 UTC
(In reply to comment #19)

> My lesson keep Java 1.6 the more longer time (but i will be hardiest, Oracle
> hide java 1.6 for a fresh install).
> 

Perfectly fine to keep using Java 1.6, most Linux distributions do. But users must work to configure and maintain them intact. The English language versions of of Java 1.6 release are available for public download here:

http://www.java.com/en/download/manual_v6.jsp

> Dev, i wish in a little time, LibO don't need java.

Not necessarily the best outcome. Java and the Java UNO components provide multiple services in LibreOffice. HSQLDB 1.8 remains entrenched in LibreOffice, and while it appears that OpenOffice is moving forward with HSQLDB 2.2 bundle--efforts to adopt SQLite as embedded DB for Base appear not to be viable. An HSQLDB 2.2 upgrade for LibreOffice presents problems. And adopting FireBird would be viable but needs a lot of work but still would need to maintain JRE for legacy HSQLDB 1.8 support
(refs --  
https://bugs.freedesktop.org/show_bug.cgi?id=44854
https://bugs.freedesktop.org/show_bug.cgi?id=51781 and
https://bugs.freedesktop.org/show_bug.cgi?id=51780 )

Beyond the embedded database support, a number of GUI functions and reporting tools remain dependent on the presence of a JRE and its UNO interfaces. 

But THE primary requirement to maintain integration of Java JRE is operation of LibreOffice's Accessibility - Assistive Technology tools. They absolutely depend on a JRE and the Oracle Java Access Bridge. Remove Java and you remove existing Accessibility support for both Windows, and Linux (where Orca has JRE dependencies)! The IAccessible2 effort may extend the Microsoft MSAA base to replace the Java AT-SPI for Windows based users, but does nothing for Linux. Apple takes care of its environment with VoiceOver--but support for VoiceOver API in LibreOffice is only being talked about. So OSX users remain dependent on a the Java Access Bridge bundled by Apple with their builds of the JRE.
Comment 21 dgustafson52 2012-07-15 19:16:42 UTC
I posted my problem on the Java website, asking for the Java 6v32 download, and they referred me to you...as I told them, I just got a new Toshiba Sattelite laptop with Windows 7, 64 bit OS.  when setting it up, Java came up and told me to update to Java 7, and how to uninstall older, less safe versions.  So I did.  

Then, since I do not use Microsoft Office apps much, I didn't want to spend the money, I just thought I would use Open Office, as it worked fine for me on my old laptop with XP OS.  So I downloaded it, and when trying to use it, it kept popping up the error message-- something about Open Office needs a JRE and to install one.  Well, after doing a bunch of research and finding out what a JRE even is!  I went to Java and tried to get Java 6 v 32 to download.  On Java, they did NOT want to let me have version 6 at all, but finally I got 6v33...and I am STILL getting the error messages.  And I wrote to Java, like I said, and they sent me to you...does this mean that I MUST shell out the money (which I don't have now) to get Microsoft Office just so I can open my XL spreadsheets from old Open Office and Works apps ?
Comment 22 Michael Stahl 2012-07-19 13:03:36 UTC
duplicate; defect in Oracle JRE 7 on Windows can be worked around
by installing MSVC2010 redistributable:
http://www.microsoft.com/en-us/download/details.aspx?id=8328

please _only_ re-open this in case installing the above
does not fix the problem for you.

*** This bug has been marked as a duplicate of bug 50584 ***
Comment 23 cincenko 2012-08-09 16:24:03 UTC
(In reply to comment #15)
> Actually the problem is not with LibreOffice, but rather the configuration of
> Oracle Java on your Windows system.
> 
> Oracle's installers are not very fastidious about cleaning up prior releases of
> Java. Also they copy the last installed Java executables into the
> Windows\System32 directory rather than correctly establishing a system
> JAVA_HOME environment variable to direct to the program. And they establish
> Windows registry keys that are not fully removed during uninstallation.
> 
> LibreOffice can not include a dedicated Java Runtime Environment package due to
> licensing issues, so it is dependent on what YOU provide in your Windows
> system. If your system is misconfigured--it is NOT a LibreOffice bug.
> 
> LibreOffice does correctly function with a Java JRE 1.7 build.  If you want to
> run with an Oracle Java 1.7 JRE, and you should, you have to fix your JRE
> installation Windows. A LO enhancement to try to fix Oracle's mess of JRE
> instllation on Windows would be helpful, but that is not the present capability
> and the responsibility lies with us as users of these two software packages to
> accomodate.
> 
> As a general rule in Windows OS maintain only one JRE, either a 1.6 or a 1.7
> release, but not both! Also, LibreOffice is a 32-bit program--if on a 64-bit
> Windows system, be sure to provide a 32-bit JRE.
> 
> Fortunately you can leave the LibreOffice 3.5.x installation intact, with minor
> configuration changes. And to get things running most work is with the JRE:
> 
> First, fully remove the Java JRE 1.6 (and JRE 1.7) including manual editing of
> the Registry and some clean up of the file system. 
> 
> (1) Run the Windows Add/Remove programs as Administrator and uninstall ALL
> Sun/Oracle Java components. You'll probably want to remove/reinstall any 3rd
> Party Java applets as they will have configurations pointing to old
> installation, the Java Access Bridge as an example.
> 
> (2) Open a command window "Run as Administrator" and run
> "regedit.exe"--navigate to the Key
> HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft (for 64-bit Windows) and
> HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft (for both 32-bit AND 64-bit Windows) and
> delete it.  And while still in registry editor, also delete the JreMetrics
> Keys.
> 
> (3) Also delete the JavaSoft keys for each user account
> HKEY_CURRENT_USER\Software\JavaSoft, starting with the Administrator account.
> And then from a new regedit.exe session for each user
> 
> (4) Use Windows Explorer and navigate to the C:\Program Files\Java folder.
> Delete jre6. Delete jre7.  And, if on 64-bit Windows, navigate to C:\Program
> Files (x86)\Java. Delete jre6. Delete jre7.
> 
> (5) Check in the C:\Windows\System32 folder for java.exe, javaw.exe,
> javaws.exe--running the uninstallers should have removed them but if still
> present delete.
> 
> (6) All Java should be off the Windows sytem at this point. Search the registry
> for Java, and the Windows file system for java.exe if you'd like to be certain.
> 
> (7) Reboot!
> 
> Now locate and download for installation the "Windows Offline" Oracle JRE 1.7
> installers. 32-bit (and 64-bit if applicable). Use this Oracle provided link: 
> http://www.java.com/en/download/manual.jsp
> 
> (1) if on 64-bit windows, run the 64-bit JRE 1.7u5 installer.
> 
> (2) run the 32-bit JRE 1.7u5 installer.
> 
> (3) the 32-bit install should have placed 32-bit versions of Java into the
> C:\Windows\System32 folder. But it could also end up being the 64-bit version
> on 64-bit windows.  So you need to force use of the 32-bit Java. Delete the
> java.exe, javaw.exe, javaws.exe from the system32 folder--they are just copies
> and you'll be establishing a location for them on the Path variable.
> 
> (4) Create a system environment variable JAVA_HOME (by Java programming
> convention). Done either from Computer --> Properties --> Advanced system
> settings --> Environment Variables, in the System variables portion of the
> panel.  Or set directly in the registry in the
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
> key. Assign the path to the 32-bit Java installation to the JAVA_HOME variable,
> e.g. "C:\Program Files (x86)\Java\jre7".  Mind the spaces.
> 
> (5) from the Advanced system settings, or the Environment key in the registry
> edit the PATH variable to insert the value "%JAVA_HOME%\bin;"--after the
> %SystemRoot% entries.  Note: setting the JAVA_HOME variable does nothing by
> itself--it is the addition of JAVA_HOME\bin in the Path variable that is doing
> the correction.
> 
> (6) verify that the correct JRE will run by entering on the start menu or from
> command window '"%JAVA_HOME%\bin\java.exe" -version'
> 
> Now clear the LibreOffice configruation file for Java and allow it to be
> rebuilt.
> 
> (1) In each user account
> C:\Users\<userName>\AppData\Roaming\LibreOffice\3\User\Config there will be a
> configuration file "javasettings_Windows_x86.xml" simply delete it. It will be
> rebuilt with now correct Java Runtime Environment settings.  Adjust to
> C:\Documents and Settingon Windows XP
> 
> (2) Launch LibreOffice. Navigate to Tools --> Options --> Java, check the radio
> button to use a Java Runtime Environment. Should have no error, and should see
> just a single value offered. An Oracle Corp Vendor entry, Version 1.7.0_u5 (or
> the version just installed). And below a "Location" value showing the entry for
> the version just installed, e.g. C:\Program Files (x86)\Java\jre7.
> 
> Configuring this way will disrupt some of Oracles auto configruation for JRE
> use on 64-bit system--defaulting most to use 32-bit JRE. But for most users
> this is going to be more functional.




Amazing, this works. Please post it also everywhere else. Thanks.
Comment 24 Heinrichmeyer 2012-08-21 08:28:47 UTC
(In reply to comment #22)
> duplicate; defect in Oracle JRE 7 on Windows can be worked around
> by installing MSVC2010 redistributable:
> http://www.microsoft.com/en-us/download/details.aspx?id=8328
> 
> please _only_ re-open this in case installing the above
> does not fix the problem for you.
> 
> *** This bug has been marked as a duplicate of bug 50584 ***

thank you, this helped here and is much less work than following comment #15
Comment 25 V Stuart Foote 2012-08-21 15:10:01 UTC
(In reply to comment #24)
> (In reply to comment #22)
> > duplicate; defect in Oracle JRE 7 on Windows can be worked around
> > by installing MSVC2010 redistributable:
> > http://www.microsoft.com/en-us/download/details.aspx?id=8328
> > 
> > please _only_ re-open this in case installing the above
> > does not fix the problem for you.
> > 
> > *** This bug has been marked as a duplicate of bug 50584 ***
> 
> thank you, this helped here and is much less work than following comment #15

The cause is fully addressed in https://bugs.freedesktop.org/show_bug.cgi?id=50584#c2, where in comment #2 you'll see there are two ways to correct for the MSVC2010 (msvcr100.dll) not being globally registered.  

One is to install it globally to assure the JRE can call it when run. 

The other is the correctly "set PATH variable to include the JRE directory in which the msvcr100.dll is located"; as is performed by following steps of comment #15.

vsf
Comment 26 Shurtski 2012-09-07 18:17:00 UTC
LibreOffic.org 3.5.6.2 Windows Vista Home Premium 36 s.p.2

After updating to this version Java 7.x seems functional on preliminary tests. thank you for your service.