Bug Hunting Session
Bug 51620 - Windows: Toolbar look inconsistent, depends on docking place
Summary: Windows: Toolbar look inconsistent, depends on docking place
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Windows (All)
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard: (target:3.6.1.1)
Keywords:
: 52545 53453 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-07-01 08:27 UTC by vitriol
Modified: 2013-08-02 12:22 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Toolbars (77.40 KB, image/png)
2012-07-01 09:55 UTC, vitriol
Details
Comparison 3.5 old look/3.6 new look at top (103.14 KB, image/png)
2012-07-01 10:04 UTC, vitriol
Details
Toolbars have the new styling only if they're docked at the top (66.35 KB, image/png)
2012-07-22 02:06 UTC, Adolfo Jayme
Details
Mockup of desired look. (80.08 KB, image/png)
2012-07-30 10:05 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vitriol 2012-07-01 08:27:29 UTC
Version: 3.6 beta
SO: Win7

Under Win7 the new toolbars aspect is not consistent. If the toolbar is floating or anchored at bottom or side, is displayed with the old look, not with the new one.
Bottom is the default position for many contextual toolbars.
Comment 1 Rainer Bielefeld Retired 2012-07-01 09:41:16 UTC
I see some smaller problems with Server Installation of  "LibreOffice 3.6.0.0.beta2  German UI/Locale [Build-ID: f010139] on German WIN7 Home Premium (64bit) and toolbars:

1) Writer Table toolbar docked at the bottom destroys the tin border line 
   at the top of the toolbar area
2) Floating Toolbar still shows the "Customize" arrowdown diriangle icon in
   the toolbar header, but it does no longer work

But I can't find something common, and I currently do not know what "old look" might be. 

@Vitriol:
Can you help me with a screenshot or similar?
Comment 2 vitriol 2012-07-01 09:55:52 UTC
Created attachment 63671 [details]
Toolbars
Comment 3 vitriol 2012-07-01 09:56:28 UTC
> @Vitriol:
> Can you help me with a screenshot or similar?

See attached screenshot-
Comment 4 vitriol 2012-07-01 10:04:02 UTC
Created attachment 63673 [details]
Comparison 3.5 old look/3.6 new look at top
Comment 5 Rainer Bielefeld Retired 2012-07-01 10:43:13 UTC
Ah, I did not see the wood among all those trees ;-)

[Reproducible] with "LibreOffice  3.5.5.2  English UI/ German Locale  [Build-ID: 24b32b4-b87ec2e-85c8e98-87a4e20-9a1b8c1] on German WIN7 Home Premium (64bit) 

I really wonder what the current goal is. I prefer the old 3D look with dividing rules between the toolbars, for me that eases quick finding the desired icon. for my impression the new look contributes a big monotonous icons area instead of separate bars, I believe that is less ergonomic.
Comment 6 Adolfo Jayme 2012-07-22 02:06:58 UTC
Created attachment 64494 [details]
Toolbars have the new styling only if they're docked at the top
Comment 7 Stefan Knorr (astron) 2012-07-30 10:02:58 UTC
*** Bug 52545 has been marked as a duplicate of this bug. ***
Comment 8 Stefan Knorr (astron) 2012-07-30 10:05:41 UTC
Created attachment 64948 [details]
Mockup of desired look.

Mockup of the desired look.
Comment 9 Stefan Knorr (astron) 2012-07-30 10:07:23 UTC
Better name for the bug, assign to Kendy since he did the original changes to the toolbars (I hope that's okay).
Comment 10 vitriol 2012-08-13 18:57:34 UTC
*** Bug 53453 has been marked as a duplicate of this bug. ***
Comment 11 vitriol 2012-08-16 09:50:43 UTC
Seems fixed in version 3.6.1.1 test build.
Comment 12 Rainer Bielefeld Retired 2012-08-16 10:17:57 UTC
Yes, now looks consistent during several tests in WRITER and CALC  with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) 

@vitriol:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable3.6  LibreOffice version
Comment 13 Stefan Knorr (astron) 2012-08-16 13:06:13 UTC
Reopening this, as Kendy's fix doesn't yet completely fix toolbars docked to the sides (they now lack borders).

For reference, Kendy's partial fix is here:
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-6-1&id=53f23d99b0f5549ede0b5e868f884c7bce2e9746
Comment 14 vitriol 2012-08-16 13:51:37 UTC
Please, see also Bug 51624.
Comment 15 tommy27 2013-08-02 11:32:44 UTC
@vitriol
do you still see issues with 4.0.x or 4.1.x GUI?
if not, could we close this bug report?
Comment 16 vitriol 2013-08-02 12:22:49 UTC
It looks pretty consistent for me in version 4.1.x. Persona's themes work only for toolbars docked on the top, but is a different problem.
I'll mark it as WORKSFORME for now. Please, reopen if you see a problem that I don't see...