Bug 52115 - In Navigator, display hyperlinks in the order of their appearance in the document
Summary: In Navigator, display hyperlinks in the order of their appearance in the docu...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
: 99914 (view as bug list)
Depends on:
Blocks: Navigator
  Show dependency treegraph
 
Reported: 2012-07-15 11:15 UTC by narayanaras
Modified: 2019-03-20 17:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2012-07-15 11:15:43 UTC
The Navigator shows the hyperlinks in the order they were created in the document. This order is not useful at all: Why should we be concerned about WHEN they were created historically?

The list should be in the order of appearance in the document, just like how tables are listed in the Navigator panel.

Also see issue #52113, which makes the list of hyperlinks absolutely useless.
Comment 1 ydutrieux 2012-12-18 11:22:15 UTC
I confirm this on libo 4 Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Ubuntu 12.04 - 64bits

nb : I note this "bug" as "enhancement" because, this is a new feature that you request.
Comment 2 Stefan Knorr (astron) 2013-02-02 19:13:53 UTC
Setting this back to (minor) bug: current order makes no sense, the change would not create any additional UI, so not an enhancement really, imho.
Comment 3 Cor Nouws 2013-05-17 16:11:48 UTC
one never knows ..
Comment 4 Joel Madero 2014-02-27 22:55:08 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 5 Robinson Tryon (qubit) 2015-12-13 11:23:55 UTC Comment hidden (obsolete)
Comment 6 Nicolas Mailhot 2016-05-18 15:14:21 UTC
*** Bug 99914 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2017-05-22 13:38:50 UTC Comment hidden (obsolete)
Comment 8 Greg 2019-03-20 17:53:50 UTC
This is still a problem in version 6.1.4.2
Windows 7
Trying to manage hyperlinks in Navigator is a *real mess* because of this issue - especially if you have a lot of them.
Nicolas Mailhot and Bug #99914 (Which has been marked as Duplicate) explained the problem quite well too.