Bug Hunting Session
Bug 52555 - Protected form becomes editable after saving in DOC format
Summary: Protected form becomes editable after saving in DOC format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
: 93229 94431 (view as bug list)
Depends on:
Blocks: DOC-Forms DOC-Doc-Protection
  Show dependency treegraph
 
Reported: 2012-07-26 17:32 UTC by Greg
Modified: 2018-10-24 06:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Original Doc (823.00 KB, application/msword)
2012-07-26 17:32 UTC, Greg
Details
Saved doc showing "formtext" failures (743.00 KB, application/msword)
2012-07-26 17:32 UTC, Greg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2012-07-26 17:32:07 UTC
Created attachment 64748 [details]
Original Doc

See attached documents. Original has locked fields in the form, save as Doc format and then reopen. The fields are now full of "formtext" entries and the locked fields are lost.
Comment 1 Greg 2012-07-26 17:32:36 UTC
Created attachment 64749 [details]
Saved doc showing "formtext" failures
Comment 2 Greg 2012-07-26 17:44:56 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2015-01-05 17:51:38 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-01-22 17:04:59 UTC
Confirmed that after saving the protection is gone (I can type or delete in the form label text), but the FORMTEXT problem does not occur anymore.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 07e84cae983c08afdba03018413a19d01abb3006
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-19_06:15:38
Comment 5 QA Administrators 2016-02-21 08:35:48 UTC Comment hidden (obsolete)
Comment 6 Justin L 2017-02-03 09:22:33 UTC
reducing from critical to major, since the form is no longer "trashed", but is simply editable after round-tripping.  (Now matches similar severity of the related .docx bug.)
Comment 7 Timur 2017-08-22 09:58:21 UTC
*** Bug 94431 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2017-08-22 10:07:14 UTC
*** Bug 93229 has been marked as a duplicate of this bug. ***
Comment 9 Justin L 2018-10-11 07:00:34 UTC
http://cgit.freedesktop.org/libreoffice/core/commit/?id=9943f37e8a80f2c4df6d58da4c50f3e7f3d6f3ce

related tdf#120225 ww8export: save PROTECT_FORM

It will be available in 6.2.0, compliments of bug 120225.