Bug Hunting Session
Bug 94431 - FILESAVE: DOC/DOCX/RTF - Write-protected lost when saving
Summary: FILESAVE: DOC/DOCX/RTF - Write-protected lost when saving
Status: RESOLVED DUPLICATE of bug 52555
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx, filter:rtf
Depends on:
Blocks: RTF DOCX DOC
  Show dependency treegraph
 
Reported: 2015-09-22 08:01 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-08-22 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-22 08:01:34 UTC
Steps:
1) Open attachment 117736 [details]
2) Notice all content is read-only accept for the gray colored fields in the table
3) Save as a new file and reopen
4) All text is now editable

This doesnt happen when saving to ODT.

Version: 5.1.0.0.alpha1+
Build ID: 1e67e94f1a308ca60d4934e9fe9d5c048225ebe8
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-09-21_07:28:58
Locale: en-US (en_US.UTF-8)
Comment 1 raal 2015-09-22 10:07:39 UTC
I can confirm with LO 5.0.1.2, win7
Comment 2 Jacques Guilleron 2015-09-22 10:11:01 UTC
Hi Yousuf,

Except for odt, I reproduce write protection losing with 
LO  5.1.0.0.alpha1+ Build ID: d417059dae303685de7aa0f4b1c192ffcf5304d5
TinderBox: Win-x86@39, Branch:master, Time: 2015-09-05_09:23:01
Locale: fr-FR (fr_FR)
& Windows 7 Home Premium
and LO 3.5.3.2 Version ID : 235ab8a-3802056-4a8fed3-2d66ea8-e241b80
so, probably inherited from OOo.
Comment 3 QA Administrators 2016-11-08 10:41:30 UTC Comment hidden (obsolete)
Comment 4 Timur 2017-08-22 09:58:21 UTC
5.1.0 as reported

5.2.7: 
DOC as reported
DOCX OK
RTF as reported

5.4.0
DOC as reported
DOCX OK
RTF as reported

6.0+:
DOC as reported
DOCX write-protected text OK, but empty forms lost; only forms with content OK
RTF as reported

DOC behavior is a duplicate of Bug 52555 and I'll mark so. 
Bug 93229, where attachment 117736 [details] originates from, is also a duplicate.
I'll check and report DOCX separately.

*** This bug has been marked as a duplicate of bug 52555 ***