Download it now!
Bug 53030 - Calc deletes current sheet, not right-clicked on sheet when trying to delete opposite directionality sheets
Summary: Calc deletes current sheet, not right-clicked on sheet when trying to delete ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL mab3.6
  Show dependency treegraph
 
Reported: 2012-08-01 09:26 UTC by Dotan Cohen
Modified: 2013-05-22 16:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
testdoc with two sheets (7.23 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-11-10 15:15 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2012-08-01 09:26:37 UTC
When right-clicking on a sheet in Calc and selecting Delete Sheet the currently-viewed sheet is deleted, not the sheet that was right-clicked on.
Comment 1 vitriol 2012-08-01 09:42:19 UTC
Not reproducible for me. If I right click on a unselected sheet, the sheet clicked become selected.
OS?
Comment 2 Dotan Cohen 2012-08-01 11:19:51 UTC
Kubuntu Linux.

Perhaps this is an issue with the fact that my locale is set to Hebrew, as when the sheet is deleted I do see that the selected sheet "jumps" to the clicked sheet and back, and then the sheet indicator switches sides.

I am sorry that I do not have an LTR environment to triage in. Try this:

0) Set Calc as RTL by default: UI: English, Locale: Hebrew, Default
languages for documents: Western: English, CTL: Hebrew

1) Open Calc (Note that the default directionality is RTL)

2) Change sheet to LTR: Format -> Sheet -> Uncheck RTL

3) Delete another sheet by right-clicking the sheet's tab and selecting Delete Sheet

Thanks.
Comment 3 Lior Kaplan 2012-11-10 15:14:57 UTC
Reproducible with 3.6.3, adding to bug 43808 (rtl-meta).

Steps:
1. Create spreadsheet with two sheets, one LTR and one RTL.
2. Try to delete the other sheet.
3. Notice the deleted sheet is the current one (easily noticable due to the different sheet directionality).

The bugs only occurs when the two sheet have opposite directionality. This happens regard less to the UI language/directionality.
Comment 4 Lior Kaplan 2012-11-10 15:15:44 UTC
Created attachment 69864 [details]
testdoc with two sheets
Comment 5 Issa Alkurtass 2012-12-24 10:42:56 UTC
Seems like the bug only happens when all the sheets are blank, can anyone confirm this?
Comment 6 Lior Kaplan 2012-12-24 12:19:50 UTC
Can't confirm this. I took the testdoc above, put some values in a few cells are followed the instruction in comment 3. I could reproduce the problem.
Comment 7 Lior Kaplan 2013-03-14 22:05:46 UTC
Move from mab4.0 to mab3.6 at Michael's request (see https://bugs.freedesktop.org/show_bug.cgi?id=54157#c126)
Comment 8 Michael Meeks 2013-03-27 09:51:10 UTC
Annoyingly I couldn't reproduce this in 4.0.1.1 - which is odd - either with or without data in the sheet (just loading Lior's nice test doc); though clearly there is quite some fun in the UI as/when it switches sheet.
Comment 9 Lior Kaplan 2013-03-31 06:36:30 UTC
Reproducible with 4.0.0.3, but not with 4.0.1.2. 

Would be great to know which commit "accidentally" fixed this, guessing something that changed the focus when right clicking on a tab.
Comment 10 Lior Kaplan 2013-05-22 16:58:31 UTC
Verified on a build from master (4.1 branch point).