Download it now!
Bug 54156 - EDITING: unreliable data overwriting Libo clipboard <-> WIN clipboard
Summary: EDITING: unreliable data overwriting Libo clipboard <-> WIN clipboard
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-28 11:45 UTC by Albin
Modified: 2014-02-02 02:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albin 2012-08-28 11:45:09 UTC
Problem description: 
Paste doesn't insert current content of the Windows cliboard but instead the old content copied in LibO.
 
Steps to reproduce:
1. Copy something in Writer, paste in same document, OK
2. Copy from other program (text), paste into Writer. The content from the previous paste gets inserted instead. 
3. Workaround: Copy what you want, paste into Wordpad, select and copy again. Now it works to paste into Writer.

This doesn't happen all the time. Sometimes the expexted content get pasted. When it works, the little Paste buttom flashes briefly in Writer when the Copy is made in the other program.
 
Bug 113171 at
https://issues.apache.org/ooo/show_bug.cgi?id=113171 
describes the behavior also.

The same thing happened in LibO 3.5.5.


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Rainer Bielefeld Retired 2012-09-28 04:31:23 UTC
Sometimes [Reproducible] with  "LibreOffice 3.6.2.2 rc  German UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit)

Unfortunately it seems very difficult to reproduce that problem. Some days I see that problem rather often, other days absolutely not. Today in the morning I did more or less 100 copy paste ad reproduced the problem exactly 3 times. If you do not not use "MS ClipBook Viewer" (like me) it's difficult to say whether it's a LibO bug of simply a mishap (wrong key ...). 

I am pretty sure that I already observed the problem with OOo 3.1.1, and also AOOo Bug is older than LibO, so problem seems inherited from OOo.

Currently seems only observed with WIN?

@Albin:
What do you want to tell with "When it works"? " ... to reproduce the bug" or "... to paste the correct contents"?
What is "the little Paste buttom"? The "paste" icon in the Standard Toolbar?
Comment 2 Albin 2012-09-28 13:08:28 UTC
I mean: when it works, the expected contents get pasted in Writer after the copy has been made in the other program.

Yes, the paste icon in the standard toolbar in Writer.

It's not 'wrong key...' I can paste the expected contents into other programs (after i tried, and failed, the Writer paste).

/Albin
Comment 3 Jens Bernhardt 2012-11-15 13:08:01 UTC
I can confirm that the bug is there and very real for the LibreOffice versions 3.5.7, 3.6.1, 3.6.2 and 3.6.3 .

I can't say I saw it in earlier versions; 3.5.2 for instance seemed fine.

The wordpad-trick doesn't work properly either.

My tests further show:
- Clearing / Emptying the system clipboard ( windows ) does have no effect.
- Copy&Paste within LibeOffice, even between documents, works fine.
- If using STRG+SHIFT+V the named source is the LibreOffice document last copied from.
- Closing said named source still keeps the selected content untouched.

Possible problem:
While it probably is not the source of the problem, the effect is that the system clipboard is being ignored; to copy content into the system clipboard is not priorized / does not reset the LibreOffice internal clipboard solution.

Possible hotfix:
One might consider adding a "insert from system clipboard"-option into the insert dialog of STRG+SHIFT+V .
Comment 4 Jens Bernhardt 2013-01-18 08:31:58 UTC
The problem continues with LibreOffice Version 3.6.4.3 !

Further test results/details:
- The problem occurs for all tested LibreOffice-versions on my "Windows 7 Prof. 64bit SP1", "Core i7-2670QM", "ATI Radeon HD 6900M", "8GB RAM".
- My older "Windows XP Prof. SP3", "Pentium M 2.1GHz", "ATI Radeon Mobility X700", "2GB RAM" works fine albeit using pretty much the same software (+versions).
- The problem occurs whether pasting everything as text only or not.
- The effect never shows right from the start.

Test-Conditions (both systems):
- There usually always is one Calc-Document and at least are 3 Writer documents opened.
- Other software, latest versions each, active during those tests: Firefox, Chrome, IE7/IE9, Skype, Text-Editor, Pegasus EMail Client, ActiveState Komodo Edit 6/7.

I don't know which of these conditions must be met or if any of them even are relevant; they simply describe my common everyday office usage during which the problem keeps popping up.

The by far greatest differences between those two test environments are: "Windows XP" -> "Windows 7" and 32bit -> 64bit.
Any chance this has to do with it ?
Comment 5 Rainer Bielefeld Retired 2013-01-18 08:43:30 UTC
Related to "Bug 56070 - EDITING: Copy / Paste only pastes plain text contents", a similar tricky one ...  ?
Comment 6 bfoman (inactive) 2013-05-21 08:50:56 UTC
@Jens Bernhardt: as you can reproduce - is this still an issue in the latest stable release (4.0.x)?
Comment 7 QA Administrators 2013-12-22 21:58:37 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 8 QA Administrators 2014-02-02 02:00:40 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO