Download it now!
Bug 56070 - EDITING: Copy / Paste only pastes plain text contents
Summary: EDITING: Copy / Paste only pastes plain text contents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.3.1 rc
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 07:13 UTC by Rainer Bielefeld Retired
Modified: 2013-03-20 05:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-10-17 07:13:17 UTC
With  "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit) I currently observe very often that when I want to copy / paste formatted text contents only plain text will be pasted. Reason seems to be that Copy (<by control+c> only brings the plain text information to the internal clipboard, not the additional formatting info.

Unfortunately I currently do not know how to make that reproducible, sometimes it works, sometimes it does not work. I will do further research. 

Might be related to "Bug 56068 - EDITING: Paste Special for copy of cell with formula unavailable, only plain text pasted".

Anybody who can confirm that problem (and may be has a solution how to make that reproducible)?
Comment 1 Michael Meeks 2012-12-06 12:27:04 UTC
An un-confirmed MAB ? unusual ! ;-) it would be really nice to have a concrete reproduction case before we make it a MAB.

Having said that Miklos - you're just re-hashed the RTF cut/paste code - I wonder if this might have been tackled ? and bug#56068 with it ?
Comment 2 Rainer Bielefeld Retired 2012-12-06 12:46:01 UTC
(In reply to comment #1)
yeah! I still suffer from this problem several times a week, and I still have no idea how to make that reproducible.
And indeed, simply the low resonance of other users shows that this one does not affect many users and MAB is not approptiate.
Comment 3 Jorendc 2013-03-19 22:30:57 UTC
(In reply to comment #2)
> And indeed, simply the low resonance of other users shows that this one does
> not affect many users and MAB is not approptiate.

Therefore I remove this from the MAB3.6 for now.

@Rainer: this bug still appears now and then with 4.0.x for example?

Kind regards,
Joren

PS: I'm sorry for the noise if I'm not right and shouldn't remove this from the mab3.6
Comment 4 Rainer Bielefeld Retired 2013-03-20 05:56:50 UTC
(In reply to comment #3)
I do not use LibO 4 for my daily work, so I can't tell.
Also with 3.6 the problem seems to have vanished, I think I did not see the problem for several weeks.

So WFM for now.