Bug 55236 - FILESAVE: Use previously selected settings, or own set of default values, when exporting a CSV file
Summary: FILESAVE: Use previously selected settings, or own set of default values, whe...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
: 87238 98727 105717 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-23 11:08 UTC by Jussi Hukkanen
Modified: 2017-04-12 08:59 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jussi Hukkanen 2012-09-23 11:08:32 UTC
Problem description:

When a spreadsheet document is saved in CSV format, the character set (encoding) of the file defaults to UTF-8 in Linux. The problem is that I cannot find a way to change the default. If I need a different character set, such as ISO-8859-1 for Windows compatibility, I have to select it from the drop-down list every time I save an ODS file as CSV.


Steps to reproduce:

1. Open an .ods file in Calc.
2. Save the file in Text (.csv) file format.


Current behavior:

The dialog with options for text file exporting always offers UTF-8 as the character set. This default is probably platform-specific.


Expected behavior:

I would like the dialog to remember the most recently used export options. If the defaults can be changed with a configuration option somewhere, please let me know.


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.7) Gecko/20100101 Firefox/10.0.7 Iceweasel/10.0.7
Comment 1 Sören 2012-12-30 12:48:56 UTC
I can confirm the behavior in
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
on Ubuntu 12.04 (x86)
Comment 2 Dries Feys 2014-10-13 12:57:48 UTC
confirmed on Windows 7, LO Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

The behaviour is opposite though : defaults to iso, where I'd love to see utf-8 and another separator character.
Comment 3 John Smith 2016-02-11 15:23:57 UTC
confirmed on Windows 7
Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737

All settings in export window should be remembered, not just encoding
Comment 4 FJB 2016-02-11 17:16:11 UTC
Confirmed on Mac OS X
Version: 5.1.0.3 (x86-64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737

All settings in the Export window should be remembered.
Comment 5 Timur 2016-03-17 16:43:27 UTC
*** Bug 98727 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2017-02-16 10:29:55 UTC
*** Bug 105717 has been marked as a duplicate of this bug. ***
Comment 7 Katarina Behrens (CIB) 2017-04-05 13:52:30 UTC
*** Bug 87238 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2017-04-06 22:09:29 UTC
Bernhard Widl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=781c026f98c848025f313940c94cbd4553259901

tdf#55236 save settings of CSV export dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 m.a.riosv 2017-04-09 00:28:57 UTC
Verified, thanks @Bernhard.
Version: 5.4.0.0.alpha0+
Build ID: 2f7b05988e6853ddac68b614e9d83e05af08bc0f
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-08_00:27:58
Locale: es-ES (es_ES); Calc: CL

Looks working properly for all options.
A reset defaults buttom could help less technical users.

Could it b backported?

I think should be resolved as fixed.
Comment 10 Buovjaga 2017-04-09 07:09:51 UTC
(In reply to m.a.riosv from comment #9)
> Verified, thanks @Bernhard.
> Version: 5.4.0.0.alpha0+
> Build ID: 2f7b05988e6853ddac68b614e9d83e05af08bc0f
> CPU threads: 4; OS: Windows 6.19; UI render: GL; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-04-08_00:27:58
> Locale: es-ES (es_ES); Calc: CL
> 
> Looks working properly for all options.
> A reset defaults buttom could help less technical users.
> 
> Could it b backported?
> 
> I think should be resolved as fixed.

FYI, Bernhard
Comment 11 Katarina Behrens (CIB) 2017-04-12 08:59:41 UTC
> Looks working properly for all options.
> A reset defaults buttom could help less technical users.

Let's make a follow-up enhancement ticket outta it

> Could it b backported?

Strictly speaking, this is a feature. It doesn't add a new UI or translatable strings, but it adds a handful of configuration variables. 

So I'd say no to backport, unless there's a real need, such as critical bug or regression that needs this patch to be resolved.