Bug 55361 - RTL: Animations that work letter-by-letter or word-by-word have it appear LTR during animation
Summary: RTL: Animations that work letter-by-letter or word-by-word have it appear LTR...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
: 73131 (view as bug list)
Depends on:
Blocks: RTL-CTL Custom-Animations
  Show dependency treegraph
 
Reported: 2012-09-26 15:44 UTC by safa alfulaij
Modified: 2018-11-05 14:36 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Example that demonstrates the problem (18.05 KB, application/vnd.oasis.opendocument.presentation)
2012-10-23 20:15 UTC, elicoten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description safa alfulaij 2012-09-26 15:44:51 UTC
while showing the preview of the animation...
I see that if I put the animation letter by letter it will be as LTR language...
see the video and you will know :)
http://www.mediafire.com/?5mkk5qlp38ag3al
sorry for the simple wrong language :p
Comment 1 elicoten 2012-10-23 20:15:47 UTC
Created attachment 68967 [details]
Example that demonstrates the problem

Same problem on Windows with LibreOffice 3.6.1 and Ubuntu LibreOffice 3.5.4.2 - RTL text is animated from the wrong end, giving the absurd effect shown in the video.
Comment 2 elicoten 2012-10-23 20:17:31 UTC
To clarify the problem, RTL text is reversed before being animated. Then once the animation is finished the text is again reversed letter by letter until it shows correctly again.
Comment 3 safa alfulaij 2012-12-09 13:29:07 UTC
(In reply to comment #2)
> To clarify the problem, RTL text is reversed before being animated. Then
> once the animation is finished the text is again reversed letter by letter
> until it shows correctly again.

OK
sorry for my little informations :P

is this bug has been solved ?
Comment 4 ign_christian 2013-05-19 03:21:55 UTC
Hi safa & elicoten

Please see Bug 56403 & Bug 46186. Related to that bug(s)?
Comment 5 Lior Kaplan 2013-05-19 08:48:36 UTC
I don't think they're related.
Comment 6 QA Administrators 2015-03-16 23:47:24 UTC Comment hidden (obsolete)
Comment 7 Lior Kaplan 2015-03-20 09:16:37 UTC
Verified in 4.3.3.2.
Comment 8 tommy27 2016-04-16 07:24:42 UTC Comment hidden (obsolete)
Comment 9 Lior Kaplan 2017-08-08 20:42:42 UTC
Verified on LibO 5.4.0.3 (Debian testing, 64bit)
Comment 10 Lior Kaplan 2017-10-12 11:00:06 UTC
Demonstrated in LibOCon 2017.
Comment 11 Yousuf Philips (jay) (retired) 2017-10-20 11:45:31 UTC
Happens in arabic as well.

Maxim, Thorsten: any thoughts?
Comment 12 Omer Zak 2017-11-02 08:10:48 UTC
Still happens in:

Version: 5.4.2.2.0+
Build ID: 1:5.4.2-3~bpo9+1
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group

OS: Debian 64bit Stretch (Debian 9.2, with some backported packages)
Comment 13 Omer Zak 2018-09-17 16:55:10 UTC
The English text animation is displayed just fine.

Then, the Hebrew text animation.
It does not look OK.
Few copies of the Hebrew text are displayed overlapping each other. Each copy is shifted a bit relative to the previous copy.
After finishing to diminish the ellipse, copies of the Hebrew text are removed over time and at end one copy is displayed - and it is displayed OK.

Tested using remote login configuration:
From computer A running Debian Stretch, I did ssh -X into another computer running the following.

6.1.1.1
מזהה הבנייה: 1:6.1.1~rc1-2~bpo9+1
תהליכי משנה במעבד: 8; מערכת הפעלה: Linux 4.16; עיבוד מנשק: בררת מחדל; VCL: gtk2; 
מיקום: en-US (en_US.UTF-8); Calc: group threaded

running under Debian Stretch:
$ uname -a
Linux c5 4.16.0-0.bpo.2-amd64 #1 SMP Debian 4.16.16-2~bpo9+1 (2018-06-26) x86_64 GNU/Linux
Comment 14 Omer Zak 2018-09-17 16:55:29 UTC Comment hidden (obsolete)
Comment 15 Mark Hung 2018-10-02 13:47:36 UTC
Some of findings here, for anyone interested:


I traced a little bit months ago, starting from keyword like:
TextAnimationType::BY_PARAGRAPH
TextAnimationType::BY_WORD
TextAnimationType::BY_LETTER

in slideshow module. It turned out I saw something suspicious in cppcanvas

https://cgit.freedesktop.org/libreoffice/core/tree/cppcanvas/source/mtfrenderer/textaction.cxx#n294

The comment said.

// TODO(F3): It currently seems that for RTL text, the
                // DX offsets are nevertheless increasing in logical
                // text order (I'd expect they are decreasing,
                // mimicking the fact that the text is output
                // right-to-left). This breaks text effects for ALL
                // RTL languages.

It is worth deeper investigation.
Comment 16 Commit Notification 2018-10-08 23:29:28 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=800c60524d25dfde71240fe3c1533e17f6749daa

tdf#55361 adjust leftmost position for RTL text while animation.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-10-08 23:29:37 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d9ad59da50c1172fe98f94370221c9c1b688200a

tdf#55361 fix result of showing RTL text in the animation.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Usama 2018-10-12 12:23:37 UTC
I can confirm the animations seems to be working fine for RTL languages.

Version: 6.2.0.0.alpha0+
Build ID: 144da6d5079bcd435e6637cb5cf95305f3ec1306
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-10-12_02:13:01
Locale: tr-TR (tr_TR.UTF-8); Calc: threaded

I think the fix is a huge improvement that allowed using text effect for large group of people.

Thank you
Comment 19 Mark Hung 2018-11-05 14:36:18 UTC
*** Bug 73131 has been marked as a duplicate of this bug. ***